-   Debian (
-   -   Sound notification when email is recieved (gnome) (

radiodee1 05-29-2009 05:45 AM

Sound notification when email is recieved (gnome)
I use sqeeze and a little bit of sid. I also use evolution and gnome. I was going through different preferences and I found that if you go to "System->Preferences->Sound" there is a tab that has options for different alerts and sound effects that you can have your system play when certain actions take place. I want to make it so that a sound plays whenever I receive a new email, BUT on my system everything in this tab of the "Sounds Preferences" dialog box is grayed out. I cannot figure out how to get those options un-grayed.

I can clearly see (in the grayed out material) that there is an option for getting notification when mail is received. How do I do this?

When I click the "help" button on the dialog I get a help window that tells me, among other things, that:


You must select the Enable sound server startup option, and the Sounds for events option before you can access the Sound Events tabbed section.
How do I do that? They also mention a "General" tab, which I cannot even find. The only tabs I have are "Devices" and "Sounds". Has anyone else had this experience or anything like it? Thanks.

farslayer 05-29-2009 02:10 PM

I think you need to install esound and gnome-audio to have desktop event sounds..

aptitude update
aptitude install esound gnome-audio



*Select "Enable sound server startup" of the control board "Sound Preference" of Gnome.
Applications ––> Systeme ––> Configuration ––> Gnome ––> Sound Preference

radiodee1 05-30-2009 05:42 AM


Originally Posted by farslayer (Post 3556890)
I think you need to install esound and gnome-audio to have desktop event sounds..

aptitude update
aptitude install esound gnome-audio

Unfortunately this didn't work, especially the part later in the post where it says "Applications > Systeme > Configuration > Gnome > Sound Preference". This just doesn't seem to exist on my system.

I googled a little and found someone tried to use gconf to change the keys directly. I went to the key at "/apps/evolution/eplugin/mail-notification" and entered a value in the spot marked "sound-file". I used "/usr/share/sounds/email.wav" but no sound played when I received an email. I find navigating around gconf to be difficult and so I might have missed something. Maybe my sound setup has the volume too low or something dumb like that. I'll try more stuff and post back later, but if anybody has any more suggestions I'd be pleased to hear them. Thanks anyway farslayer.

farslayer 05-30-2009 06:45 PM

was worth a shot. I've never bothered to work on enabling desktop notification sounds on my system, but I was pretty sure it's esd related.

When you find the solution, please come back and share. It would be greatly appreciated. (and archived for future searches) :)

radiodee1 05-31-2009 07:32 AM

I'm using gnome 2.24. This is what my "System->Preferences->Sound" dialog box looks like:

The only difference is that on my computer, under "Sound Theme", where it should say "default", there is nothing. Also, as I said before, the entire contents of that tab (the "Sounds" tab) is grayed out. This leads me to believe I don't have a sound theme installed, but I do have installed the packages gnome-audio and esound, and unfortunately I can't see any packages in the debian archives that have in them sound themes. I'm sort of stuck. If anyone has any ideas I'd love to hear them.

radiodee1 06-01-2009 02:59 PM

I got it to work. I installed pulseaudio-esound-compat, as I use pulseaudio (I guess I didn't even know) and restarted and it worked. The sound plays that I specified in gconf. The "Sounds" tab of "System->Preferences->Sound" is still grayed out.

farslayer 06-01-2009 03:48 PM

Interesting. pulseaudio is not installed on my Lenny system, but then again this system is an upgrade from Etch, and previously Sarge.

I'll have to look at a Fresh Lenny install to see if they are now using pulseaudio by default.

Thanks for the update !!

radiodee1 06-01-2009 04:57 PM

It's testing, and I'm not sure that it's part of the "official" testing at all. I may have installed pulseaudio somewhere along the way for some reason or another that I cannot remember.

radiodee1 06-10-2009 12:52 PM

I revisited this thing with the sounds because I wanted to remove pulseaudio and have it still work. I removed all pulseaudio packages and the email notification sounds stopped. I was back where I started, so I googled more and found this on a Ubuntu launchpad site:

Gnome 2.24 uses a different framework for playing sound events called libcanberra. Libcanberra will not play any sound themes unless it can find the freedesktop sound theme to fall back on, in the event that a sound for a particular event cannot be found.

Ubuntu currently doesn't have this theme in a stand-alone package in the archive. It has been packaged for Debian, however it has been rejected for licensing reasons.
This explains why the "sounds" tab on the gnome-sound-properties dialog box is greyed out. Reading further, someone explains how to get the sounds to work using a '' theme. First download the file from here:

Then the author did this:

extract to /usr/share/sounds and then could get some of the sounds working.
I tried this and it worked for me. Now my sound notification works under alsa, and the "sounds" tab is no longer grayed out. This is the page that has all the original info on it:

EDIT: I'm wrong again. In fact installing those files un-grays the "sounds" dialog, but it doesn't make the sounds audible. I'm gonna have to do more messing with these sounds.

farslayer 06-10-2009 02:56 PM

Still interesting.. Thanks for the update. I'm curious now to see your final solution.

All times are GMT -5. The time now is 01:10 AM.