LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-16-2005, 01:11 PM   #1
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Rep: Reputation: 30
sound can only play 1 stream at a time


So i'm using alsa, technically i have esound installed, but i have no esd. I can only have one stream of sound output at a time. For example, when my xmms song stops playing, kde will then do all its sound alerts. Pretty annoying. Anyone know how to solve this? I'm using alsa and have an nforce2 chipset with nvidia drivers installed.
 
Old 01-16-2005, 02:32 PM   #2
pevelius
Member
 
Registered: Mar 2004
Location: Tampere, Finland
Distribution: Debian, Familiar, OS X
Posts: 145

Rep: Reputation: 16
you need to configure dmix, i believe:
http://alsa.opensrc.org/index.php?page=DmixPlugin
i havenīt, so i cannot help
 
Old 01-17-2005, 09:09 AM   #3
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Original Poster
Rep: Reputation: 30
i'm having problems getting it to work. I have no ~/.asoundrc, so it's annoying and creating one with a pcm.dmix plugin didn't do anything either. Anyone got this working with the nforce2 drivers? Thanks.
 
Old 01-19-2005, 04:10 AM   #4
kostian
Member
 
Registered: Jul 2004
Location: LT
Posts: 150

Rep: Reputation: 15
Quote:
Originally posted by bobbens
i'm having problems getting it to work. I have no ~/.asoundrc, so it's annoying and creating one with a pcm.dmix plugin didn't do anything either. Anyone got this working with the nforce2 drivers? Thanks.
Hi.
heres mine:
Code:
pcm.!default {
    type plug
    slave.pcm "dmixer"
}
 
pcm.dsp0 {
    type plug
    slave.pcm "dmixer"
}
 
pcm.dmixer  {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 32768
        #periods 128
        #rate 44100
    }
    bindings {
        0 0
        1 1
    }
}
 
ctl.mixer0 {
    type hw
    card 0
}
and for xmms/bmp select "default" for audio device in alsa plugin configuration and turn off mmap mode. in mplayer.conf ao=alsa.
 
Old 01-19-2005, 07:14 AM   #5
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Original Poster
Rep: Reputation: 30
thanks, let's see how it works next reboot :P
 
Old 01-19-2005, 03:30 PM   #6
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
NEVER REBOOT LINUX!
 
Old 01-19-2005, 03:40 PM   #7
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Original Poster
Rep: Reputation: 30
But i like rebooting, makes me feel all powerful and mighty. :P
Nah, just that my computer needs some rest every so often (it seems to be happier after being off for 1 hour or so).
 
Old 01-19-2005, 04:08 PM   #8
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
okay

If you configure alsa properly the asoundrc becomes active instantly. Stop and start a sound to check if it works. Dmix is confusing, but definitely the way to go.
 
Old 01-20-2005, 10:52 AM   #9
bobbens
Member
 
Registered: Sep 2004
Location: Barcelona
Distribution: Debian, FreeBSD, Gentoo
Posts: 586

Original Poster
Rep: Reputation: 30
i love you guys, i got sound to work from multiple sources. Any tips on configuring all programs to use this? I remember reading somewhere that for xmms you had to disable nmap mode or something like that, did that. For vlc, you just have to switch output to alsa. Is there someway to default output to alsa for all apps? Using kde, just curious. And how would i configure kde to use this? Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot play sound from different sources at the same time with ALSA mrosati Linux - Software 2 09-21-2005 04:04 PM
Can't play more than one sound at a time boyakasha Linux - Software 3 04-18-2005 05:40 PM
Alsa drivers cannot play more than one sound at a time rsnic Linux - Hardware 5 06-26-2003 05:40 AM
Alsa drivers cannot play mor than one sound at a time rsnic Linux - Distributions 0 06-24-2003 10:36 PM
unable to play more than one sound file at a time. wonka_vision Linux - Hardware 2 06-10-2003 06:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration