-   Debian (
-   -   sid samba error (

SteveSch 08-09-2010 08:17 AM

sid samba error
Hello all,

My computer was getting slow. I know I had a problem with flash for sure. I was thinking it was because I haven't done a dist-upgrade in a while and there were a lot of updates.

So last night I backed up all my important data and did a dist-upgrade. Well now IceWM no longer shows and it just boots to command line. Not the first time I've done that.

Anyway, when I run 'apt-get -f install' I get hung up with errors on Samba.

Errors were encountered : /var/cache/XXX...samba_2%3a3.4.8~dfsg-2_i386.deb

I tried to remove samba but was unable to and 'dpkg -r --force-all samba' returns a processing error.

The error states that it can't locate File/ in @INC.

I am sure someone with more knowledge could easily salvage this. Funny, I have been running sid for 5-7 years now and it has given me very few problems. And pretty much every problem has originated from my hand. Typing the wrong thing, accepting the wrong option, or accidentally deleting the wrong folder.

Any help will be appreciated.

Thanks in advance,

David the H. 08-10-2010 05:19 PM

Does the error say what it wants to do with

I've had times when an uninstall script would fail because it couldn't find a file it wanted to delete. Simply creating a dummy file in that location for it to remove generally allowed it to continue on its way.

Edit: apt-file reports three packages that contain File/

libfile-fu-perl: /usr/share/perl5/File/Fu/File/
libfile-temp-perl: /usr/share/perl5/File/
perl-modules: /usr/share/perl/5.10.1/File/

If you can figure out which one, you might see if you can get it installed. It's possible you may have to download the package separately and install it with dpkg.

SteveSch 08-11-2010 04:04 PM

Thanks David the H.

I just reinstalled and used Lenny. I needed to get back to work. LOL

I was smart enough that when I installed the first time I kept / and /home separate. Made it very easy to reinstall without losing any data at all. Even my WinXP in VirtualBox, and all of the software, still works.

Thanks for the answer though.


All times are GMT -5. The time now is 05:02 PM.