LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-06-2007, 03:14 PM   #1
Indiestory
Member
 
Registered: Aug 2006
Location: Aberdeen, Scotland
Distribution: OpenBSD
Posts: 164
Blog Entries: 1

Rep: Reputation: 30
Setting up sound etch


Okay, i have a netinstall of etch, downloaded the alsa packages, did an alsaconf it found my sound card, it set it up. Amixer seemed to crash during the setup though, and i checked neither alsamixer or amixer can find a default sound device, dont seem to have /dev/dsp(thats normally the sound card right?)

sorry that may have seemed quite rash. lsmod contains this
Code:
Module                  Size  Used by
snd_powermac           48188  0 
snd_pcm_oss            52032  0 
snd_mixer_oss          20704  1 snd_pcm_oss
snd_pcm                91396  2 snd_powermac,snd_pcm_oss
snd_timer              26500  1 snd_pcm
snd                    65908  5 snd_powermac,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11204  1 snd
snd_page_alloc         11304  1 snd_pcm
I really doubt I could just create /dev/dsp, but any working solution is good for me
 
Old 03-07-2007, 01:21 PM   #2
mpapet
Member
 
Registered: Nov 2003
Location: Los Angeles
Distribution: debian
Posts: 547

Rep: Reputation: 72
su alsaconf

As long as you know what your sound card is (lspci should give you the info) do alsaconf as root and follow the prompts.
 
Old 03-08-2007, 04:51 AM   #3
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
I had no sound with my Soundblaster Audigy when I first installed Etch, found this informative web-page below. For me, all I had to do was unmute amixer as it apparently is mutted upon fresh install some times with these two commands:

$ amixer set Master 100% unmute

$ amixer set PCM 100% unmute

Needless to say my Debian ROCKS with those %100 settings.

http://www.debiantutorials.org/content/view/161/200/
 
Old 03-08-2007, 09:36 AM   #4
Indiestory
Member
 
Registered: Aug 2006
Location: Aberdeen, Scotland
Distribution: OpenBSD
Posts: 164

Original Poster
Blog Entries: 1

Rep: Reputation: 30
I have just checked and my favourite piece of software has fixed it again. Pbbuttonsd, gives me every thing i need for the this laptop to work. Thanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound on Debian Etch eric_marsh Linux - General 7 02-10-2007 10:56 AM
Setting up Radeon 9600 in Etch irvken Linux - Hardware 3 02-09-2007 01:02 PM
no sound in etch unisol Debian 2 01-10-2007 09:06 AM
debian etch sound help snuffy115 Debian 1 12-30-2006 02:11 PM
Etch: no CD sound bazder Debian 3 06-17-2005 05:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration