LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-08-2004, 05:23 PM   #1
macondo
Senior Member
 
Registered: Jul 2003
Location: Central America
Distribution: Slackwre64-current Devuan
Posts: 1,034

Rep: Reputation: 62
Setting Nano to wrap at 72 cols, fails


I want nano to wrap at 72 cols, but i can't make it work.

man nanorc:

set fill n
Wrap lines at column number n. If n is 0 or less, the line length
will be the screen width less n. The default value is -8.

So, in my ~/.nanorc I got:

set fill 72
unset nowrap

I put the second one when the first line failed. What am i doing wrong?
Any clues?

thanks,
~
 
Old 11-09-2004, 07:33 AM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I hadn't noticed that before, but you appear to be right -- nano doesn't do wordwrap in my Debian box, either. Editing /etc/nanorc or creating ~/.nanorc doesn't seem to have any effect on wordwrapping (or the lack of it). I have no solution.

Maybe it's just better to use the right tool for the job and view files in wordwrap mode with vi (or mcview if you've got Midnight Commander) and edit them in nano (or mcedit).

Another thing, the nano documentation says that if you invoke nano using the "pico" command (/usr/bin/pico is actually just a symlink to /bin/nano), you are supposed to get nano in a "pico compatibility mode". I'm not sure if this actually works and I don't know how to test this. Does anyone know what's different when nano uses "pico compatibility mode"?

I suspect that the lack of wordwrap mode and the possible lack of pico compatibility mode in nano may be bugs. Second opinions, anyone?
 
Old 11-09-2004, 12:18 PM   #3
macondo
Senior Member
 
Registered: Jul 2003
Location: Central America
Distribution: Slackwre64-current Devuan
Posts: 1,034

Original Poster
Rep: Reputation: 62
I checked google, the IRC, the docs, and finally, the nano mailing lists, this problem was reported back in April of this year, it seems it hasn't been fixed, maybe i'll email the main developer, nano is light compared to vim, that's why i wanted it for writing. I removed gedit, in my quest for leaness and speed.

I use Pine, so i have Pico by itself, when i use it, it has the same problem, I configured Vim in my ~/.vimrc with:

:set tw=72

It works perfectly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Thunderbird text search wrap setting UKBMD Linux - Distributions 0 11-03-2005 02:13 AM
nano hostmark101 Linux - Newbie 8 08-12-2005 06:53 PM
About wrap around Nerox Programming 3 03-13-2005 12:13 PM
text mode resolution (changing rows and cols) jaylee Linux - General 3 06-22-2003 08:16 PM
Linux 7.2 install fails after setting partitions Michael Linux - Software 2 01-15-2002 08:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration