LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Debian (http://www.linuxquestions.org/questions/forumdisplay.php?f=26)
-   -   Setting Chrome as default web browser (http://www.linuxquestions.org/questions/showthread.php?t=4175445930)

theAdmiral 01-16-2013 04:24 PM

Setting Chrome as default web browser
 
I am using Gnome 2, with Debian 6.0.6.

I have been thumbing around different alternatives for web browsing utilities, i.e.--Iceweasel vs. Firefox vs. Chrome. I had been using Chrome for a long time, but for some reason thought Iceweasel or Firefox would be better. My reason had to do with Java. Also, I think my reason is that when I clicked on an hyperlink in my Thunderbird client, the client wouldn't open up that page in my browser. I still have that problem, but the Java problem is solved.

Now that I have a retrograde problem such that an hyperlink in Thunderbird will not open up a page in Chrome, I'd like to get that fixed. Chrome keeps telling me whenever I open up a new instance that I can select it as the default browser or to "Not ask again".

I have selected Chrome as the default in Preferences -> Preferred Applications. I have also tried selecting Chrome as the default in Chrome -> Settings -> Default Browser -> <button> "Set Chrome as default web browser". When I do that, though, the button acts like it is dead. It can be pressed, but no change takes effect. I have also tried the Chrome support forum and there is nothing on it there for Linux to speak of.

Has anybody out there had this problem for Chrome in Debian 6.0.6?

Please help.
Thanks in advance.

Peacedog 01-16-2013 06:45 PM

Hi theAdmiral, Have you tried this?

http://productforums.google.com/foru...me/zXH00hCliDE

Quote:

gbroonLevel 2
More message actions
3/23/11
Had this problem myself, not sure if you managed to fix iit but I found it was because /usr/share/applications/google-chrome.desktop didn't exist.

I fixed it by creating a link to the file in /opt where chrome is installed.

# ln -s /opt/google/chrome/google-chrome.desktop /usr/share/applications/google-chrome.desktop
Good luck. ;-)

jim_p 01-17-2013 01:26 AM

You can run (as root)
Code:

update-alternatives --config x-www-browser
and, assuming chrome is listed as a choise there, set it as the default web browser for your system.

theAdmiral 01-17-2013 10:35 AM

Quote:

Originally Posted by jim_p (Post 4871931)
You can run (as root)
Code:

update-alternatives --config x-www-browser
and, assuming chrome is listed as a choise there, set it as the default web browser for your system.

Thank you for your contribution, but I just tried this as you suggested and there was no effect.

jim_p 01-17-2013 11:33 PM

If you run
Code:

x-www-browser
in a terminal, which browser shows up? Please don't be epiphany :P

Plus, I think gnome has some option gnome-control-center that allows you to change what gnome uses as default web browser, mail client, terminal etc.

theAdmiral 01-19-2013 06:51 PM

If I run

Code:

$ x-www-browser
a fresh instance of Chrome pops open.

I have tried the Gnome Control Center approach, selecting Chrome as the default browser. In my Preferred Applications, the radio button for Open Link in New Tab is selected. The Command field lists

Quote:

/opt/google/chrome/google-chrome
I think. The tail of it is concealed. And it is shaded out. I cannot seem to get to it, if need be.

I also tried to run Gnome Control Center from the command line as superuser. And I got an error message. The error message was:

Quote:

root@debian:/home/john# gnome-control-center

(gnome-control-center:22208): Unique-DBus-WARNING **: Unable to open a connection to the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(gnome-control-center:22208): Unique-DBus-WARNING **: Unable to connect to the running instance, aborting.

odiseo77 01-19-2013 08:15 PM

Quote:

root@debian:/home/john# gnome-control-center
You're launching gnome-control-center as root; try launching it as your regular user. There should be a "Default applications" option somewhere where you can configure your default browser. BTW, I don't remember if, on Gnome2, it is in the control center, or under "System > Administration".

theAdmiral 01-19-2013 11:12 PM

Are you understanding my problem here?

My problem is that I try to click on an hyperlink in Thunderbird that would normally open up a new tab to that hyperlink's URL page, but the hyperlink acts like it is dead. I seem to think that we are going about this incorrectly. Wouldn't you agree?

Thanks.

jim_p 01-20-2013 12:06 AM

If you click on a url that is not inside a browser nor inside thunderbird, e.g in some instant messenger, does it open in chrome?
If yes, then you have to change the browser (or browser string) thunderbird uses to open up urls, because it may say "firefox %u" for instance. I have no idea where such setting may be located in thunderbird :(


All times are GMT -5. The time now is 10:21 PM.