LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-12-2017, 10:10 AM   #1
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Arch, KDE Neon, & ROSA
Posts: 2,976

Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
SD-CARD functionality on boot


So not too often I actually have issues with Debian I can't figure out. However, have one right now.

So have Debian Stretch on my laptop (Latitude E5250, "defiant" in my sig). EVerything works fine except the sd-card reader. I know this, and have known this for a long time. It's pretty easy to fix.

Code:
rmmod sdhci_pci sdhci_acpi
rmmod sdhci
modprobe sdhci debug_quirks2="0x10000"
modprobe sdhci_pci sdhci_acpi
and it works fine. So trying to set up /etc/modprobe.d/sdhci.conf so that it'll load correctly on boot (I leave a sd card in there because it came without the insert).

I've got the file created with
Code:
options sdhci debug_quirks2="0x10000"
yet upon boot, it acts like it's ignoring it, as the sd-card doesn't work. I can rmmod everything and then just modprobe them back, and it DOES work, so the file is correct, but doesn't work on bootup. I'm thinking maybe I'm missing something else that's necessary, but not sure what.

Thanks.
 
Old 06-12-2017, 02:18 PM   #2
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17
Posts: 5,744
Blog Entries: 20

Rep: Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801
Shot in the dark. Bios setting maybe?

Either that or /etc/default/grub needs to be told to see your .sh file and and then

Code:
sudo update-grub
afterwards.

Code:
harry@biker:~
$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=800x600

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
GRUB_INIT_TUNE="480 440 1"

GRUB_DISABLE_OS_PROBER=false
GRUB_BACKGROUND=/home/harry/Wallpaper/cheshire_cat.jpg
harry@biker:~
Like I said. A shot in the dark. Maybe make a .sh file and put in startups?

Last edited by rokytnji; 06-12-2017 at 02:19 PM.
 
Old 06-12-2017, 10:23 PM   #3
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Arch, KDE Neon, & ROSA
Posts: 2,976

Original Poster
Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
Hmmmm, good idea. Worth a shot!
 
Old 06-12-2017, 10:23 PM   #4
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Arch, KDE Neon, & ROSA
Posts: 2,976

Original Poster
Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
edit - double post.
 
Old 06-13-2017, 09:14 AM   #5
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17
Posts: 5,744
Blog Entries: 20

Rep: Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801Reputation: 2801
Just to explain a little better why I posted like I did.

I ran into your problem on a Easy Peasy Ubuntu install way back when. It was on a Acer Aspire One ZG5 SD slot. No boot options in bios for that slot. Acer never gave bios update for fixing that missing feature either. It was a hardware quirk for that netbook series then. SD card required a USB card reader adapter to boot from SD card.

It was not seen by Easy Peasy Kernel also after boot up. So I did a little kernel editing on the legacy grub kernel line in the /boot/grub/ folder. It was so long ago. I can't remember the exact syntax I used.

Long story short. The SD slot was seen by the file manager and mounted fine with that kernel edit.
But that edit. For whatever reason unknown to me. Heated up my internal wifi card till it would drop out of service.

So I admitted defeat. After days of trouble shooting it. Used a external USB wifi adapter. Turned off internal wifi card in bios. Rolled like that in Linux till I gave the Acer to my father-in-law after putting Windows XP back on it < wifes request > .
 
Old 06-14-2017, 10:02 PM   #6
Hungry ghost
Senior Member
 
Registered: Dec 2004
Posts: 1,222

Rep: Reputation: 666Reputation: 666Reputation: 666Reputation: 666Reputation: 666Reputation: 666
This may be some of a hack, but you could try creating a small script with those commands and tell systemd to run it at a specific stage of the boot process (more info here).
 
Old 06-14-2017, 10:51 PM   #7
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Arch, KDE Neon, & ROSA
Posts: 2,976

Original Poster
Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
So, it looks like it might have been a kernel issue. Got the upgrade from 4.9.03-2 to 4.9.03-3 today, and now when I boot the sd-card is read with just the /etc/sdhci.conf file like it should.

Last edited by Timothy Miller; 06-14-2017 at 10:52 PM.
 
1 members found this post helpful.
Old 07-22-2017, 07:09 PM   #8
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Arch, KDE Neon, & ROSA
Posts: 2,976

Original Poster
Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
Further update if anyone is searching for this issue, the 4.11 kernel in buster seems to have completely fixed the issue. I commented out the sdhci options to test, and sd-card is working exactly like it should. So looks like this is no longer an issue for Broadcom chipsets with the 4.11 kernel in Debian.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel upgrade from 2.2 to 2.6.8, lost network card/functionality MrCranky Linux - Kernel 3 04-14-2007 04:30 PM
Usb Boot Business Card Iso - Network Card - Kernel Module yogi4yu Debian 0 10-07-2006 06:10 AM
diagnosing usb card-reader non-functionality ender42 Ubuntu 1 05-06-2006 12:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration