LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   sata hdd not detected during install (https://www.linuxquestions.org/questions/debian-26/sata-hdd-not-detected-during-install-367291/)

nukeu666 09-26-2005 05:03 PM

sata hdd not detected during install
 
i was doing a net instal with stage1&2 on cd of debian and the install said it couldnt find any hdd's
i know they are sata...worked fine on fedora
any workaround?

Krugger 09-26-2005 05:47 PM

When the installation cd boot there is a part where it ask if you need to load any modules. You need to load something like sata or sata_uli and maybe other modules. You will see this if you install in expert mode.

nukeu666 09-27-2005 01:50 AM

hmm...i didnt get any screen asking for expert mode/additional modules
guess im stuck wtih fedora
thnx neway

raptorman 09-27-2005 04:27 AM

To install debian in expert mode, instead of hitting immediately enter to boot, first type expert26 (this will get you into the expert mode and install the 2.6 kernel, which has a better SATA support). If it still doesn't find any hard disks, disable SATA in your BIOS and chose IDE instead. After installing Debian, you can compile a new kernel (2.6.13.2), install it, and enable SATA again.

Ray_Kovecses 09-27-2005 11:57 AM

simply type............... linux26 ......... at boot

raptorman 09-27-2005 12:05 PM

Quote:

Originally posted by Ray_Kovecses
simply type............... linux26 ......... at boot
This won't install Debian in expert mode.

Ray_Kovecses 09-27-2005 12:40 PM

He didn't want to install debian in expert....he just wanted it to detect his sata

juggalo080 09-27-2005 01:08 PM

hey, I seem to be having the same problem. I just tried what was posted here and had no luck. It didn't seem to know an expert26, but I could type expert and get in. I am new to the linux world other than running red hat a couple of times. The system I am installing on is an Athlon 64 3700+, MSI mobo, and of course a SATA hd. I believe the install I have is with kernel 2.6.11. I also tried linux26 and that didn't do anything for me. I tried disabling the sata drive in the bios, I also tried setting it as ide and neither of these made a difference. Any suggestions would be appreciated.

Ray_Kovecses 09-27-2005 01:31 PM

not expert26 linux26................... it works trust me

raptorman 09-28-2005 03:23 AM

Quote:

Originally posted by Ray_Kovecses
not expert26 linux26................... it works trust me
You'd better start reading people their posts before replying.

I also tried linux26 and that didn't do anything for me.

It clearly didn't work for him :rolleyes:

Ray_Kovecses 09-28-2005 07:03 AM

What version of debian are you using

juggalo080 09-28-2005 11:21 AM

I believe I am using Sarge 3.1 is what it is called. Kernel 2.6.11

If you have a link for a better installer, post the link and I will give that one a try.

Thanks

Ray_Kovecses 09-28-2005 11:51 AM

Sorry I dont have a clue.. I too have sata drives that sarge 3.1 didnt detect. But the linux26 boot option worked for me.

I hope you find a fix

HappyTux 09-28-2005 02:14 PM

Quote:

Originally posted by juggalo080
I believe I am using Sarge 3.1 is what it is called. Kernel 2.6.11

If you have a link for a better installer, post the link and I will give that one a try.

Thanks

http://tinyplanet.ca/~lsorense/amd64 try the 2.6.12 version.

jayakrishnan 10-05-2005 04:40 AM

slack has support for sata , but the install says its still under testing so dunno to what extent it works


All times are GMT -5. The time now is 03:13 AM.