LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-30-2004, 01:44 AM   #1
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Rep: Reputation: 15
Sarge Installer Doesn't Prompt for Important Details


I'm having some major issues with Sarge!

I decided to install Sarge, as I wanted to use Gnome 2.6, as well as up-to-date apt-get packages, and figured that installing Sarge would be the best way to accomplish this. I was told that while Sarge is "testing," it is quite stable, and for a meaningless little testing server, it would work fine.

I downloaded the netinst CD (apparently I had done this only three days after Gnome 2.x was added to Sarge...I guess I got lucky!), and went about installing sarge. The installation went very well...I was very surprised that it detected everything, versus Wood's constant nagging. I got Sarge up and running in no time...

...there was just one problem. Sound. I could not get the sound to work, no matter what I did! It seemed to have the correct drivers...and I tried for hours to fix it.

I decided that perhaps, if I reinstalled Sarge, things might work better. Perhaps I had messed up in the installation, you know? I went about reinstalling Sarge...but strangely...I was not prompted for essentially anything, save a few small things. I wasn't asked about resolution, inetd vs. daemon...nothing! Even stranger, during the postgresql configuration, it said that the directory already existed!

I thought, "Hmm...maybe I didn't format correctly?"

Well, I reinstalled it, making sure that it formatted first. Same issue.

I used my old Woody CD to reformat. Same issue.

I did that again. Same issue.

I did that five more times. Same damn issue.

I created a partition that took up the entire disk, initialized that, and then deleted it. Same frickin' issue!

The next day, I tried installing it about two more times, before I realized that it was hopeless. No matter how much I reformatted, I had the same problem. My friend joked that my harddisk was write-protected!

I then decided to try Gentoo. Did that...was too complicated...gave up.

I decided to try Fedora. I figured that installing Fedora might accomplish two things: it might overwrite all the old stuff, and it might also help me figure out the sound issue.

Well, Fedora had sound. Lovely! I wrote down the details:

Vendor: Intel Corp.
Model: 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
Module: snd-intel8x0

(I have a Dell PowerEdge 400SC, if you're wondering)

I was very excited, and felt that now, if I installed Sarge again, it might work...

Once again, the same damn problem!

I mean, the computer works...but the resolution is all screwed up, because it never asked me about it. I'm sure that Postgresql doesn't work too well, either. I'm sure that it's very confused about inetd vs. daemon, since it never asked me about that. It didn't ask me anything important, no matter what I do!

It did it the first time! I didn't like...change the CD (although, I did end up burning a new one, from three days later, hoping that something may have changed in the online database...you know, that they moved the prompts to a different part of the installation, and because I was using the old CD with the possibly updated database, that part of the install didn't exist...of course, I was wrong, and this did not fix a thing)...or anything...

I'm in desparate need of your help!

Thanks!
 
Old 06-30-2004, 02:03 AM   #2
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
Bizarre

Ok the sound thing was probably due to the fact that sound is muted on fresh installs. Sounds stupid but I spent hours figuring that out first time I installed alsa. Ok so now that it did install once, obviously but refused to install again I can't explain. From what little I know of your situation and setup I would think this is possibly due to hardware. Did you perhaps try a different kernel the first time from the f3 option? Did you pass any extra parameters to the boot loader on install? You can always run dpkg-reconfigure < package name > and it will give you your options. It sounds kind of like debconf got borked. That controls the dialogs and the questions apt or dpkg asks you. Have you tried to format in a different filesystem? I don't know what else to try at the moment.
 
Old 06-30-2004, 02:19 AM   #3
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Re: Bizarre

Quote:
Originally posted by RunLevelZero
Ok the sound thing was probably due to the fact that sound is muted on fresh installs. Sounds stupid but I spent hours figuring that out first time I installed alsa. Ok so now that it did install once, obviously but refused to install again I can't explain. From what little I know of your situation and setup I would think this is possibly due to hardware. Did you perhaps try a different kernel the first time from the f3 option? Did you pass any extra parameters to the boot loader on install? You can always run dpkg-reconfigure < package name > and it will give you your options. It sounds kind of like debconf got borked. That controls the dialogs and the questions apt or dpkg asks you. Have you tried to format in a different filesystem? I don't know what else to try at the moment.
Naw, I wish muting was the case, but I made sure that it wasn't muted ...

I've been using parameter "linux26" every time...I never changed that. Not once.

I've only formated using the Linux filesystem...do you really think formatting it in NTFS, for example, would help? Why would that make a difference?

Thanks for the help!

Still, I feel the need to use this perdiful smiley:

 
Old 06-30-2004, 04:59 PM   #4
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15


I need help!

Thanks ...
 
Old 06-30-2004, 09:53 PM   #5
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
not NTFS

I meant use Reiser or ext3 or even ext2 to just see if that perhaps does anything. Also delete and recreate the partitions might do something too. I'm curious if you are you using the new installer or are you using the old one? If your using the old installer go here > http://cdimage.debian.org/pub/cdimag...86-netinst.iso

That is the new Test Candidate 1 installer for the new debian installer that will be coming out with the next release. The only problem I have had so far is that it doesn't want to format fat32 drives but then again it could have just been me. It worked great for me other than the fat32 thing.
 
Old 06-30-2004, 09:56 PM   #6
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Re: not NTFS

Quote:
Originally posted by RunLevelZero
I meant use Reiser or ext3 or even ext2 to just see if that perhaps does anything. Also delete and recreate the partitions might do something too. I'm curious if you are you using the new installer or are you using the old one? If your using the old installer go here > http://cdimage.debian.org/pub/cdimag...86-netinst.iso

That is the new Test Candidate 1 installer for the new debian installer that will be coming out with the next release. The only problem I have had so far is that it doesn't want to format fat32 drives but then again it could have just been me. It worked great for me other than the fat32 thing.
I'm using the current Sarge installer. I've been formatting in ext3 the entire time, and I've been deleted and recreating partitions every time I format.

 
Old 06-30-2004, 10:04 PM   #7
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
Ok

So you are using the new installer? Do you have any oddball hardware or something hardware wise that could be causing this? The only other thing I can think of is when you re-create the partitions do you reboot and start the installer again? Fdisk tells you to do this before the partions will be read properly. cfdisk does too I think. It will say unable to re-read the partition table, please reboot or something like that. I have gone through an install without rebooting and it acted just like what you are saying. I use ext3 on /boot and reiser on /. maybe you can partition yours in a similar manner and see what results you get? I'll keep brain storming but this is a difficult one.
 
Old 06-30-2004, 10:14 PM   #8
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Re: Ok

Quote:
Originally posted by RunLevelZero
So you are using the new installer? Do you have any oddball hardware or something hardware wise that could be causing this? The only other thing I can think of is when you re-create the partitions do you reboot and start the installer again? Fdisk tells you to do this before the partions will be read properly. cfdisk does too I think. It will say unable to re-read the partition table, please reboot or something like that. I have gone through an install without rebooting and it acted just like what you are saying. I use ext3 on /boot and reiser on /. maybe you can partition yours in a similar manner and see what results you get? I'll keep brain storming but this is a difficult one.
Hmm...I'll try rebooting. I have no oddball hardware...to my knowledge. Just a good old Dell Poweredge 400SC. I haven't done anything to it.
 
Old 06-30-2004, 10:29 PM   #9
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
k

Well I hope the rebooting does it. I can remember doing that myself and wondering what the hell happened, it was Slackware at the time, but when I formatted and reloaded it again it was ok because it was able to read the partition scheme. If that doesn't work grab damn small and see if it will install to the hard drive... or Mepis or Knoppix... whichever you like. Oh yeah.. the sound problem could have been due to not being in the proper audio group. I had to put myself in the group before I could get sound. Even chmod wouldn't do it. But that will only help if you can get it installed. I am glad you are so determined because debian is worth it which it sounds like you already know .
 
Old 07-03-2004, 05:57 PM   #10
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Re: k

Quote:
Originally posted by RunLevelZero
Well I hope the rebooting does it. I can remember doing that myself and wondering what the hell happened, it was Slackware at the time, but when I formatted and reloaded it again it was ok because it was able to read the partition scheme. If that doesn't work grab damn small and see if it will install to the hard drive... or Mepis or Knoppix... whichever you like. Oh yeah.. the sound problem could have been due to not being in the proper audio group. I had to put myself in the group before I could get sound. Even chmod wouldn't do it. But that will only help if you can get it installed. I am glad you are so determined because debian is worth it which it sounds like you already know .
Well, I noticed that it automatically reboots...

However, I got it to work! You know how? It's the weirdest thing. After all the partitions are done, and the base system is installed, it says that I should reboot into my new system. Instead of pressing continue, I press "Go Back," and then press "Finish Installation" in the menu, and when it reboots, it has a menu again. When I follow this menu, though, I get all the options that it was forgetting! Display stuff, everything. It's like 200 prompts that it just ignored...important prompts...like resolution, everything.

Weird, eh?

I'm glad it works, though .

Well, except for sound.

Any ideas about sound?

 
Old 07-04-2004, 06:21 PM   #11
darrellc
LQ Newbie
 
Registered: Dec 2003
Location: Louisville, Kentucky USA
Distribution: Debian
Posts: 5

Rep: Reputation: 0
Sound in Debian Testing/Unstable

Check your /dev/sound folder. Try adding a link there to /dev/mixer. I was getting "no such device errors" until I did this. This in addition to setting proper permissions, of course.

Good Luck !
 
Old 07-05-2004, 05:22 PM   #12
psilo
Member
 
Registered: May 2004
Location: Holland
Distribution: Debian
Posts: 33

Rep: Reputation: 15
Missed prompts:
Probably a lower debconf priority: Did you use "expert" at the syslinux prompt of d-i the first time?
Install configure-debian with apt-get. It gives you a categorized list of all installed packages with debconf questions. Use it to reconfigure everything you might have missed, For X: x11 / xserver-xfree86

Sound issue;

Sarge currently has two hardware autodetection systems. Discover and hotplug. They are different in capabilities(for example: discover attempts to detect X settings at install, and hotplug can detect newly plugged in USB devices) but both can load drivers at boot. Sometimes they load conflicting drivers! For example: I had troubles with discover loading OSS drivers and hotplug loading ALSA drivers after discover (ALSA drivers start with the snd- prefix and are in every way superior to OSS drivers). Solution: remove discover or remove the word "audio" from this line in /etc/discover-modprobe.conf:
types="bridge broadband display fixeddisk \
humaninput imaging miscellaneous modem network \
optical printer removabledisk tape video"

Other solutions: remove hotplug. blacklist the module hotplug wants to load. Load the right module first at boot by including it in /etc/modules or selecting it with modconf (that's basically the same).

X:

Remains a PITA after more than a decade of development... ! For optimal settings try to find the perfect ModeLine with Xvidtune.
 
Old 07-06-2004, 03:29 AM   #13
TLV
Member
 
Registered: Jun 2004
Distribution: Ubuntu
Posts: 185

Rep: Reputation: 30
I don't know if you have the same problem that I had, but this is what happened to me and how I solved it:

I couldn't get sound to work on my 2.6 kernel installation with ALSA sound on my IBM R40 laptop. When I started KDE I got a message saying that permission was denied for /dev/dsp and no sound was to be heard.

The remedy was to add the user to the audio group in /etc/group. I also had to do a chmod 666 to /dev/dsp?, /dev/audio?, and /dev/mixer?. Then in the KDE Sound System configuration, I selected Threaded OSS as the audio device...

This works for me. I don't have any advanced need for sound on my laptop

/TLV
 
Old 07-06-2004, 07:42 PM   #14
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by psilo
Missed prompts:
Probably a lower debconf priority: Did you use "expert" at the syslinux prompt of d-i the first time?
Install configure-debian with apt-get. It gives you a categorized list of all installed packages with debconf questions. Use it to reconfigure everything you might have missed, For X: x11 / xserver-xfree86

Sound issue;

Sarge currently has two hardware autodetection systems. Discover and hotplug. They are different in capabilities(for example: discover attempts to detect X settings at install, and hotplug can detect newly plugged in USB devices) but both can load drivers at boot. Sometimes they load conflicting drivers! For example: I had troubles with discover loading OSS drivers and hotplug loading ALSA drivers after discover (ALSA drivers start with the snd- prefix and are in every way superior to OSS drivers). Solution: remove discover or remove the word "audio" from this line in /etc/discover-modprobe.conf:
types="bridge broadband display fixeddisk \
humaninput imaging miscellaneous modem network \
optical printer removabledisk tape video"

Other solutions: remove hotplug. blacklist the module hotplug wants to load. Load the right module first at boot by including it in /etc/modules or selecting it with modconf (that's basically the same).

X:

Remains a PITA after more than a decade of development... ! For optimal settings try to find the perfect ModeLine with Xvidtune.
Hmm...

/etc/discover-modprobe.conf doesn't exist...
 
Old 07-07-2004, 03:29 PM   #15
psilo
Member
 
Registered: May 2004
Location: Holland
Distribution: Debian
Posts: 33

Rep: Reputation: 15
My bad. You probably have discover1 installed, while my sid box runs Discover2. To disable OSS driver loading by discover you should edit /etc/discover.conf. If this doesn help after the next reboot, try this command:
Code:
modprobe snd-intel8x0

Last edited by psilo; 07-07-2004 at 03:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Sarge Installer kurrupt Debian 1 01-15-2005 05:57 AM
sarge installer kpachopoulos Debian 4 11-09-2004 11:11 AM
Sarge Installer RC1 iotc247 Debian 6 08-10-2004 08:42 AM
debian sarge installer. TuxToaster Debian 3 07-21-2004 10:46 AM
sarge installer partitioning asb Debian 2 06-11-2004 02:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration