LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-26-2003, 02:21 AM   #1
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
Question same fstab, new problems


I recentlly made the step to Sarge and last night as I was trying to listen to some music I observed that I couldn't access my vfat partitions.

How is that possible?
I made no change to the fstab and as the man page says no program will edit this file...I didn't edit it, the progs didn't so want is the problem?

I have all my music on my vfat partition (M$ legacy) and I had to listen music from windoze!!!
I hate it!!!
 
Old 08-26-2003, 02:33 AM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 48
Have you tried mounting it from the console?
Whats your fstab looklike?

Hows the harddrives setup?
 
Old 08-26-2003, 08:29 AM   #3
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by leonscape
Have you tried mounting it from the console?
yes, as a user I can mount it only if root unmounts it.
the drive is mounted on startup but a normal user can't access it..
Quote:
Whats your fstab looklike?

Hows the harddrives setup?
Code:
# /etc/fstab: static file system information.
#
# <file system>	<mount point>	<type>	<options>		<dump>	<pass>
/dev/hda1	/		ext3	errors=remount-ro	0	1
/dev/hda5	/home		ext3	errors=remount-ro	0	1
/dev/hda9	none		swap	sw			0	0
proc		/proc		proc	defaults		0	0
/dev/fd0	/mnt/floppy	auto	user,noauto		0	0
/dev/cdrom	/mnt/cdrom	iso9660	ro,user,noauto,noexec		0	0
/dev/cdrom1	/mnt/cdrom1	iso9660	ro,user,noauto,noexec		0	0
#/dev/hda6	/mnt/movie	vfat	user,auto,noexec		0	0
#/dev/hda7	/mnt/data	vfat	user,auto,noexec		0	0
#/dev/hda8	/mnt/kits	vfat	user,auto,noexec		0	0
/dev/hda6	/mnt/movie	vfat	user,auto,user,noexec		0	0
/dev/hda7	/mnt/data	vfat	user,default		0	0
/dev/hda8	/mnt/kits	vfat	user,default		0	0
The commented lines with /mnt/kits and so on are the settings that I used before the upgrade and worked fine.

They are now like this because I tried some other combinations to see if they work
 
Old 08-26-2003, 08:39 AM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 48
Does it work without auto?

Also try using auto as the filesystem type, see if that help.
 
Old 08-26-2003, 09:06 AM   #5
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Original Poster
Rep: Reputation: 30
It works with auto, but only root can browse the /mnt/xxxx dirs (vfat ones)
 
Old 08-26-2003, 09:23 AM   #6
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 48
try adding nosuid to the options

Edit:
and or users

Last edited by leonscape; 08-26-2003 at 09:26 AM.
 
Old 08-26-2003, 09:30 AM   #7
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by leonscape
try adding nosuid to the options

Edit:
and or users
You mean that I should replace user with nosuid in the option field?
 
Old 08-26-2003, 09:34 AM   #8
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 48
Direct from man mount:

users:
Allow every user to mount and unmount the file system. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line users,exec,dev,suid).

Users could replace user, nosuid is a slightly diffrent option, and would have to be put in as well as user. (but is unecssary with users)

If that makes sense.
 
Old 08-26-2003, 10:00 PM   #9
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
In the options section, add in "gid=<your group name>,uid=<your user number>". That should work. I think the mount commands work slightly differently under woody and sarge. That's what caused the problem...
 
Old 08-27-2003, 01:20 AM   #10
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Original Poster
Rep: Reputation: 30
Question A group???

So, the elegant way would be to insert a gid=vfat_users and insert in that group whomever I want to access the vfat drives!!!

Ok, I will try this too.

the nosuid option had no effect only that I could mount the volumes when they were unmounted.
 
Old 08-27-2003, 01:56 AM   #11
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Yeah. You could also add in the group number of the users group (gid=100, I think). The user part if I recall is also pretty important. Try the group thing first and if that works then great. If not then you'll have to put in the uid option. I recall that there was a time that I didn't have to do this but recently, I did have to. Hence I believe that the newer version of mount works differently. I've always had to specify those options with ntfs, though. Linux is a lot pickier with ntfs. I don't run windows on this computer so I haven't messed around with those settings for a while now.

You may also want to change the "user" option to "users", and ditch the "noexec" and "default" options. I think that's what I had and it worked. At some point I even specified a "umask" option though I don't remember whether that was for the ntfs partition or for the vfat...
 
Old 08-27-2003, 04:55 PM   #12
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Original Poster
Rep: Reputation: 30
Angry the gid option didn't work

when I run mount it says that the partitions are owned by the vfatusr - the group I made. My user is a member of vfatusr, also the root is a memeber.

This is the output
Code:
/dev/hda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda5 on /home type ext3 (rw,errors=remount-ro)
/dev/hda6 on /mnt/movie type vfat (rw,noexec,nosuid,nodev,gid=1002)
/dev/hda7 on /mnt/data type vfat (rw,noexec,nosuid,nodev,gid=1002)
/dev/hda8 on /mnt/kits type vfat (rw,noexec,nosuid,nodev,gid=1002)
automount(pid357) on /var/autofs/net type autofs (rw,fd=5,pgrp=357,minproto=2,maxproto=4)
automount(pid337) on /var/autofs/misc type autofs (rw,fd=5,pgrp=337,minproto=2,maxproto=4)


and this is fstab

# /etc/fstab: static file system information.
#
# <file system>	<mount point>	<type>	<options>		<dump>	<pass>
/dev/hda1	/		ext3	errors=remount-ro	0	1
/dev/hda5	/home		ext3	errors=remount-ro	0	1
/dev/hda9	none		swap	sw			0	0
proc		/proc		proc	defaults		0	0
/dev/fd0	/mnt/floppy	auto	user,noauto		0	0
/dev/cdrom	/mnt/cdrom	iso9660	ro,user,noauto,noexec		0	0
/dev/cdrom1	/mnt/cdrom1	iso9660	ro,user,noauto,noexec		0	0
#/dev/hda6	/mnt/movie	vfat	user,auto,noexec		0	0
#/dev/hda7	/mnt/data	vfat	user,auto,noexec		0	0
#/dev/hda8	/mnt/kits	vfat	user,auto,noexec		0	0
/dev/hda6	/mnt/movie	vfat	gid=vfatusr,auto,noexec,user		0	0
/dev/hda7	/mnt/data	vfat	gid=vfatusr,,auto,user		0	0
/dev/hda8	/mnt/kits	vfat	gid=vfatusr,nosuid,auto,user		0	0
As u can see the partitions have different options (changed them over an over again!!!).

Any Ideas?!?!?
I will try the user group thing and so on...
I will inform u aboutr the results...
 
Old 08-27-2003, 07:00 PM   #13
Matthew_I
LQ Newbie
 
Registered: Aug 2003
Location: Georgia
Distribution: Debian
Posts: 17

Rep: Reputation: 0
Also try adding umask=000, to allow everyone to read and write, or umask=002 to only allow group and owner to rw, and user to ro.
 
Old 08-28-2003, 05:12 AM   #14
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
"umask=000" stops everyone from reading and writing. You can try to "uid=<your user number>" option and possibly the umask=007.
 
Old 08-29-2003, 05:43 AM   #15
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Original Poster
Rep: Reputation: 30
umask, uid, gid?

umask might be ok, gud might be ok(it doesn't work - at least now), but uid in fstab that's too much!!!!

What if I had a server that shared one partition over samba and I had 100 users that use the parttion?!?!?! that is just too much work (ok, it can be done through scripts) and gets fstab to giant sizes!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there problems with my fstab cheetahman SUSE / openSUSE 3 03-26-2005 04:17 AM
Problems with fstab? SiLiCoN Debian 2 10-01-2004 04:21 AM
problems with fstab Jeebizz Slackware 10 09-21-2004 05:58 AM
fstab problems h8r Linux - General 6 03-09-2003 07:15 PM
Problems in fstab! marksstroud Linux - Newbie 2 10-27-2001 08:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration