LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-12-2008, 06:19 PM   #1
anubis2k7
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Rep: Reputation: 0
Running FreeNX as root


Hi,

I am trying to login as root remotely onto a debian machine running freenx. However, whenever I try this, I receive the following error message:

user root cannot be used as an nx user

I have already tried to edit the following values in the server.cfg file under usr/NX/etc:

EnableFullDesktopSharing = "1"
EnableAdministratorDesktopSharing = "1"

Any ideas? thnx
 
Old 02-12-2008, 06:25 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,138

Rep: Reputation: 167Reputation: 167
I'm pretty sure it can't be done - and the error message seems to confirm it. Is there anything you need to do that can't be done with su or sudo (or it's KDE and GNOME equivalents)?
 
Old 02-12-2008, 06:37 PM   #3
anubis2k7
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Thnx for the quick reply.

Well, I have a fedora box where I am able to use NX to login as root, so I assumed that it was a configuration setting that was preventing this from working on the debian machine. I am using the same computer to logon to both (win box).

I can do what I need using "su"...it's just a pain to constantly retype the root password to get to what I need, especially at the start of a new session.
 
Old 02-12-2008, 07:23 PM   #4
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,190

Rep: Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038
I am not quite sure how NX works, but VNC starts a new KDM session when you connect to the server. If that is the case, Debian does not allow root login in X.

Alternatively, the debian version of NX might have been patched in order to disable root access.

Generally it is bad idea to run a GUI as root. You can do everything from with KDE as a root, but it should be avoided to run the GUI itself as root.

If you insist and you know what you are doing, edit /etc/kde3/kdm/kdmrc (or /etc/somewhere/gdmrc if you use gnome) and allow root access and see if that helps.

jlinkels
 
Old 02-13-2008, 01:18 PM   #5
anubis2k7
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Original Poster
Rep: Reputation: 0
What you said about the OS blocking root access makes a lot of sense....this version of debian was an image built to run an infosec IDS framework, so it's logical to assume the creators patched it/made it harder to hack.

How would I login as root after I login as a user using FreeNX? I would kill X Window? ctrl+alt+backspace does not work on the FreeNX client.

thnx
 
Old 02-13-2008, 02:00 PM   #6
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,190

Rep: Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038
You only can start applications as root by using ALT-F2. Press "Options >>" button.

In a shell you can obviously use 'su'. Once you are root in a console you can NOT start a GUI application from the command line.

You can also use kdesu to start an app with root permissions.

jlinkels
 
Old 02-16-2008, 12:58 AM   #7
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
you can also use sux
 
Old 02-16-2008, 12:30 PM   #8
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Quote:
Originally Posted by anubis2k7 View Post
Hi,

I am trying to login as root remotely onto a debian machine running freenx. However, whenever I try this, I receive the following error message:

user root cannot be used as an nx user

I have already tried to edit the following values in the server.cfg file under usr/NX/etc:

EnableFullDesktopSharing = "1"
EnableAdministratorDesktopSharing = "1"

Any ideas? thnx
I am not familiar with FreeNX but I believe with nomachine NX CLient you can set up a login to root but it would be with a gui....would root log in in SSL work for you?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Running FreeNX using a Mandriva 2008 Server LXer Syndicated Linux News 0 11-05-2007 07:20 PM
Problem with Starting FreeNX. Followed Guide. Centos. Dont think GNOME is running. CrewXp Linux - Software 5 08-14-2007 02:04 AM
Installed Freenx. Changed sshd config. Can't ssh root. CrewXp Linux - Software 1 08-13-2007 04:52 AM
How could I tell if Im running as ROOT? wardialer Linux - Security 9 03-19-2005 09:47 PM
installed as root, running as non-root? daniela Linux - Newbie 4 09-09-2003 04:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration