LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-24-2019, 08:48 PM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,675

Rep: Reputation: 105Reputation: 105
rpc.statd does not kick in


Hya,

System Debian amd64, all up-to-date buster. Several Penguins are networked and one of them is a nfs file server.

Problem On the server Penguin, rpc.statd does not kick in on boot, and things get upside down.

Gorilla patch solution After boot
Code:
start-statd
troubleshooting When checking several logs on nfs server and clients, there not much informative ones. Both server and clients
Code:
 penelve systemd[1]: /lib/systemd/system/rpc-statd.service:13: PIDFile= references path below legacy directory /var/run/, updating /var/run/rpc.statd.pid -> /run/rpc.statd.pid; please update the unit file accordingly.
This thread is not much help. There are several old bugs in Debian (562757, 484861), which look irrelevant.

Penguins can survive with a patch above, but it may not be a good idea.

Does anybody know what happened and have a good idea?

cheers
 
Old 02-27-2019, 10:52 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,675

Original Poster
Rep: Reputation: 105Reputation: 105
Self reply:

I found
Code:
* 27-systemd-enable-with-systemctl-statd.patch: let the admin
    enable/disable statd via systemd tools. (LP: #1428486)
  * debian/rules: don't start statd by default (or it will trigger upstart
    and systemd statd unit startup).
in the changelog of nfs-utils.
Then,
Code:
systemctl enable rpc-statd.service
does the job.

I was checking only nfs-common package!!
 
  


Reply

Tags
debian, nfs-common, rpc.statd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to close the rpc.statd in reboot,not to autorun? luofeiyu Linux - Newbie 1 08-19-2015 03:55 PM
[SOLVED] Debian mount.nfs: rpc.statd is not running but is required for remote locking jmc1987 Linux - General 2 11-04-2013 08:18 AM
[SOLVED] rpc.statd not running David the H. Linux - Networking 4 04-13-2012 01:37 AM
rpc.lockd & rpc.statd twantrd Linux - General 1 05-21-2005 09:24 AM
rpc.statd won't start mahaabaala Linux - Software 0 01-24-2003 05:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration