LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-25-2004, 03:07 AM   #1
cdgeorge
LQ Newbie
 
Registered: Mar 2004
Distribution: woody
Posts: 7

Rep: Reputation: 0
Exclamation revert to a stable distribution of woody


Hello,


I've done an upgrade of woody with the unstable packages. I have some problems. I need glibc 2.2.5, and the newest one is 2.3.x . But it so happens , that almost everything depends on the libc 6.1 package installed (which represents a glibc 2.3.x) . So I need to revert with all my packages to the stable version.

Could anyone tell me how to do that ?

Thanks and regards,
George
 
Old 03-25-2004, 09:20 AM   #2
Cinder
LQ Newbie
 
Registered: Mar 2004
Location: Gloucester, UK
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Try and re-install the libc6 package from the stable release again, as opposed to try and removing the unstable version.

http://packages.debian.org/stable/base/libc6
 
Old 03-25-2004, 09:24 PM   #3
cdgeorge
LQ Newbie
 
Registered: Mar 2004
Distribution: woody
Posts: 7

Original Poster
Rep: Reputation: 0
Hello,

Here's the tricky part. So the stable libc6.1 has the glibc 2.2.5 and the new one has the glibc 2.3.1. So doing a downgrade is not a solution because it is not in fact a downgrade (because the files are different). OK so maybe i should try just installing it.

Ok i tried to do that. But together with the new libc6.1 comes libdb1-compat which already has the libc .so library (2.2.5) and therefore I can't install it. I could do at most an overwrite, but i'm not sure this changed something. In fact it got debian a little confused. And I'm also in need of the libc61-dev meaning the old headers.

I hope there is a solution . I'm out of ideas for now.

George
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Debian] Stable: Woody or Sarge? e11 Linux - Newbie 1 10-20-2004 01:06 AM
How to upgrade from Woody(Stable) to Sid(Unstable) The Pentium Guy Debian 8 10-14-2004 10:32 PM
stable woody with testing gtk malbery Debian 8 08-18-2004 12:33 AM
how can i upgrade my squid 2.5 stable 1 to stable 3 in RH9? debloxie Linux - Networking 0 05-12-2004 08:49 PM
how can i upgrade my squid 2.5 stable 1 to stable 3 in RH9? debloxie Linux - Networking 0 05-12-2004 11:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration