LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-04-2004, 02:31 AM   #1
basanta
LQ Newbie
 
Registered: Jun 2004
Posts: 14

Rep: Reputation: 0
rendering is not upto the mark with mozilla 1.7.3 libpango 1.4


Dear I am trying to build mozilla 1.7.3 with pango enable.

Firstly I couldn't ./configure mozilla with follwing switches
-----
./configure --enable-svg-renderer-libart --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man --infodir=/usr/share/info --localstatedir=/var --disable-pedantic --with-default-mozilla-five-home=/usr/lib/mozilla --disable-debug --disable-tests --disable-short-wchar --enable-xprint --enable-strip-libs --enable-crypto --enable-mathml --enable-oji --enable-extensions=all --enable-ldap --enable-freetype2 --enable-default-toolkit=gtk --enable-toolkit=gtk --disable-gnomevfs --enable-xft --disable-installer --with-gssapi=/dev/null --enable-svg --without-system-mng --without-system-png --enable-pango
--------

it doesn't './configure', so I take out '--enable-svg-renderer-libart' and '--enable-svg' option then it configures and compile and installs ok. but when I open the browser my rendering is not what i expected --ofcourse some rendering is done. Then I go back all over again to './configure' with these '--enable-svg-renderer-libart' and '--enable-svg' switches And this time it ./configures ok after setting the variable MOZ_INTERNAL_LIBART_LGPL=1 but give following error while running 'make'

----------------
make[2]: Leaving directory `/mytemp/mozilla/jpeg'
make[2]: Entering directory `/mytemp/mozilla/modules/zlib'
make[3]: Entering directory `/mytemp/mozilla/modules/zlib/src'
/mytemp/mozilla/config/nsinstall -R -m 644 zlib.h zconf.h ../../../dist/include/ zlib
/usr/bin/perl -I../../../config ../../../config/build-list.pl ../../../dist/incl ude/zlib/.headerlist zlib.h zconf.h
make[3]: Leaving directory `/mytemp/mozilla/modules/zlib/src'
make[2]: Leaving directory `/mytemp/mozilla/modules/zlib'
make[2]: Entering directory `/mytemp/mozilla/other-licenses/libart_lgpl'
make[2]: *** No rule to make target `export'. Stop.
make[2]: Leaving directory `/mytemp/mozilla/other-licenses/libart_lgpl'
make[1]: *** [tier_1] Error 2
make[1]: Leaving directory `/mytemp/mozilla'
make: *** [default] Error 2
------

please help

basanta
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cant link to libpango sibtay Linux - Software 0 12-16-2004 03:27 AM
i think i did something stupid with libpango ... whatever that is pguru Linux - Newbie 0 07-11-2004 08:38 PM
Mozilla 'mark all read' shortcut in mail/news not working EdoardoC Linux - General 3 03-10-2004 03:46 AM
debian with a upto date kernel emetib Debian 12 08-04-2003 04:03 PM
Loads just upto banner? DiZASTiX LQ Suggestions & Feedback 2 05-15-2003 07:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration