LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-06-2018, 02:26 AM   #1
aristosv
Member
 
Registered: Dec 2014
Posts: 164

Rep: Reputation: Disabled
remove all the messages shown during the boot up process


This is a question for Raspbian Stretch, but since it's based on Debian (and I still didn't get a reply in the raspbian forums) I though I would ask it here.

I am using Raspbian Stretch Lite and I want to remove all the text scrolling during the boot up process. I've googled how to do this and found various articles indicating that I should modify /boot/cmdline.txt, redirect the console to tty3 and configure loglevel=3. I also tried dmesg --console-off in /etc/rc.local.

These suggestions haven't worked for me, I can still see the full text during the boot up process.

Also this forum post provides a zip file containing files to be overwritten in Raspbian to hide all the text during boot. But I would really prefer not to overwrite system files, not really knowing how they will affect it.

Any suggestions on how to hide all boot messages?

It's not that I don't like looking at all the green [OK] messages, it's just that I want to use the pi for digital signage, and I need to hide the boot process messages.

Thanks
 
Old 12-06-2018, 03:33 AM   #2
aristosv
Member
 
Registered: Dec 2014
Posts: 164

Original Poster
Rep: Reputation: Disabled
eventually I found it. This gave me a completely blank screen.

Code:
echo hide raspberry pi icons
sudo sed -i "1 s|$| logo.nologo quiet splash|" /boot/cmdline.txt

echo hide boot messages
sudo sed -i "1 s|$| quiet splash|" /boot/cmdline.txt

echo disable login prompt
sudo systemctl disable getty@tty1.service

echo hide blinking cursor
sudo sed -i "1 s|$| vt.global_cursor_default=0|" /boot/cmdline.txt

echo hide undervoltage message
sudo sed -i "1 s|$| loglevel=1|" /boot/cmdline.txt

echo hide undervoltage lightning bolt icon
sudo sed -i '1 i\avoid_warnings=1' /boot/config.txt
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
usb keyboard identified and events shown but key character not shown on the prompt flyxtop Linux - Software 0 11-30-2013 08:45 AM
No transfer process shown during USB transfer mad.slacker Slackware 6 01-23-2010 04:48 PM
User shown as "already exist" when there is no user directory shown on home directory Sharpeye Linux - Newbie 3 03-18-2009 02:17 AM
While booting no option is shown for Linux! Only windows xp is shown!! mon avis Linux - General 7 08-06-2006 05:14 PM
nvidia geforce qstn - shutdown messages not shown h/w Linux - Hardware 4 11-29-2003 01:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration