-   Debian (
-   -   recent dist-upgrade of xorg has killed my mouse (and thusly, xorg). (

Lokathor 06-09-2006 06:07 AM

recent dist-upgrade of xorg has killed my mouse (and thusly, xorg).
So i run apt-get update, apt-get upgrade, and it gets the new stuff for most of the programs, but some are held back. I use apt-get dist-upgrade figuring it's some kind of dependency thing. Sure enough it says it's going to replace a bunch of packages with others. I select Yes and it does its thing. I reboot my computer even though it's not required, just to make sure that if a problem comes up i'd know about it right away. Lucky me.

It reboots and tries to start X and can't. I wait a moment for the bug report to come up and it says that it can't detect /dev/psaux. I, finding this very odd, check the directory and the device is there. I tried setting it to 0666 readable and rebooting, but that didn't work (so i put it back to the 0600 it was at before). I don't seem to have any other kinds of mose devices in the directory that i recognize, and I can't seem to find (or remember) whatever script it is that's supposed to walk you through the xorg configuration process. I'm stuck, I've not idea what to do or where to start at this point. Any help would be appreciated.

craigevil 06-09-2006 07:15 AM

If you can login try ctrl+alt+F1 then as root enter dpkg-reconfigure xserver-xorg

BTW you might want to put which Debian release you are using in your profile, makes it easier for ppl to know what went wrong.

Lokathor 06-09-2006 07:39 AM

I'm using debian testing. sorry i don't have it in my profile but i recently reinstalled and switched (i was using stable to keep my printer working, but now it works in testing, lucky me).

Anyways, i reconfigured it with the dpkg-reconfigure command, and the most it mentiond or asked about the mouse was to use IMps2 or IMDiscover (i think those were the options, i picked IMps2 of course). I restared and it still doesn't detect the mouse device.

Side question: the terminal keeps displaying information in the terminal, and it really screws up the lynx display (which is what i'm using right now). Is there a way to prevent a program from writing to the terminal to stop this?

craigevil 06-09-2006 02:30 PM

Chances are the info showing up in the terminal is your firewall logging. you can turn loggin off.

What modules are loading when you boot?

Have you tried a different mouse ?

You try looking here at the mouse info:

Lokathor 06-10-2006 04:52 AM

ah-hehe.. hasty me, I just reinstalled everything (only took about 2 hours from boot to finish, including time for food, since it was a new setup anyways).

Anyways, it seems that the issue was with /dev/input/mice. I had changed it over to /dev/psaux because the older version of X hadn't recognized input/mice, but now it's using that and working fine. Fickle, fickle X.

Everything is mostly back fine, but apache2 wasn't autoconfigured to recognize public_html directories for some odd reason. Fixed it though.

All times are GMT -5. The time now is 06:33 AM.