-   Debian (
-   -   Recent Debian installation not booting, computer stops with usb problmes. (

Knitter 02-26-2006 04:54 PM

Recent Debian installation not booting, computer stops with usb problmes.

I've just installed debian for the first time, been using Ubuntu for about 1.5 years but still a n00b.
The problem is that the computer stops at startup and doesn't even accept keyboard commands, only way to shut it down is to press the power button.

I get the following error message:

usb.c: USB device not accepting new address = 2 (error=-110)
hub.c: new USB device 00:1d.0-1, assigned address 3
usb.c: USB device not accepting new address = 3 (error=-110)
hub.c: new USB device 00:1d.0-1, assigned address 2
usb.c: USB device not accepting new address = 3 (error=-110)
hub.c: new USB device 00:1d.0-1, assigned address 3

The booting procedures just stop here and I get a blinking cursor, I have never seen my debian installation working :(

I've been trying to install Debian Sarge from a net install CD on a HP Pavillion ZD8000 series laptop.
I'm using dual boot with WinXP and i'm able to edit files on my debin installation from windows but I don't know how to login into debian, I've absolutly no idea of what to do :(


Laptop General specs:

Model zd8158ea from June 2005
Pentium 4 630 Prescott 3.0 GHz
1024MB DDR2
ATI Mobility x600

lestoil 02-26-2006 05:15 PM

Check this out for debian install notes on your lappy. Good luck.
But this is newer lappy with newer hardware for which Sarge 2.6.8 kernel may be too old. The Etch or Sid netinstaller with 2.6.15x kernel may work out better. Also you might try kanotix 2005-04 live-cd to see how it runs on your lappy.

Knitter 02-26-2006 08:16 PM

Thanks for the reply, but I'd seen that page before. There's nothing there that I can see of help :(.
The steps taken in the page are known to me, I've installed Ubuntu a few times and i can set up my machine once the system is installed and I'm at a console or something, the prob is that in this debian installation there is no console no nothing!
I'm a dos and windows user, I'm just not used to being stuck outside of the system this way :(.
Sorry but I'm feeling a bit useless right now.

One other thing about the kernel question, the netins cd of Debian Sarge stable version that can be downloaded from has a 2.4 kernel, shouln'd it be 2.6.x by now?I just notice that my kernel is 2.4 and was a bit surprise, I was expecting it to be 2.6.x has I been using that kernel since I came to Linux with Ubuntu.

I'm going to see if I can find any grub commands that may help get into a recovery console type, and then I'm going to learn how to upgrade my kernel and assuming I can do all this, I'm going to sleep because this prob has been on my nerves for a long time.

Thanks for the replys and by the way Ubuntu realy made things easy, but I'm still "two bits short" on given up :)

lestoil 02-26-2006 10:34 PM

Sarge netinstall
Actually 2.4 and 2.6x kernels have been on netinstall iso since Sarge came out. Press F3 for boot options or type expert26(asks more questions and gives more options) or linux26 instead of hitting enter at install start. Sid netinstall cd has 2.6.15x kernel and xorg. Etch one has 2.6.12 or 2.6.14 now and is pretty stable. Also Kenshi Muto puts out sarge netinstall iso with 2.6.15 kernel,xorg and better sata handling.
Boot parameters you may try are noapic,nolapic,noacpi,debian-installer/probe/usb=false(for usb legacy devices or turn legacy usb support off in BIOS). Most lappys now dont have usb1 but usb2 ports anyway.
Since you mentioned grub you might like ultimatebootcd for linux and UBCD4Win both great rescue/boot cds.

Knitter 02-27-2006 09:35 AM

Wowow slow it down please! :D
OK, I'll NOT ask what the hell you just said up there, I'll search the master google's database insted :)
Thanks, I'll try that, whatever it is :), when I get home.

Knitter 02-28-2006 02:08 PM

I have installed debian in a virtual machine on my windows using the options expert26 and linux26. Expert26 asked lots of questions I din't knew the answer but everything worked fine so, with new confidence in those solutions, I try installing debian again in my laptop using linux26 after the first installing procedures, after having removed the netinst cd and reboot the machine for the first time my laptop stoped again and I couldn't continue the installation :(
I ended up with the following call trace:

Call trace:
[<f8a2b233>] i810_configure_cloking+0xaa/0x419 [i810_audio]
[<f8a2afba>] i810_ac97_init+0x325/0x4f4 [i810_audio]
[<f802b9d4>] i810_probe+0x432/0x54c [i810_audio]
[<c0194991>] pci_device_probe_static+0x2e/0x41
[<c01949c3>] __pci_device_probe+0x1f/0x32
[<c01949f2>] pci_device_probe+0x1c/0x31
[<c01d47ef>] bus_match+0x2e/0x4d
[<c01d48c4>] driver_attach+0x39/0x6e
[<c01d4c28>] bus_add_driver+0x58/0x70
[<c01d4f77>] driver_register+0x2d/0x31
[<c0194b96>] pci_register_driver+0x4e/0x6b
[<f8829014>] i810_init_module+0x14/0x89 [i810_audio]
[<c012b0b0>] sys_init_module+0xe3/0x1d4
[<c0105fa7>] syscall_call+0x7/0xb
code: 8b 53 24 31 ff 83 7a 08 00 75 0d 66 83 a0 16 02 00 000 fb e9
./pci.agent:line156:2004 segmentation fault $ MODPROBE $ MODULE >/dev/null 2>&1 i810_audio:can't be loaded
missing kernel or user mode driver i810_audio
<6> usb 2-1: new low speed USB device using address 3
input: USB HID v1.10 Mouse [1241:1177] on usb-0000:00:1d.1-1

I may be new to all this linux thing but I believe "segmentation fault" is something that shouldn't happen :D
Any clues on how to put my system up and running would be welcome :)

Knitter 03-02-2006 09:05 AM

Well as no one asked I had to go to the very hard google search :D
And, after long search hours, I was able to find that the problem is something called S3discover and S40hotplug, I don't quite know what that is bu but removing it from /etc/rcS.d/ I found that the system was able to boot and I could finhish the debian setup (at this point I jumped around the room like a crazy man :D)
After one thing solved another prob arrises :(

I now have no idea of how to set up my ethernet :(, Dmesg says nothing about network card, ifconfig shows only the lookup interface, so... back to google's sea of information to learn how to set the module for my network card, if anyone has any idea how to set it up I'll be glad to heart it :D

dracae 03-02-2006 09:19 AM

discover and hotplug both setup your hardware automagically. You don't need both but having one will make things easier. I would install hotplug again. If it hangs you can blacklist the offending module in /etc/hotplug/blacklist.

Knitter 03-02-2006 09:24 AM

I would install hotplug again too if only I knew how :)
I don't have net access in my debian and I'm now using dual boot to try to figure this out!

Knitter 03-02-2006 09:25 AM

And by the way I belive that my probs started with usb, if I inable hotplug would that make the system hang again?
I remove discover and hotplug by moving them to /tmp.

dracae 03-02-2006 09:30 AM

The proper way would be:
apt-get install
apt-get remove
for installing and removal respectively.

I would put them back in their proper location and

apt-get remove --purge discover
cat >> /etc/hotplug/blacklist<<EOF

Knitter 03-02-2006 09:49 AM

Ok, I now know the proper way :) thanks, but how can I know activate my network card how do I make the kernel aware of the hardware?

dracae 03-02-2006 10:06 AM

what nic do you have?

Knitter 03-02-2006 10:16 AM

Prob solved :), just 'apt-get install discover' and it detected the card, 'ifconfig up eth0' and some 'dhclient' and I'm up and running.
Now just have to set up the rest of the system :(, The console's black is getting on my nerves, it feels like it blocks the brain, or maybe the was no brain to start with :).

Thanks for the replys and I'm sorry if I was too n00b and a bit lazy :D
See you all in my next prob :D :D :D

All times are GMT -5. The time now is 04:10 AM.