-   Debian (
-   -   raid 0 in Crunchbang? (

Rita G. 04-06-2011 05:40 PM

raid 0 in Crunchbang?
Linux distro: Crunchbang “Statler” 64bit

i am posting in this forum because this distro is debian based & i haven’t gotten any response at it's forum.

i have made 2 unsuccessful attempts at installing statler openbox in raid0. i used the same procedure as i have always (successfully) used with debian. is it possible to do this in statler, or am i wasting my time?

anyway....tried again today to install statler in raid0. installation completed “successfully”, but entries on grub menu are flashing and boot will not proceed all the way to desktop. tried booting in recovery mode and procession stops at:

Gave up on waiting for root device. Common problems:
Boot args (cat /proc/cmdline)Check rootdelay= (did the system wait long enough?)
Check root= (did the system wait for the right device?)
Missing modules (cat /proc/modules; ls dev)ALERT! /dev/md0 does not exist. Dropping to a shell!
BusyBox v1.17.1 (Debian 1:1.17.1-8) built-in shell (ash)
Enter 'help' for a list of built-in commands.
/bin/sh: can't access tty; job control turned off(initramfs) _

any advice?

Dutch Master 04-06-2011 07:11 PM


Missing modules (cat /proc/modules; ls dev)ALERT! /dev/md0 does not exist.
There's the culprit. You want the kernel to boot from a device (the RAID array) that doesn't (yet) exist. Possible solution: divide both disks into 2 partitions, sdX1 (small, ca 1 GB) and sdX2. Combine both sdX1 partitions in a RAID1 array and use the rest as RAID0. Use the RAID1 to boot the system. Alternatively, only divide the largest disk and use that partition to boot from, while retaining the rest and the smaller drive for the RAID0 setup.

All times are GMT -5. The time now is 07:04 AM.