Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 10-10-2004, 03:49 PM   #1
LQ Newbie
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
Radeon 9600 on Sarge

Ok, well I'm a newbie at linux.

I have installed Sarge and have that up and running. Unfortunately, I have a Radeon 9600 video card which is not currenly supported (I found this out after attempting to install and run x-window-system).

I have found a .deb package for my video card, however, it requires xserver-xfree86 version 4.3 or above. The version I have is 4.1, and I can't figure out how to upgrade it. when I run apt-get, I get a message that says I have the newest version.

If anyone has had any problems with Radeon video cards, could you please post your step by step instructions, or if anyone has any ideas or tips.

Thank you very much!
Old 10-10-2004, 10:20 PM   #2
Registered: Aug 2003
Location: Melbourne Australia
Distribution: Debian Stretch
Posts: 374

Rep: Reputation: 32
sarge atm has XFree86 Version

run apt-get update
apt-get dist-upgrade

that will upgrade everything to the latest "testing"

i took my radeon 9200 back because of the crap linux support, but i did get it working well before i did

this site helped, its for the 9200 but shoudl work for you
Old 10-11-2004, 01:18 PM   #3
LQ Newbie
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
thanks cadj,

I'm attempting to go through those instructions, however I am getting stuck on installing alien (to convert the rpm to deb)

I run:
apt-get install alien

but I get the error:
alien: Depends: debhelper (>=3) but it is not going to be installed
E: Broken Packages

Then I run:
apt-get install debhelper:
dephelper: Depends: debconf-utils but it is not going to be installed
E: Broken Packages

Then I run:
apt-get install debconf-utils:
debconf-utils: Depends: debconf (>= 0.9.59) but it is not going to be installed
E: Broken Packages

apt-get install debconf
debconf is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Is there anyway to force an upgrade?
Or any other ideas around this?

Thanks again
Old 10-11-2004, 11:09 PM   #4
Registered: Aug 2003
Location: Melbourne Australia
Distribution: Debian Stretch
Posts: 374

Rep: Reputation: 32
did u do the apt-get dist-upgrade?

if u have i cant really think of anythin to help, mayb someone else can tho
Old 10-11-2004, 11:49 PM   #5
LQ Newbie
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
I tried to do the apt-get dist-upgrade, but got the following error message:

Unpacking fileutils (from .../fileutils_4.1-10_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fileutils_4.1-10_i386.deb (--unpack):
trying to overwrite '/bin/chgrp', which is also in package coreutils
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas?

(I'm thinking about trying a different disto, maybe Mandrake or Suse?)
Old 10-12-2004, 03:10 PM   #6
LQ Newbie
Registered: Sep 2004
Location: Syracuse, NY
Distribution: dEbiaN
Posts: 2

Rep: Reputation: 0
ok you need to get midnight commander if you dont already have it

apt-get install mc

run mc and navigate to /etc/apt/sources.list
edit sources (F4)

in there youll see your cd first, put a # infront of this line to comment it out

you shoould have a few xources listed here. comment all of them out but one

the one you leave should start with deb , not deb-src

after the site in that line itll say stable contrib non us, whatever you selected when you added this

well just change stable to testing, press f10 to exit, say yes to the change and then run apt-get update

try it then

afterwords, you should neaten up your apt list, i usually keep 2 sets of sources and security updates i have a stable set and a testing set. leave the testing set commented out untill you come across a time when you need to use it like this
i found when looking for something in testing its best to comment out EVERYTING else just to be sure

and remember you probably moved to linux so that you can build and customize your machine just how you like it. learning exploring and running into trouble is gonna happen, but your doing the right thing, asking questioins and sticking with it, dont move to suse or mandrake, when all is said and done the skills your learning will be a great reward.
Old 10-19-2004, 03:23 PM   #7
LQ Newbie
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Well, I hate to say it, but I switched to Mandrake 10. When I have more time, I'll try Debain again as I would like to completely customize my install. But for now, just to get something up and running, Mandrake worked like a charm. Thanks to everyone for all of your help
Old 10-21-2004, 04:07 PM   #8
LQ Newbie
Registered: Oct 2004
Location: Belgium
Distribution: Debian
Posts: 6

Rep: Reputation: 0
For when you decide to give it another try:

make /etc/apt/sources.list read like the following (subsitute your preferred mirror host for
# official stable
deb stable main contrib non-free
deb-src stable main contrib non-free

# official testing
deb testing main contrib non-free
deb-src testing main contrib non-free

# official unstable
deb unstable main contrib non-free
deb-src unstable main contrib non-free

# official security updates
deb stable/updates main
make /etc/apt/apt.conf.d/70debconf read like:
APT::Cache-Limit 10485760;
APT::Default-Release "stable";

// Pre-configure all packages with debconf before they are installed.
// If you don't like it, comment it out.
DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};
The upped Cache-Limit is a bit of a bug fix. Without it, you won't be able to process the list of packages. The second line makes Debian stick to the stable distribution unless you tell it otherwise. This is one way to eliminate the need to comment/uncomment blocks in sources.list all the time.

Finally, if it doesn't yet exist, create /etc/apt/preferences like this:
Explanation: see
Package: *
Pin: release o=Debian,a=stable
Pin-Priority: 900

Package: *
Pin: release o=Debian,a=testing
Pin-Priority: 400

Package: *
Pin: release o=Debian,a=unstable
Pin-Priority: 300

Package: *
Pin: release o=Debian
Pin-Priority: -1
This is used to keep things under control when sources.list pulls in more than two releases. If you only want to install from two (say stable and testing, or testing and unstable), you don't need it.

You can now install from any of the official releases. Just remember to run 'apt-get update' before your first install of testing/unstable on any given day. Use the '-t' flag with 'install' to indicate the release you want to use. This will automatically add/upgrade the packages required by whatever you're trying to install.

So: 'apt-get -t testing install xserver-xfree86' grabs XFree86 4.3.x and all the packages that need to be upgraded


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
TV-Out with Radeon 9600 NullDevice23 Linux - Hardware 2 05-23-2005 11:01 AM
radeon 9600 help itywygms Linux - Newbie 10 08-27-2004 07:17 PM
Radeon 9600 jjreid Linux - Software 0 03-23-2004 08:05 PM
radeon 9600 se Motown Mandriva 0 03-20-2004 10:34 AM
Radeon 9600 xt casimir Linux - Hardware 1 02-08-2004 06:08 AM > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:27 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration