-   Debian (
-   -   Quagga permission issue (

navic 03-13-2012 06:42 PM

Quagga permission issue
I'm running the embedded distro Voyage on an ALIX board. It's a derivative of Debian. I've tried the Voyage mailing list with no luck, so hopefully you guys can help me out.

Installed quagga via apt-get install, went fine. I copied over the example files into /etc/quagga then changed the permissions to quagga.quaggavty and chmod 640 as shown on this page but quagga is still failing:


root@voyage:/etc/quagga# /etc/init.d/quagga start 
Loading capability module if not yet done.
WARNING: All config files need .conf: /etc/modprobe.d/hostap-utils, it will be ignored in a future release.
WARNING: /etc/modprobe.d/ALIX.conf line 8: ignoring bad line starting with 'options'
WARNING: /etc/modprobe.d/ALIX.conf line 9: ignoring bad line starting with 'options'
Starting Quagga daemons (prio:10): zebravty_read_config: failed to open configuration file /etc/quagga/zebra.conf: Permission denied
can't open configuration file [/etc/quagga/zebra.conf]

The zebra.conf file is there:


root@voyage:/etc/quagga# ls -l
total 12
-rw-r----- 1 quagga quaggavty 849 Mar 13 22:24 daemons
-rw-r----- 1 quagga quaggavty 471 Oct  2 10:22 debian.conf
-rw-r----- 1 quagga quaggavty 385 Mar 13 22:25 zebra.conf

I've tried changing the /etc/quagga directory and files to root.root, quagga.quagga with no luck. Can anyone point me in the right direction?


All times are GMT -5. The time now is 03:29 PM.