LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Q1: Setting DMA Mode with hdparm (https://www.linuxquestions.org/questions/debian-26/q1-setting-dma-mode-with-hdparm-299758/)

mattz40 03-09-2005 05:09 PM

Q1: Setting DMA Mode with hdparm
 
I was running Debian Woody compact flavor and was having great results turning DMA on using 'hdparm -d1 /dev/hda' Buffered disk reads would go up by a factor of 10 when it was turned on. I've since switched to the bf24 flavor in an attempt to fix a slow network problem and add usb support. It didn't fix the network problem, does see the usb port, but now i can't turn on DMA.
When I issue the same command I get the following error:
HDIO_SET_DMA failed: Operation not permitted
I am of course entering the command as root. Anyone have any suggestions? Thanks in advance.
Matt

slackie1000 03-10-2005 07:28 AM

hi there,

did you compile this kernel by yourself? i would say that the problem is in the kernel: IDE/DMA options.
how are they defined? are you sure that the module of the chipset of your disk is loaded or compiled as builtin?

regards

slackie1000

dastrike 03-10-2005 12:11 PM

Unless you have some special reasons for running Debian 3.0 ('woody', current stable release) as that is three years old, I recommend installing Debian testing ('sarge', what will become the next release 3.1), that is much better to use currently for desktop/workstation purposes.

What hardware do you have? Your DMA issues could be because your hardware could be considerably newer than the kernel in Debian 3.0 ('woody') as that is three years old and thus cannot possibly have proper support for all the very latest hardware.

mattz40 03-15-2005 05:52 PM

No, I didn't compile this, that is beyond me. I'm using the stable release off the Debian site. I was hoping I overlooked something since I could turn on DMA under the 'compact' flavor of Woody but can't under the 'bf24' flavor. I'll Try Sarge since I can't get the network speed up to a reasonable level and I can't live with that.
Thanks for the advice.


All times are GMT -5. The time now is 07:27 PM.