LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-21-2011, 07:18 PM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Rep: Reputation: 50
PulseAudio configured for per-user sessions ... (warning).


hi

During the wheezy startup I get this message on the screen:

PulseAudio configured for per-user sessions ... (warning).

Even if I try to restart pulseaudio:
Code:
# /etc/init.d/pulseaudio restart
PulseAudio configured for per-user sessions ... (warning).
Anyone knows howto solve this?
 
Old 11-21-2011, 10:15 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
From the man page:
Code:
--system[=BOOL]
              Run  as  system-wide  instance instead of per-user. Please note that this disables certain features of PulseAudio and is generally not recommended unless the system knows no local
              users (e.g. is a thin client). This feature needs special configuration and a dedicated UNIX user set up. It is highly recommended to combine this  with  --disallow-module-loading
              (see below).
I would take a look at both your config file, and your init.d config, and have a closer look at how it is being started. Are you starting pulseaudio manually?
 
Old 11-22-2011, 08:02 PM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by corp769 View Post
I would take a look at both your config file, and your init.d config, and have a closer look at how it is being started. Are you starting pulseaudio manually?
I don't know which config file:
Code:
# ls /etc/pulse
client.conf  daemon.conf  default.pa  system.pa
should be changed and pulseaudio is started automatically during the startup.


My /etc/init.d/pulseaudio:
Code:
# cat /etc/init.d/pulseaudio

#!/bin/sh -e
### BEGIN INIT INFO
# Provides:          pulseaudio esound
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Should-Start:      udev NetworkManager
# Should-Stop:       udev NetworkManager
# Default-Start:     2 3 4 5
# Default-Stop:      1
# Short-Description: Start the PulseAudio sound server
# Description:       System mode startup script for
#                    the PulseAudio sound server.
### END INIT INFO

DAEMON=/usr/bin/pulseaudio
PIDDIR=/var/run/pulse
PIDFILE=$PIDDIR/pid
DAEMONUSER=pulse
PATH=/sbin:/bin:/usr/sbin:/usr/bin

test -x $DAEMON || exit 0

. /lib/lsb/init-functions

PULSEAUDIO_SYSTEM_START=0
DISALLOW_MODULE_LOADING=1
test -f /etc/default/pulseaudio && . /etc/default/pulseaudio
if [ "$PULSEAUDIO_SYSTEM_START" != "1" ]; then
        log_warning_msg "PulseAudio configured for per-user sessions"
        exit 0
fi

pulseaudio_start () {
        log_daemon_msg "Starting system PulseAudio Daemon"
        if [ ! -d $PIDDIR ]; then
                mkdir -p $PIDDIR
                chown $DAEMONUSER:$DAEMONUSER $PIDDIR
        fi
        start-stop-daemon -x $DAEMON -p $PIDFILE --start -- --system --daemonize --high-priority --log-target=syslog --disallow-module-loading=$DISALLOW_MODULE_LOADING
        status=$?
        if [ -e /var/run/pulse/.esd_auth ]; then
                chown pulse:pulse-access /var/run/pulse/.esd_auth
                chmod 640 /var/run/pulse/.esd_auth
        fi
        if [ -e /var/run/pulse/.pulse-cookie ]; then
                chown pulse:pulse-access /var/run/pulse/.pulse-cookie
                chmod 640 /var/run/pulse/.pulse-cookie
        fi
        log_end_msg ${status}
}

pulseaudio_stop () {
        log_daemon_msg "Stopping system PulseAudio Daemon"
        start-stop-daemon -p $PIDFILE --stop --retry 5 || echo -n "...which is not running"
        log_end_msg $?
}

case "$1" in
        start|stop)
                pulseaudio_${1}
                ;;
        restart|reload|force-reload)
                if [ -s $PIDFILE ] && kill -0 $(cat $PIDFILE) >/dev/null 2>&1; then
                        pulseaudio_stop
                        pulseaudio_start
                fi
                ;;
        force-stop)
                pulseaudio_stop
                killall pulseaudio || true
                sleep 2
                killall -9 pulseaudio || true
                ;;
        status)
                status_of_proc -p $PIDFILE "$DAEMON" "system-wide PulseAudio" && exit 0 || exit $?
                ;;
        *)
                echo "Usage: /etc/init.d/pulseaudio {start|stop|force-stop|restart|reload|force-reload|status}"
                exit 1
                ;;
esac

exit 0
 
Old 11-22-2011, 09:32 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
After looking at what you gave me, post the output of the following for me:
Code:
echo $PULSEAUDIO_SYSTEM_START
Hopefully, this gives us something, as this is the underlying problem.
 
Old 11-23-2011, 05:28 AM   #5
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Code:
# echo $PULSEAUDIO_SYSTEM_START

#
 
Old 11-23-2011, 06:50 AM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
All you need to do is change the following in your init.d file:
Code:
PULSEAUDIO_SYSTEM_START=1
And that should be it.

Cheers,

Josh
 
Old 11-23-2011, 02:14 PM   #7
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by corp769 View Post
All you need to do is change the following in your init.d file:
Code:
PULSEAUDIO_SYSTEM_START=1
And that should be it.

Cheers,

Josh
I have changed, but still get this boot text message during the startup:

PulseAudio configured for per-user sessions ... (warning).
 
Old 11-29-2011, 01:22 PM   #8
m0g
LQ Newbie
 
Registered: Nov 2011
Posts: 1

Rep: Reputation: Disabled
The point is you need to change PULSEAUDIO_SYSTEM_START in /etc/default/pulseaudio

But for me it doesn't change anything, pulseaudio's still not working.
 
Old 11-30-2011, 10:10 PM   #9
62chevy
Member
 
Registered: Mar 2002
Location: West (By God) Virginia
Distribution: Debian Squeeze - Sid
Posts: 281

Rep: Reputation: 45
Quote:
Originally Posted by cccc View Post
I have changed, but still get this boot text message during the startup:

PulseAudio configured for per-user sessions ... (warning).
The first time I installed Sid I had to add my user to pulse and pulse-access as well as audio to get it to work. This time it just worked with me being added to audio only.

And I still get the warning too just ignore it.
 
1 members found this post helpful.
Old 07-12-2013, 07:04 PM   #10
jikun
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Rep: Reputation: Disabled
Post Please Pardon the Necromancy

I'm posting this for the sake of Googlers. According to the PulseAudio Wiki, system wide mode is only recommended for minimalist installs (such as embedded clients) where there aren't really any users per say. System wide mode creates a few security issues. I believe it also disables a few features of PulseAudio. The recommended mode is per-user configuration.

So, unless you specifically need to disable per-user configuration in order to use PulseAudo, then it is safest to ignore the warnings at boot.
 
Old 07-17-2013, 12:25 AM   #11
Soapm
Member
 
Registered: Dec 2012
Posts: 182

Rep: Reputation: Disabled
I know this isn't yours to answer but shouldn't the warning be for system wide mode since it's the non-preferred setting? Why warn you when it's running as it should? That's generated so many questions it isn't funny.

It's like having your check engine light on to say the engine is running fine.
 
Old 07-17-2013, 12:52 AM   #12
jikun
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by Soapm View Post
I know this isn't yours to answer but shouldn't the warning be for system wide mode since it's the non-preferred setting? Why warn you when it's running as it should? That's generated so many questions it isn't funny.

It's like having your check engine light on to say the engine is running fine.
Exactly. It is very counter-intuitive for the end user.
 
Old 01-06-2014, 04:19 AM   #13
ear
LQ Newbie
 
Registered: Jan 2014
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by m0g View Post
The point is you need to change PULSEAUDIO_SYSTEM_START in /etc/default/pulseaudio

But for me it doesn't change anything, pulseaudio's still not working.

set it on "pulseaudio_system_start=1"
and "disallow_module_loading=0" in /etc/default/pulseaudio

so it sill working without this message, perharps it is not really good, however it works on my machine fine! no difference between now to before!

ron
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Squeeze + Pulseaudio + Alsa and USB Midi device causes Pulseaudio crash mad4linux Debian 1 01-26-2011 04:57 AM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 08:30 AM
[SOLVED] How to track the user sessions hiarunn Linux - Desktop 4 12-02-2009 01:07 AM
[Pulseaudio] how to change user settings using a command line ? Ed38 Linux - Software 1 12-23-2007 02:31 PM
record of user sessions PirateJack Linux - Newbie 5 04-03-2006 03:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration