-   Debian (
-   -   PS/2 mouse error in psmouse.c (

kushalkoolwal 08-15-2005 04:23 PM

PS/2 mouse error in psmouse.c
I have been trying the Debian Sarge Distribution( Kernel 2.6.8) on two Single Board Computers. One has PS/2 port and the mouse is attached to it. I get no problems getting my Debian system running on these boards.

While the other board does not have any PS/2 port so the mouse is attached to USB port. After my installation is finished, when the Debian boots, I get kernel error message:

psmouse.c: bad data from KBC - time out bad parity.

I know that my Linux boots to the login prompt but the rate at which this message is thrown on my screen is so fast that I can't type anything. Everything loads fine except I get these messages continuously and at a very fast rate. It just freaks out.

I googled about this error message and it seems that there is some kind of bug in the kernel and people have suggested to manually change the kernel source such as in this website: to stop those error messages.

I am really not comfortable with modifying the kernel source and I have never done this before. Is there any other way by which I can achieve this? Does anyone know a patch for this which I can download and patched to my existing kernel?

Also, does anyone know a kernel parameter which we can give at the boot-time to disable all the PS/2 stuff.

Any help will be greatly appreciated.

aikidoist72 08-15-2005 06:27 PM

By the sounds of it the PS/2 mouse connection is built into the kernel. Here lies the problem. You can not - not load it!! It is part of the kernel. Either you need to load another kernel where the PS/2 is compiled as a module(or not at all), or compile a kernel yourself.

Compiling is not too difficult. Like anything it is just a process you need to follow. Configuring the kernel is harder, because you need to know your hardware.

kushalkoolwal 08-15-2005 07:18 PM

Thanks for the help.

How do I compile PS/2 as a module? Do you mean I should go make menuconfig way? Can anyone give more details?


kushalkoolwal 08-16-2005 02:57 PM

Does any one have any idea how can I compile the PS/2 mouse drives as Module or completely disable them.

Please help me.

aikidoist72 08-16-2005 05:41 PM


You need to compile a kernel. Although it is not too complicated to do so, it is not something you can't summarize here very well. Also there are a few Distro specific things you may have to have in your configuration in order to compile a working kernel. The best advice is for you to visit your distro's web site for any info regarding this. Once you have done a little research, then attempt to compile a kernel.

Try this a s a google search just to see how much info is out there

Kernel Compilation Guide

kushalkoolwal 08-17-2005 04:20 PM

Oh...I think I didn;t make myself clear. Well I have compiled Debian kernel couple of times (The Debian way and not the usual way). What I was asking is where can I find that option once I run the make menuconfig command.


aikidoist72 08-17-2005 05:08 PM

Ahhh righto,

Under the section

Device drivers -> Input device -> mouse

There you will need to unselect the PS/2 option. Just out of interest, have you tried


make xconfig
I find this much easier to navigate. With the description panel to help you, it makes compiling so much easier. You need to log into root to do this.

kushalkoolwal 08-17-2005 06:07 PM

Thanks!!!! Excellent!!!

Yes you are right.

make menuconfig does not give enough information. May be I will try xconfig this time as you suggested.

Will let you know how did it go.



kushalkoolwal 08-18-2005 10:46 AM

Thanks aikidoist72. It worked. I was successfully able to remove that error message. You are simply great!!!!!!

aikidoist72 08-18-2005 04:21 PM

Hey well done!! Did you like the xconfig better?

Glad to be of help. ;)

kushalkoolwal 08-19-2005 02:04 PM

Yes. It is way way better than menuconfig. Only thing is that one has to installed qt libraries which was so easy using apt-get. ;)

All times are GMT -5. The time now is 03:07 PM.