-   Debian (
-   -   proftp issue (

nomb 05-18-2007 09:31 AM

Few Misc Questions
Hey guys,

I'm starting to setup how I want my pII debian LAMP box and running into some trouble. Firstly, I'm not online so I can't install anything. I am running debian from a net install off of a virtual machine. (Just to practive until I setup the real thing) I installed proftpd and it keeps giving me an error which I think is maybe a hostname problem.

It tells me there is a problem resolving first the IPv6 hostname so I changed shadow.Linuxhouse to localhost.localdomain and now it tells me the same thing but with IPv4.

Why is vi messed up. This also was like this when I tried ubuntu. First I hit 'a' to edit the file then when I use any of the arrow keys or del or Backspace it puts letters and characters up on the screen instead of letting me edit the file. This only happens with vi not emacs.

Also, how can I turn off the terminal beep.
does etch not have .20 or .22 kernel?

thank you,



For the beeping I tried

echo 'set bell-style none' >> ~/.inputrc
bsetterm -blength 0

It still beeps.

Dutch Master 05-19-2007 04:23 PM

proftpd: sorry, no luck here...

Forget vi, nano is much more newbee friendly. It tells you what keys to press for which commands ;)

On the kernel stuff: you don't seem to grasp what Debian stands for. The main thing about Debian is to provide a stable (as in: it only moves when blasted by a nuke) distro for the userbase. If you want the latest and greatest in Linux-land, Debian is not for you... Try Fedora, Mandriva and (Open)Suse for the latest kernel releases instead. If you've decided you really cannot live with the standard 2.6.18 kernel, build one yourself or go for Lenny (current Testing). Keep in mind that the Testing designation really has a meaning: it can and probably will break, but not so bad as in Unstable...

nomb 05-19-2007 09:34 PM

I have been using fedora core since 1 and before, and have been using vi for many years. I don't need a 'newbie friendly' editor and prefer vi over anything else out there. For every debian based distro I've tried, vi hasn't worked.

TheLateJC 05-22-2007 01:39 AM

Your vi problem has something to do with terminal settings I'm guessing. I've seen it before on UNIX, but navigation always worksed outside of edit mode so I never bothered to address it.

you can turn off the speaker by blacklisting pcspkr. There is a thread here somewhere on it.

No idea on the kernel. I'm guessing they do.

I've not worked with proftpd for about 5 years so I'm not much help to you :(.

All times are GMT -5. The time now is 09:17 AM.