LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-13-2005, 12:56 PM   #1
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Rep: Reputation: 30
Problems with my printers and sarge


Hello,

i have just had an hd crash ( the was sarge mostly still in testing installed ) and so i have installed sarge stable on another hd.

The problem is that i am unable to configure my printer ( an epson c42 ) again ( in the past it just worked perfectly )

To do so i have tried both mozilla http://localhost:631 , and both foomatic-gui .

Result is the same: the test page works, then sometimes when i print with gv nothing happens, and sometimes when i print an image with the gimp i obtain the postscript text instead of the image.

Any ideas?

Thank you in adv.
 
Old 07-14-2005, 12:23 PM   #2
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
I have always found printer configuration in Linux to be rather confusing - printing is composed of so many layers.

I think your problem is that you don't have not configured your printer correctly from the CUPS frontend, or you are missing some essential packages. I usually install "foomatic-bin" with aptitude to get all printer drivers available, or gimpprint drivers if my printer is supported.

As I see it, if Gimp prints postscript files as ascii, you are missing the driver that converts the postscript to something hat the printer understands. Therefore your printer spits out only ascii.
 
Old 07-15-2005, 12:53 PM   #3
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Original Poster
Rep: Reputation: 30
Thank you basileus, i'll install foomatic-bin too. With the hd crash i have also lost my packages list, and this could be the final solution.

Anyway now i have partially solved the problem with apps like OpenOffice and gv.

But gimp problem is still here.
Do i need to click on setup printer and choose my printer in the print dialog box of gimp?

Currently i have:
lp -s -dstylus_c42 -oraw

and i bet it is the problem.

Could someone please past an example of a working config?
Thank you in advance.
 
Old 07-15-2005, 03:55 PM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally posted by mtb
Thank you basileus, i'll install foomatic-bin too. With the hd crash i have also lost my packages list, and this could be the final solution.

Anyway now i have partially solved the problem with apps like OpenOffice and gv.

But gimp problem is still here.
Do i need to click on setup printer and choose my printer in the print dialog box of gimp?

Currently i have:
lp -s -dstylus_c42 -oraw

and i bet it is the problem.

Could someone please past an example of a working config?
Thank you in advance.
WRT gimp you need to reconfigure the settings the -oraw suffix has to be removed as that tells it to send it to post script.
 
Old 07-19-2005, 03:11 PM   #5
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 17 Xfce
Posts: 284

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by TigerOC
WRT gimp you need to reconfigure the settings the -oraw suffix has to be removed as that tells it to send it to post script.
Ok, thank you a lot. This has solved the problem.

During the next days i'll have to add a ibm proprinter compatibile parallel printer ,i hope it won't be a problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New install of Sarge, some problems? lugoteehalt Debian 2 09-30-2005 07:51 AM
Mouse Problems under Sarge AlexMax Debian 4 09-06-2005 08:12 PM
HD problems on new install with sarge Conficere Linux - Hardware 2 09-28-2004 11:03 PM
Problems with sarge installation poofington Debian 2 05-02-2004 03:27 AM
recommendation on photo printers and general purpose printers raminolta Linux - Hardware 3 01-21-2004 01:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration