-   Debian (
-   -   Problems with HAL, dbus, network after Java install... (

JustMeAgain 09-12-2008 11:34 AM

Problems with HAL, dbus, network after Java install...
Running Debian Lenny/Testing on an AMD64 system with 2 Gig RAM, Gnome desktop.

Yesterday I went to install Jalbum to make some web photo albums. It said I needed a Java Virtual Machine so I downloaded and installed JRE Added it to the path and then Jalbum installed ok. Then rebooted for good measure.

First problem, GDM didn't come up, boots into command line. This seems to happen a lot, reinstalling xorg & xserver-xorg usually fixes it so I tried that. Apt can't find them, huh? Ok, next problem, no network connection, apt-get update can't resolve any of the repositories.

If I run xinit GDM starts up but gives an "Internal Error, Can't Initialize "HAL". No network connections still.

No boot log was created, nor syslog, they usually are. dmesg and xorg logs don't show any problems.

Running /etc/init.d/dbus returns to the prompt with no message.
Running /etc/inid.d/hal fails asking if dbus is running.
I seem to have dbus-1 installed which may be different than dbus.

Not sure what to do at this point. Got any hints?

(kernel is

JustMeAgain 09-12-2008 03:35 PM

At least any ideas how to get network connection back to get apt functionality?

JustMeAgain 09-13-2008 12:32 PM

Can't access my USB drives either. I'm thinking that the Java install messed with the dbus but not sure. Uninstalling Jalbum didn't make a difference. Java was installed from a deb package with dpkg.

Anything, anyone?

JustMeAgain 09-13-2008 01:15 PM

Argh, many of the scripts (including dbus and bootlogd) in /etc/init.d/ are 0 bytes. So not running the programs. All dated 9/11. Did terrorists get me?

JustMeAgain 09-13-2008 03:20 PM

I was able to get many of the /etc/init.d scripts by booting from a live CD, doing some mounting and copying. (I wasn't able to mount anything from the hard disk boot). I am still missing a lot of them though. I'm back online but a lot of programs don't start up, all my servers are still down. Trying to look for the scripts one at a time will take days.

Does anyone know a repository or collection of init.d scripts for Debian online?

It looks to me now that this problem had nothing to do with the Java install. I'm guessing I was hacked or got a malicious script.

JustMeAgain 09-13-2008 05:31 PM

Actually, if anyone is in a really, really helpful mood and can zip/tar and post as many of the following as they can from their /etc/init.d directory (Debian Lenny) I will forever be in their debt, will owe them many beers, my firstborn, or whatever...

alsasound courier-imap-ssl mysql-ndb rmnologin
amule-daemon courier-pop mysql-ndb-mgm rsync
apache2 courier-pop-ssl nfs-common samba
atd dirmngr nfs-kernel-server saslauthd
autofs exim4 ntp sendmail
bacula-director festival nvidia-glx slapd
bacula-fd fetchmail nvidia-glx-legacy slpd
bacula-sd heartbeat nvidia-kernel spamassassin
bind9 irmp3 portmap squid
binfmt-support ispconfig_server postgresql-7.4 ssh
clamav-daemon ld10k1 pptpd webmin
clamav-freshclam lisa proftpd winbind
courier-authdaemon mon pulseaudio
courier-imap mysql quotarpc

JustMeAgain 09-13-2008 06:22 PM

Found copies, thanks anyway, nice chatting with myself. ;)

All times are GMT -5. The time now is 04:29 AM.