LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-02-2005, 06:08 PM   #1
REHead
LQ Newbie
 
Registered: Sep 2005
Location: Port St. Lucie, Florida
Posts: 4

Rep: Reputation: 0
Problems starting GDM


Well, it of course has to be right after I fix one problem, another comes rolling along. I updated gdm, and tweaked the configuration file a bit.. Then, after all was updated and configured, I went to go log in to a GDM session, though nothing comes up.. I'll either get a blank screen, or the Debian splash.. And that's it.. My GDM log only shows one problem, but I'm not sure if this would be it... Here's the log:

Module Loader present
OS Kernel: Linux version 2.4.18-bf2.4 (root@zombie) (gcc version 2.95.4 20011002 (Debian prerelease)) #1 Son Apr 14 09:53:28 CEST 2002 T
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Sep 2 05:43:31 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols found

Any suggestions would be appreciated.. Take it easy.
 
Old 09-03-2005, 02:47 AM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
If you didn't tamper with XF86Config-4 and have just tweaked gdm then you can restore the gdm by doing apt-get --purge remove gdm then apt-get install gdm.
 
Old 09-03-2005, 11:02 AM   #3
REHead
LQ Newbie
 
Registered: Sep 2005
Location: Port St. Lucie, Florida
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, well, I just found something else out.. Whenever I remove dhcp
from my loopback interface in the interfaces, GDM will start fine.
Though, when dhcp is removed from the loopback interface, I am not
able to get connected to DSL.. Is there any way around this?
 
Old 09-03-2005, 03:22 PM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Please post your /etc/network/interfaces because it isn't clear what you doing. If you want to automatically get a lease you should have an entry like;

auto eth0
iface eth0 inet dhcp

Problems with getting a lease or finding an ip address can cause the system to stall while it tries and it can be lengthy till it abandons the attempt.
 
Old 09-03-2005, 05:01 PM   #5
REHead
LQ Newbie
 
Registered: Sep 2005
Location: Port St. Lucie, Florida
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, well, I do have my eth0 interface configured correctly,
and here is my interfaces:

auto lo
iface lo inet loopback dhcp

auto eth0
iface eth0 inet dhcp

And that's it. I know that there are too many options on the lo
interface, though right now, that is how I am getting connected.
But, with the dhcp option, GDM hangs after login, and without it,
I am unable to connect... Take it easy
 
Old 09-03-2005, 07:19 PM   #6
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 49
try this first

dpkg --purge gdm

and then do

apt-get install gdm
 
Old 09-04-2005, 12:13 PM   #7
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally posted by REHead
Ok, well, I do have my eth0 interface configured correctly,
and here is my interfaces:

auto lo
iface lo inet loopback dhcp

auto eth0
iface eth0 inet dhcp

And that's it. I know that there are too many options on the lo
interface, though right now, that is how I am getting connected.
But, with the dhcp option, GDM hangs after login, and without it,
I am unable to connect... Take it easy
I don't think that the loopback interface is valid and I cannot see or find any reason to structure it like that. The loop back connects to your local 127.0.0.1 server. This should have no effect on the network cards or their connection to another network. I am not networking expert and perhaps this question should be addressed in the network forum where other more experienced than me can address this.
 
Old 09-04-2005, 12:35 PM   #8
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
I would just remove dhcp from local which means:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting up KDM instead of GDM? vbraun Fedora 9 01-19-2007 12:14 PM
Starting Xterm in X through GDM flower.Hercules Linux - General 1 10-15-2005 03:37 PM
Starting gdm instead of shell login calcon Slackware 1 04-10-2005 11:17 AM
typing gdm, starting kde javb Linux - Newbie 2 03-10-2005 11:55 AM
gdm fails to finish starting, why? mark_umr Linux - General 1 12-20-2002 12:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration