-   Debian (
-   -   Problems getting a GUI and internet connection with VIA Tech. drivers (

cillm527 05-29-2005 04:48 PM

Problems getting a GUI and internet connection with VIA Tech. drivers
I just installed the latest "stable" version of debian. I used to use SuSE, on which I could easily use KDE, internet, etc.

My computer has VIA drivers..

When I type in 'startx' in Debian, it always brings up "no screens found" error. This is when I tried the VESA driver option, because VIA was not an option. Next, I tried VGA driver option, I barely got a GUI...It was really fuzzy, when I clicked on something it moved slowly (I guess it didnt detect my video card), and I still had no internet connection.

I read the Debian installation manual, so I've pretty much done this "by the book". The kernel I used was "compact", because the installation manual on the website said that the 'compact' kernel was compatible with VIA Rhine stuff...

Here's the manual:
(i dont have enough posts to post a link, so it's at the debian website, sorry)

Here's the page I was referring to....
(chapter 4.2.2)

If you can solve this problem, or know someone who does, please help.

If you don't, then at least reccommend a different distro; I'm open to others. I just want to use Linux as my operating system.

EDIT: I've also tried using an opensource VIA driver a friend directed me to, but it didn't work either...

EDIT #2: I also don't understand why Linux seems to be so hardware specific. Only certain people who bought the perfect, matching, exact hardware should be able to use Linux? Seriously, though, I have a little less than $0US at my disposal, so I'm really hoping there's a way around this...

comprookie2000 05-29-2005 06:44 PM

Run as root #dpkg-reconfigure xserver-xfree86 and make sure you know your monitors rates. I couldn't find the "via" selection also so I just edited XF86Config-4 and it worked,but that was on sarge.
for the internet what happens when you do ifconfig as root. If the interface isn't showing up try modprobe via-rhine then dhcpcd if you connect that way.good luck
also post uname -a that kernel may be old,if it gets to be 2 much trouble Mepis is pretty good.

cillm527 05-29-2005 07:41 PM

Thanks, man.

That's another problem, though. I couldn't find XF86Config-4, because after I had ran dpkg-reconfigure xserver-xfree86 a million times, trying the different drivers, I just wanted to try editing it myself.

I'll try those other commands your mentioned, but I have never even seen them before. Thanks a lot, and wish me luck.

comprookie2000 05-29-2005 08:02 PM

It may just be XF86Config

cillm527 05-29-2005 08:18 PM

Can you give me a directory?

comprookie2000 05-29-2005 08:33 PM

/etc/X11 sorry about that:eek:

cillm527 05-29-2005 09:31 PM

No problem, man. By the time I got back to see your reply, I had already found it with the 'find' command...

Well, I tried editing it...and apprantly, searching for "vesa", changing "vesa" to "via" didnt work. It said via module didnt exist. What exactly do I have to change?

comprookie2000 05-29-2005 09:38 PM

First thingis to get on the net and then you can use apt to get a newer kernel that has the via driver in it.That is what I would do first.Do you have a AMD cpu?This is how I install debian sarge;

cillm527 05-29-2005 09:44 PM

I'm not sure if I have sarge, I dont think so...

But, the computer doesn't have connection to the internet, remember? So, I guess I should download this Sarge, burn another CD, and try my luck again.

Which one is "Sarge", though? Is it the current, stable one, or the "testing" one?

EDIT: And, no, I think my CPU is Intel x86.

EDIT: Also, I dont even know which files I should download. I've been wrestling with this for about two days, and I'm really tired, not to mention frustrated, since SuSE and WINDOWS-XP had absolutely no problem detecting my video card or my network card, so I'm having a hard time understanding what the deal is with Debian, so please be patient with me, if I'm a little slow.

vharishankar 05-29-2005 11:45 PM

To configure your X, you can also run

This will run a prompt-by-prompt utility where you can configure all aspects of X including drivers. I'm sure the Via chipset is supported.

comprookie2000 05-30-2005 09:31 AM

You should be able to get the internet working.this would be a good time to learn.first post as root ifconfig if your card is detected than you will see a listing for eth0 if you only have one card.Then there is only two files to edit;

How do you connect to the is mine I connect to a dsl modem;

# /etc/resolv.conf

    search launchmodem
    nameserver  <--- this is the modems address----

next is


# /etc/network/interfaces
This file contains the IP information that your system uses to work with the NIC(s).
There is a parent entry for each NIC, and the information for the NIC is listed
underneath it like so:

auto eth0
iface eth0 inet static
        gateway <--- again the modem----

That is for static
This is for dhcp

  auto eth0
  iface eth0 inet dhcp

if you use dhcp then you don't need to fool with /etc/resolv.conf
You can manually start the network with ifup eth0.
That is if you see eth0 when you do

ifconfig eth0
Now how do you connect?

cillm527 05-30-2005 09:52 AM

Harishankar: Thanks. There were over 1000 options available...VIA wasn't one of them. :(


I connect to the internet with DSL. I just connect this long ethernet cable to the hub. There was no /etc/resolv.conf. I'm in the process of writing down what root ifconfig returns. I can tell you now that it didnt look like either 'code' segement you posted =(

Thanks for the help, at this rate I might have this done by the end of the day =)

Also, I'm trying to download debian-testing-i386-binary-1.iso, but nobody is seeding it, and when i try to directly download it, sometimes it'll freeze right in the middle.

comprookie2000 05-30-2005 09:55 AM

Use the one in post #8
get the netinst CD image (100 Mb) i386
I just installed it a few days ago on a via motherboard when you boot put
linux26 I think,whatever will give you the 2.6 kernel, it is in the options.Press F1 or something.
may be debian26

comprookie2000 05-30-2005 10:06 AM

Does it look like this;
abbottdavid david # ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:0C:F1:E4:80:F6
inet addr: Bcast: Mask:
inet6 addr: fe80::20c:f1ff:fee4:80f6/64 Scope:Link
RX packets:1460665 errors:0 dropped:0 overruns:0 frame:0
TX packets:1026160 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1991553084 (1899.2 Mb) TX bytes:149416221 (142.4 Mb)

abbottdavid david #
You don't need to write it all down if you see eth0 that means your card is ready;

You know you're using the computer too much when:
you look out of the bus/car window on the way to work and think "hey, these
graphics are pretty cool"

cillm527 05-30-2005 10:14 AM

Nope, not an "eth0" to be found. I'll downloaded the net thing, though, and I'm fixing to burn it. I'll be back on when family members are done using the computer. Wish me luck. And thanks, again.

All times are GMT -5. The time now is 02:01 AM.