-   Debian (
-   -   problem with wireless on dell d600 (

mark_alfred 08-04-2011 07:42 PM

problem with wireless on dell d600
Hello. I bought a used dell d600. I initially installed debian lxde on it, and then tried to set up wicd. I was unable to get this to pick up wireless signals. So I installed the default (gnome) on it (speaking of newly installing the OS). I did manage to get this working (specifically network-manager-gnome).

I figured that I had accidentally pressed the Fn-F2 key deactivating the wireless when I was attempting to press Alt-F2 to use the run application box. So I once again re-installed the lxde option (a new install). However, this time, I was not given the option to install non-free options for the wireless hardware. This is an option during the install that I had been given in all previous installations. I had used a usb-stick with firmware files that had several debian files on it. The one that it specifically wanted was ipw2x00. So, I installed this later, but not during the initial install. I'm not sure if this makes a difference, but it seems to.

I tried to set up wicd, and this failed. In doing so, I made sure that the Fn-F2 key was allowing wireless. Failing with wicd, I got rid of it, and install network-manager-gnome in lxde. However, this too is not working, even though in a previous install I had been able to get this to work.

I'm really hoping to get wicd working, but at this point, I'll settle for getting network-manager-gnome working. Any suggestions?

PS, when I initially set up wicd, I did follow the instructions at

widget 08-04-2011 08:39 PM

I have never seen Debian offer to install non-free soft ware on one of their install disks. Not saying it doesn't but find it hard to believe considering their removal of non-free stuff that is included in the Linux kernel.

If you have a wired connection, I assume you do as you installed the gnome package, you need to edit your sources list and install some things.

A sample of what it needs to look like;

deb testing main contrib non-free
deb testing/updates main contrib non-free
Run as root;

apt-get update

apt-get install firmware-linux
you should actually have the free stuff but that is a meta package depending on both the free and non-free Debian packages.

Try setting it up again and if it works mark this solved. If not try the command in terminal and post the output here. Someone that knows more about wireless than I do will undoubtedly know what to do.

You need those non-free packages first of all.

mark_alfred 08-04-2011 10:40 PM

I have the packages "firmware-linux-free" and "firmware-linux-nonfree" installed. Still no luck. I also, as I mentioned, installed firmware-ipw2x00. Regarding the Debian install being "hard to believe", feel free to read about it here -- "Installation via Debian Installer". As the site mentions, it prompted me for the ipw2100-1.3.fw driver. So, I used a usb-stick with the debs from the non-free firmware tarball. This did work the first time, but as I mentioned, the installer did not give such a prompt the second time.

The result of iwconfig is this:

root@debian:/home/mark# iwconfig
lo    no wireless extensions.

pan0  no wireless extensions.

mark_alfred 08-04-2011 11:51 PM

Okay, just to add some further information. dmesg gives the following:

ipw2100:  Detected Intel PRO/Wireless 2100 Network Connection
ipw2100 0000:02:03.0:  firmware:  requesting ipw2100-1.3.fw
ipw2100:  eth0:  ipw2100_verify failed:  -5
ipw2100:  eth0:  Failed to power on the adapter.
ipw2100:  eth0:  Failed to start the firmware.
ipw2100Error calling register_netdev
ipw2100 0000:02:03.0: PCI INT A disabled
ipw2100:  probe of 0000:02:03.0 failed with error -5

I've been trying some of the suggestions at this site here. But, no luck. I guess I'll try a fresh install, and see if I have better luck this time.

cynwulf 08-05-2011 04:50 AM

1) Connect to your router using an ethernet cable
2) Enable the non-free repo.
3) Install the package "firmware-ipw2x00"
4) Reload the module


modprobe -r ipw2100 ; modprobe ipw2100
(Read the documentation for this - it's all in there:

If the output of "iwconfig" gives you, e.g, "wlan0" then install wicd go into "preferences" and manually enter the interface name (it's always blank).

mark_alfred 08-05-2011 05:34 AM

Well, I did a fresh install (gnome this time) and still no luck. I get much the same:

root@debian:/home/mark# iwconfig
lo    no wireless extensions.

pan0  no wireless extensions.

root@debian:/home/mark# if config eth1 up
eth1:  ERROR while getting interface flags:  No such device

I have followed all the advice of the ipw2100 site, and have had no luck. All suggestions are welcome.

mark_alfred 08-05-2011 06:06 AM


Originally Posted by Caravel (Post 4434339)
1) Connect to your router using an ethernet cable

Don't have ethernet. I do have dial-up, though. In fact, even if I did have a wired connection, another problem with the install seems to be that the Broadcom NetXtreme BCM5700 series 10/100/1000 Mbps Ethernet Network Controller of the laptop was not recognized.

Originally Posted by Caravel (Post 4434339)
2) Enable the non-free repo.
3) Install the package "firmware-ipw2x00"


Originally Posted by mark_alfred (Post 4434137)
I also, as I mentioned, installed firmware-ipw2x00.


Originally Posted by Caravel (Post 4434339)
4) Reload the module


modprobe -r ipw2100 ; modprobe ipw2100
(Read the documentation for this - it's all in there:


Originally Posted by mark_alfred (Post 4434176)
I've been trying some of the suggestions at this site here ( But, no luck.

In fact, I tried pretty well all of the suggestions there, including reloading the module. Still no luck. Thanks for the feedback, however. All ideas are appreciated.

cynwulf 08-05-2011 06:07 AM


Originally Posted by mark_alfred (Post 4434369)
Well, I did a fresh install (gnome this time) and still no luck. I get much the same:

root@debian:/home/mark# iwconfig
lo    no wireless extensions.

pan0 no wireless extensions.

You've reinstalled several times... the outcome will be the same, i.e. missing firmware, so I'm not sure what you're trying to achieve with that...? Whatever desktop you install will make no difference to the wireless interface: hint the firmware is missing and thus the device is working - at all.

Have you checked output of


dmesg | grep firmware
again? Until you can post that here showing firmware being loaded, no one is going to be able to assist you (post #4 clearly shows that the firmware fails to load). Please show that firmware is loaded and device shows up in iwconfig - don't waste your time with different desktops, wicd or network-manager until then...


Originally Posted by mark_alfred (Post 4434369)
root@debian:/home/mark# if config eth1 up
eth1: ERROR while getting interface flags: No such device[/code]

There is no sense in trying to put up an interface which doesn't exist.

mark_alfred 08-05-2011 06:36 AM

Hello Caravell. Here's the dmesg:

root@debian:/home/mark# dmesg | grep firmware
[    5.941267] ipw2100 0000:02:03.0: firmware: requesting ipw2100-1.3.fw
[    6.293247] platform radeon_cp.0: firmware: requesting radeon/R200_cp.bin
[    6.320189] ipw2100: eth0: Failed to start the firmware.

Besides desperation, the only other reason I have tried reinstalling as a possible solution is from my past experience (which I mentioned in a previous post), in that during the initial installs, the Debian Installer recognized both the Broadcom NetXtreme Network card and it recognized the Wireless LAN 2100, requesting and installing ipw2100 from my usb-stick, and wireless worked (this capability of the Debian Installer is mentioned in the site you recommended.) Contrary to Steve McIntyre's claim that "d-i will do the right thing," recently the Debian Installer has NOT done the right thing. So, I've been trying the other ideas for "established systems" from the site you suggested.

Anyway, keep the ideas coming.

cynwulf 08-05-2011 06:53 AM


apt-cache policy firmware-ipw2x00
Verify it's actually there, it should be in "/lib/firmware/ipw2100-1.3.fw"

mark_alfred 08-05-2011 03:30 PM

Hello. Here's the result of the command you suggested, and some other exploratory commands I did:

root@debian:/media/usb# apt-cache policy firmware-ipw2x00 wireless-tools firmware-bnx2 firmware-bnx2x firmware-linux-nonfree firmware-linux-free wireless-tools:
  Installed: 30~pre9-5
  Candidate: 30~pre9-5
  Version table:
 *** 30~pre9-5 0
        500 cdrom://[Debian GNU/Linux 6.0.0 _Squeeze_ - Official i386 DVD Binary-1 20110205-17:27]/ squeeze/main i386 Packages
        100 /var/lib/dpkg/status
  Installed: 2.6.32-30
  Candidate: 2.6.32-30
  Version table:
 *** 2.6.32-30 0
        500 cdrom://[Debian GNU/Linux 6.0.0 _Squeeze_ - Official i386 DVD Binary-1 20110205-17:27]/ squeeze/main i386 Packages
        100 /var/lib/dpkg/status
  Installed: 0.28
  Candidate: 0.28
  Version table:
 *** 0.28 0
        100 /var/lib/dpkg/status
  Installed: 0.28
  Candidate: 0.28
  Version table:
 *** 0.28 0
        100 /var/lib/dpkg/status
  Installed: 0.28
  Candidate: 0.28
  Version table:
 *** 0.28 0
        100 /var/lib/dpkg/status
  Installed: 0.28
  Candidate: 0.28
  Version table:
 *** 0.28 0
        100 /var/lib/dpkg/status

root@debian:/lib/firmware# ls
3com                                    atmel_at76c503-rfmd.bin          brcm                            kaweth            r128              sd8686_helper.bin
advansys                            atmel_at76c504_2958-wpa.bin  cf8385.bin                    keyspan_pda    radeon              sd8688.bin
agere_ap_fw.bin                            atmel_at76c504a_2958-wpa.bin  cf8385_helper.bin            lbtf_usb.bin    rt2561.bin              sd8688_helper.bin
agere_sta_fw.bin                    atmel_at76c504.bin                  cis                            matrox            rt2561s.bin        STLC2500_R4_00_03.ptc
ar7010_1_1.fw                            atmel_at76c504c-wpa.bin          cxgb3                            mts_cdma.fw    rt2661.bin              STLC2500_R4_00_06.ssf
ar7010.fw                            atmel_at76c505a-rfmd2958.bin  dabusb                    mts_edge.fw    rt2860.bin              STLC2500_R4_02_02_WLAN.ssf
ar9170.fw                            atmel_at76c505-rfmd2958.bin  dsp56k                    mts_gsm.fw            rt2870.bin              STLC2500_R4_02_04.ptc
ar9271.fw                            atmel_at76c505-rfmd.bin          dvb-fe-xc5000-1.6.114.fw  NPE-B            rt3070.bin              tehuti
ath3k-1.fw                            atmel_at76c506.bin                  dvb-usb-dib0700-1.20.fw  NPE-B.01020201  rt3071.bin              tigon
atmel_at76c502_3com.bin                    atmel_at76c506-wpa.bin          e100                            NPE-C            rt3090.bin              usb8388.bin
atmel_at76c502_3com-wpa.bin            av7110                          hp                            NPE-C.02020201  rt73.bin              usb8682.bin
atmel_at76c502.bin                    BCM2033-FW.bin                  i2400m-fw-usb-1.4.sbcf    phanfw.bin            RTL8192E              v4l-cx2341x-dec.fw
atmel_at76c502d.bin                    BCM2033-MD.hex                  i2400m-fw-usb-1.5.sbcf    prism2_ru.fw    RTL8192SU              v4l-cx2341x-enc.fw
atmel_at76c502d-wpa.bin                    bnx2                          i6050-fw-usb-1.5.sbcf    prism2_ru.hex  rtl_nic              v4l-cx2341x-init.mpg
atmel_at76c502e.bin                    bnx2-06-4.0.5.fw                  ipw2100-1.3.fw            ql2100_fw.bin  rtlwifi              v4l-cx25840.fw
atmel_at76c502e-wpa.bin                    bnx2-09-4.0.5.fw                  ipw2100-1.3-i.fw            ql2200_fw.bin  ru010803.hex      v4l-pvrusb2-24xxx-01.fw
atmel_at76c502-wpa.bin                    bnx2x                          ipw2100-1.3-p.fw            ql2300_fw.bin  sd8385.bin              v4l-pvrusb2-29xxx-01.fw
atmel_at76c503-i3861.bin            bnx2x-e1-          ipw2200-bss.fw            ql2322_fw.bin  sd8385_helper.bin  zd1211
atmel_at76c503-i3863.bin            bnx2x-e1-          ipw2200-ibss.fw            ql2400_fw.bin  sd8682.bin
atmel_at76c503-rfmd-0.90.2-140.bin  bnx2x-e1h-          ipw2200-sniffer.fw            ql2500_fw.bin  sd8682_helper.bin
atmel_at76c503-rfmd-acc.bin            bnx2x-e1h-          ipw2x00.LICENSE            qlogic            sd8686.bin

root@debian:/lib/firmware# locate tg3

root@debian:/lib/firmware# cd /lib/modules/2.6.32-5-686/kernel/drivers/
root@debian:/lib/modules/2.6.32-5-686/kernel/drivers# ls
acpi  bluetooth    connector  dma        gpu        ide            isdn    media    misc  parport  power        scsi        staging    usb    w1
ata    cdrom            cpufreq    edac        hid        ieee802154  leds    memstick  mmc  pci      pps        serial  telephony  uwb    watchdog
atm    char            crypto    firewire  hwmon        infiniband  lguest  message  mtd  pcmcia    regulator  spi        thermal    video
block  clocksource  dca        firmware  i2c        input            md            mfd      net  platform  rtc        ssb        uio            virtio

root@debian:/lib/modules/2.6.32-5-686/kernel/drivers# cd firmware
root@debian:/lib/modules/2.6.32-5-686/kernel/drivers/firmware# ls
dcdbas.ko  dell_rbu.ko        edd.ko        efivars.ko

root@debian:/lib/modules/2.6.32-5-686/kernel/drivers/firmware# cd ..
root@debian:/lib/modules/2.6.32-5-686/kernel/drivers# cd net
root@debian:/lib/modules/2.6.32-5-686/kernel/drivers/net# ls
3c501.ko    ac3200.ko        bnx2x.ko    dnet.ko          eth16i.ko        igbvf                macvtap.ko    niu.ko              pppox.ko        sfc            sundance.ko    veth.ko
3c503.ko    acenic.ko        bonding      dummy.ko          ethoc.ko        ipg.ko                mdio.ko        ns83820.ko      ppp_synctty.ko  sis190.ko    sungem.ko            via-rhine.ko
3c505.ko    amd8111e.ko  bsd_comp.ko  e1000          ewrk3.ko        irda                mii.ko              pcmcia              qla3xxx.ko      sis900.ko    sungem_phy.ko  via-velocity.ko
3c507.ko    appletalk        can              e1000e          fealnx.ko        ixgb                mlx4              pcnet32.ko      qlcnic              skfp            sunhme.ko            virtio_net.ko
3c509.ko    arcnet        cassini.ko  e100.ko          forcedeth.ko  ixgbe                myri10ge      phy              qlge              skge.ko            tehuti.ko            vmxnet3
3c515.ko    at1700.ko        chelsio      e2100.ko          hamachi.ko        jme.ko                natsemi.ko    plip.ko              r6040.ko        sky2.ko            tg3.ko            vxge
3c59x.ko    atl1c        cnic.ko      eepro.ko          hamradio        ks8842.ko        ne2k-pci.ko    ppp_async.ko    r8169.ko        slhc.ko            tlan.ko            wan
8139cp.ko  atl1e        cs89x0.ko    eexpress.ko  hp100.ko        ks8851.ko        ne.ko              ppp_deflate.ko  rrunner.ko      slip.ko            tokenring            wd.ko
8139too.ko  atlx        cxgb3              enc28j60.ko  hp.ko        ks8851_mll.ko        netconsole.ko  ppp_generic.ko  s2io.ko              smc9194.ko    tulip            wimax
82596.ko    b44.ko        defxx.ko    enic          hp-plus.ko        lance.ko        netxen              ppp_mppe.ko    sb1000.ko      smc-ultra.ko  tun.ko            wireless
8390.ko    benet        depca.ko    epic100.ko  ifb.ko        lp486e.ko        ni52.ko        pppoe.ko        sc92031.ko      smsc9420.ko  typhoon.ko    yellowfin.ko
8390p.ko    bnx2.ko        dl2k.ko      eql.ko          igb                macvlan.ko        ni65.ko        pppol2tp.ko    seeq8005.ko    starfire.ko  usb            znet.ko

root@debian:/lib/modules/2.6.32-5-686/kernel/drivers/net# dmesg | grep firmware
[    5.322765] platform radeon_cp.0: firmware: requesting radeon/R200_cp.bin

root@debian:~# lsmod
Module                  Size  Used by
ipw2200              108368  0
isofs                  24608  0
udf                    62930  0
crc_itu_t              1035  1 udf
nls_utf8                908  1
nls_cp437              4489  1
vfat                    6570  1
fat                    34912  1 vfat
acpi_cpufreq            4951  0
cpufreq_userspace      1480  0
cpufreq_powersave        602  0
cpufreq_conservative    4018  0
cpufreq_stats          1940  0
ppdev                  4058  0
lp                      5570  0
sco                    5857  2
bridge                33019  0
stp                      996  1 bridge
bnep                    7444  2
l2cap                  21705  3 bnep
crc16                  1027  1 l2cap
bluetooth              36319  5 sco,bnep,l2cap
rfkill                10264  3 bluetooth
binfmt_misc            4907  1
uinput                  4796  1
fuse                  44033  1
loop                    9765  0
ipw2100                53316  0
libipw                18439  2 ipw2200,ipw2100
lib80211                2870  2 ipw2200,libipw
snd_intel8x0          19595  1
snd_intel8x0m          8100  0
snd_ac97_codec        79148  2 snd_intel8x0,snd_intel8x0m
ac97_bus                710  1 snd_ac97_codec
snd_pcm                47226  3 snd_intel8x0,snd_intel8x0m,snd_ac97_codec
snd_seq                35463  0
snd_timer              12258  2 snd_pcm,snd_seq
snd_seq_device          3673  1 snd_seq
pcmcia                16194  0
snd                    34375  9 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pcm,snd_seq,snd_timer,snd_seq_device
radeon                511184  2
ttm                    33386  1 radeon
drm_kms_helper        18309  1 radeon
drm                  112088  4 radeon,ttm,drm_kms_helper
joydev                  6739  0
i2c_algo_bit            3497  1 radeon
i2c_core              12696  4 radeon,drm_kms_helper,drm,i2c_algo_bit
yenta_socket          16403  4
rsrc_nonstatic          7057  1 yenta_socket
rng_core                2178  0
pcmcia_core            20450  3 pcmcia,yenta_socket,rsrc_nonstatic
soundcore              3450  1 snd
snd_page_alloc          5045  3 snd_intel8x0,snd_intel8x0m,snd_pcm
parport_pc            15799  1
parport                22554  3 ppdev,lp,parport_pc
shpchp                21220  0
evdev                  5609  14
battery                3782  0
button                  3598  0
ac                      1640  0
dcdbas                  3892  0
pcspkr                  1207  0
video                  14605  0
processor              26327  2 acpi_cpufreq
output                  1204  1 video
pci_hotplug            18065  1 shpchp
psmouse                44657  0
serio_raw              2916  0
ext3                  94212  2
jbd                    32169  1 ext3
mbcache                3762  1 ext3
usb_storage            30585  1
sg                    15968  0
sr_mod                10770  0
sd_mod                25977  6
crc_t10dif              1012  1 sd_mod
cdrom                  26487  1 sr_mod
ata_generic            2067  0
uhci_hcd              16057  0
ata_piix              17736  3
ehci_hcd              27851  0
thermal                9206  0
libata                115753  2 ata_generic,ata_piix
thermal_sys            9378  3 video,processor,thermal
usbcore                98453  4 usb_storage,uhci_hcd,ehci_hcd
scsi_mod              101429  5 usb_storage,sg,sr_mod,sd_mod,libata
nls_base                4541  7 isofs,udf,nls_utf8,nls_cp437,vfat,fat,usbcore

In searching the web, I found that this site here on devices and drivers for Dell's D600 suggested tg3 for the ethernet card and ipw2200 for the wireless. So, I made sure to have the tg3 and ipw2100 and ipw2200 drivers installed. Further, some sites recommended the bnx2 and bnx2x drivers for the Broadcom NetXtreme Gigabit Ethernet card (rather than tg3), so I made sure to install these and modprobe them (which seemingly worked, but they don't appear in the lsmod command above -- likewise I suspect the only reason the ipw2100 and ipw2200 modules do appear is that I just recently modprobed them before doing the lsmod command -- of course it hardly matters since they're used by nothing anyway).

I had mentioned the install a while back. Interestingly, during the last install, it indicated that no network or ethernet cards were found, but gave me the chance to pick drivers to be installed from a list. So, I tried to pick tg3 (which was listed) and bnx2/x also listed, but it would not let me. I then tried to have it scan the usb-stick, which had all these files on it, but it said nothing was found. So, I continued, and it gave me an ominous warning about modules (the exact warning I can't offhand recall). Anyway, I also installed kernal headers and made sure the linux image was installed (it is). I think I'll submit a bug to the debian-install program.

Anyway, hopefully this will give some information as to what I should do. I'm not going to attempt another install. I'll just try to fix it (and if I ever get it working, I'll definitely leave it this time.)

mark_alfred 08-07-2011 03:49 AM


Originally Posted by mark_alfred (Post 4434747)
I'm not going to attempt another install. I'll just try to fix it (and if I ever get it working, I'll definitely leave it this time.)

Hating to contradict myself, but I decided that there was nothing more that I could do to try and fix it. So, instead, I just turned off the computer, left it alone for the day while I went out and socialized with actual human beings, and then came back, and had another go at installing Debian. And this time, it indicated that it found both network devices (the Broadcom and the wireless), it scanned my usb-stick with the non-free driver for the wireless, and asked if I accepted the user-agreement for the non-free driver. I accepted. It then asked if I wanted wireless or the Broadcom ethernet device to be my default network connection, and I indicated that wireless should be it. Then, it installed Debian. AND, it was able to find the wireless connections -- from my neighbours, which are blocked to me, but this means that when I go to a cafe or a pub or the library or other place with free wifi, that I'll be able to use it.

Perhaps the computer was overworked, and needed a rest. Anyway, it did work. So, this is now solved.

All times are GMT -5. The time now is 12:17 PM.