LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-24-2010, 09:29 AM   #1
Treize.k
LQ Newbie
 
Registered: May 2006
Posts: 5

Rep: Reputation: 0
Problem with russian(?) text appearing in various places..


Hi,

I'm using Debian unstable with KDE. Today I suddenly noticed when doing a df command in Konsole that the column header titles were in russian or something.. Also when for example I download an image in Iceweasel and the file save dialog comes up, the labels on the buttons are in russian..
I already went to System Settings -> Regional & Language to add US English as a language. Country or region is not set but it says it defaults to generic English. Does anyone know what is causing this?

Thanks.
 
Old 04-25-2010, 06:22 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
try setting the default to the correct language/region.

What does
Code:
echo $LANG
give you ?
 
Old 06-29-2010, 01:22 PM   #3
Treize.k
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Hi, I'm sorry I didn't respond sooner. I thought I would try a full system upgrade. It didn't help.

It's starting to really annoy me now. Some things seem to be in Russian, others are in English.
Here are two links to screenshots of the 'russian' text, one in the console when executing 'df' and the other in the download dialog of iceweasel:

http://users.telenet.be/mordredshave...c/russian1.png
http://users.telenet.be/mordredshave...c/russian2.png

The really weird thing is that some applications display the menu in russian while other are in english. For example the gimp displays the menu (and other stuff) in russian, while filezilla is in english. Even though they both use GTK I think?

The value of $LANG is: be_BY@latin
Which is also not correct I guess. I am in Belgium but I just want the language to be english. I've set my location to United states and language to English in the KDE region and language settings though..

Any ideas?

Thanks.
 
Old 06-29-2010, 01:58 PM   #4
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
You could edit /etc/default/locale and change LANG and LANGUAGE to language you want (en_US.UTF8 is standard American English).
You could also put similar lines in your .bash_profile
LANG=en_US.UTF8
LANGUAGE=en_US.UTF8

You will need to log out and in again to see any effect.
 
Old 06-29-2010, 02:09 PM   #5
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
Or just try as root:

Code:
dpkg-reconfigure locales
 
Old 07-07-2010, 05:52 AM   #6
Treize.k
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks, that did the trick. Apparently I just didn't look hard enough.
I am still wondering why it is that I get russian text when my locale is set to Belgium though (fyi we don't speak russian in Belgium, just Dutch, French and German).
 
Old 07-07-2010, 10:14 AM   #7
Phiebie
Member
 
Registered: Oct 2004
Location: Austria
Distribution: Debian testing
Posts: 111

Rep: Reputation: 17
Quote:
Originally Posted by Treize.k View Post
I am still wondering why it is that I get russian text when my locale is set to Belgium though
No, it wasn't! be_BY@latin is the setting for Belorussia (witrusland). And that was what you reported before.
Kind regards.
 
Old 07-08-2010, 03:10 AM   #8
Treize.k
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Oh I see, that explains it
I should've gone for nl_BE then. It's just that I'm used to picking the first thing with BE in it for Belgium. Thanks for clarifying.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Entering text -- Cursor jumps to different places randomly 1kyle SUSE / openSUSE 1 03-25-2008 06:46 AM
Adding text to places in a file helptonewbie Programming 6 10-05-2007 06:09 PM
LXer: New russian blog "Digged Linux Articles in Russian" LXer Syndicated Linux News 0 07-31-2007 06:16 AM
X windows not appearing, root window refresh problem kdogksu Linux - Software 7 01-22-2005 11:07 AM
OpenOffice in Russian - font problem nikolayds Fedora 0 06-24-2004 03:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration