LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Problem with russian(?) text appearing in various places.. (https://www.linuxquestions.org/questions/debian-26/problem-with-russian-text-appearing-in-various-places-803941/)

Treize.k 04-24-2010 09:29 AM

Problem with russian(?) text appearing in various places..
 
Hi,

I'm using Debian unstable with KDE. Today I suddenly noticed when doing a df command in Konsole that the column header titles were in russian or something.. Also when for example I download an image in Iceweasel and the file save dialog comes up, the labels on the buttons are in russian..
I already went to System Settings -> Regional & Language to add US English as a language. Country or region is not set but it says it defaults to generic English. Does anyone know what is causing this?

Thanks.

smoker 04-25-2010 06:22 PM

try setting the default to the correct language/region.

What does
Code:

echo $LANG
give you ?

Treize.k 06-29-2010 01:22 PM

Hi, I'm sorry I didn't respond sooner. I thought I would try a full system upgrade. It didn't help.

It's starting to really annoy me now. Some things seem to be in Russian, others are in English.
Here are two links to screenshots of the 'russian' text, one in the console when executing 'df' and the other in the download dialog of iceweasel:

http://users.telenet.be/mordredshave...c/russian1.png
http://users.telenet.be/mordredshave...c/russian2.png

The really weird thing is that some applications display the menu in russian while other are in english. For example the gimp displays the menu (and other stuff) in russian, while filezilla is in english. Even though they both use GTK I think?

The value of $LANG is: be_BY@latin
Which is also not correct I guess. I am in Belgium but I just want the language to be english. I've set my location to United states and language to English in the KDE region and language settings though..

Any ideas?

Thanks.

smoker 06-29-2010 01:58 PM

You could edit /etc/default/locale and change LANG and LANGUAGE to language you want (en_US.UTF8 is standard American English).
You could also put similar lines in your .bash_profile
LANG=en_US.UTF8
LANGUAGE=en_US.UTF8

You will need to log out and in again to see any effect.

the trooper 06-29-2010 02:09 PM

Or just try as root:

Code:

dpkg-reconfigure locales

Treize.k 07-07-2010 05:52 AM

Thanks, that did the trick. Apparently I just didn't look hard enough.
I am still wondering why it is that I get russian text when my locale is set to Belgium though (fyi we don't speak russian in Belgium, just Dutch, French and German).

Phiebie 07-07-2010 10:14 AM

Quote:

Originally Posted by Treize.k (Post 4026091)
I am still wondering why it is that I get russian text when my locale is set to Belgium though

No, it wasn't! be_BY@latin is the setting for Belorussia (witrusland). And that was what you reported before.
Kind regards.

Treize.k 07-08-2010 03:10 AM

Oh I see, that explains it :)
I should've gone for nl_BE then. It's just that I'm used to picking the first thing with BE in it for Belgium. Thanks for clarifying.


All times are GMT -5. The time now is 07:46 PM.