LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-30-2003, 01:23 PM   #1
lipkaj
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Rep: Reputation: 0
PROBLEM with Qt library and KDE installation from .deb


Hi!
I have installed debian recently, but the problem is i want to use KDE(am used to it from RH). But the qt library in debian package (i have 3.0 stable Woody) is ver. 3-0-2, and kde from the package on the CD wants at least 3-0-4.1, what can i do?
I installed from sources downloaded a qt library version 3-2-2, but the dselect program im using doesnt see it, and cant install kde (kdelibs and kdebase - thats what you start with). it tries to install the 3-0-2 ver. from the package but it is not recent enough.
Please help, i need to use linux quickly...
Thanx in advance,
Andru
 
Old 10-30-2003, 03:38 PM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Have a look at this thread. I assume you are trying to install KDE 3.1.X.
 
Old 10-30-2003, 03:52 PM   #3
lipkaj
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Thanx TigerOC, but the problem is not with KDE, but with the Qt library! The one that is in woody dist is too old for my kde from cD (ver.3.0.2). Ok, i have internet connection. How can I get the qt package (neeeded!) before the line you gave for installing the kde package (3.1.4):
deb http://download.kde.org/stable/3.1.4/Debian stable main
the problem is with apt as well as dselect with dependancies on libqt. I found a version (unstable!) libqt3c102-mt.deb, it is 3.2.1 so its good enough, but how can i make dselect or apt see it? It is on packages.debian.org/unstable/libs/

Please help, TIA.
 
Old 10-31-2003, 02:50 AM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
qt3 support is included in kdelibs as I understand it so when you go the route I suggested it is installed automatically. I personally installed qt3 before doing the upgrade which you can get here.
 
Old 10-31-2003, 07:43 AM   #5
lipkaj
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, I will try in a second if it will work, but in my ver. of kde on cd (3.0.2) the qt support is clearly not included! I will try to install the 3.1.4 ver. from net. thanx.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mozilla-firefox_1.0.6-0ubuntu0.1_i386.deb installation jupiter3437 Linux - Software 3 08-24-2005 08:16 PM
bitorrent deb dpkg installation complaint about python celejar Debian 3 04-22-2005 12:38 PM
library installation problem ravalox Linux - Software 2 11-27-2004 08:15 PM
.deb packages for kde 3.3? nuka_t Debian 2 09-12-2004 07:54 PM
How to create a .deb library package? FloFri Debian 3 05-03-2004 12:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration