LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-18-2005, 04:39 AM   #1
d1s4st3r
Member
 
Registered: May 2004
Location: Italy
Distribution: Ubuntu, Slackware, OpenBSD, PC-BSD
Posts: 68

Rep: Reputation: 15
Problem with Debian Sid, Xorg, nVidia and Extensions


Hi folks,
I've got the following problem: currently I have Debian Sid (with kernel 2.6.10), with latest release of Xorg from Ubuntu's repositories, and nVidia drivers version 6629.
By installing nVidia drivers in the standard way (I mean, "sh NVIDIA-Linux-x86-1.0-6629-pkg1.run"), I got kernel module working fine, but not GLX at all (even if I correctly modified xorg.conf). I have to say that I have the same configuration on my laptop but with Slackware 10.1 and everything works (GLX included), so I think my problem depends on Debian.
By launching "glxinfo" or "glxgears", I received "missing glx extension on :0.0 ...".
Well now, a few weeks ago I decided to try transparency on Xorg, so I downloaded "xcompmgr" and "transset" and modified xorg.conf like this:
Code:
# I added this to tweak on Xorg...
Section "Extensions"
    Option "Composite" "true"
    Option "RENDER" "true"
EndSection

[... bla bla bla...]

Section "Device"
    Identifier  "nVidia GeForceFX 5900"
    Driver      "nvidia"
    # ... and this, by following a tutorial
    Option "RenderAccel" "true"
EndSection
Transparency is cool, but I'd love to have GLX, so finally I decided to install "nvidia-glx" package with APT.
Now, when I launch X and try "glxinfo" or "glxgears", I get a loud and clear "Segmentation fault", nothing else.
I noticed, by reading Xorg logs, that
Code:
(EE) GLX is not supported with the Composite extension.
Ok, but if I comment out (or remove) the new lines I added to xorg.conf a few weeks ago to have transparency working, when I launch X I see shitty dirty green lines on white background, then X dies silently...
What could I do now?
If I have to remove the Composite extension to have GLX working, goodbye Composite extension!!! But if I remove it, X doesn't work.
Please help me I'm getting mad!!!
Thanks very much!
 
Old 02-18-2005, 05:02 AM   #2
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
instead of reconfiguring your xorg.conf i would suggest that since u have kernel 2.6.10 u should reconfigure it and build in the module for nvidia graphic card

it will work as smooth as a fish
 
Old 02-18-2005, 10:49 AM   #3
d1s4st3r
Member
 
Registered: May 2004
Location: Italy
Distribution: Ubuntu, Slackware, OpenBSD, PC-BSD
Posts: 68

Original Poster
Rep: Reputation: 15
Thanks for the suggestion, but...
how can I do that?
I mean, nVidia drivers are distributed as binary files (also Debian package "nvidia-kernel-source" with "apt-get source nvidia-kernel-source").
How can I build nVidia module into the kernel?
I use a custom 2.6.10 vanilla kernel (no patches), and I compile and install it in stardard way (no Debian-way).
And why deletion of Xorg's extensions make X server die?
Thanks anyway!
 
Old 02-18-2005, 10:58 AM   #4
d1s4st3r
Member
 
Registered: May 2004
Location: Italy
Distribution: Ubuntu, Slackware, OpenBSD, PC-BSD
Posts: 68

Original Poster
Rep: Reputation: 15
Thanks for the suggestion, but...
how can I do that?
I mean, nVidia drivers are distributed as binary files (also Debian package "nvidia-kernel-source" with "apt-get source nvidia-kernel-source").
How can I build nVidia module into the kernel?
I use a custom 2.6.10 vanilla kernel (no patches), and I compile and install it in stardard way (no Debian-way).
And why deletion of Xorg's extensions make X server die?
Thanks anyway!
 
Old 02-24-2005, 01:20 AM   #5
jaws_tas
LQ Newbie
 
Registered: Jan 2005
Posts: 25

Rep: Reputation: 15
GLX with composite extensions

You should try adding the line:

Option "AllowGLXWithComposite" "true"

in the device section of xorg.conf

GLX apps will run with Composite overlays but they are slower than when you use the OpenGL overlays. Unfortunately you have to choose between Composite for eye candy or OpenGL for rendering speed.

If you want to use OpenGL overlays, disable the composite extension - but you wont be able to use transparency/shadows etc.
 
Old 05-05-2005, 07:18 PM   #6
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
I didn't get Xorg from Ubuntu and had little trouble with it (also Nvidia here). Is there any news on using Composite with Glx? It's a pity they don't play nice, but I suppose it will get fixed?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
will the ltmodem drivers work in debian sid (knoppix sid) maximalred Debian 5 05-29-2009 10:44 AM
Debian SID problem horatiub Debian 5 09-18-2005 03:48 PM
Problem with java in Debian (sid) yarjar Debian 2 06-19-2005 01:52 AM
xorg in debian sid? greythorne Debian 0 11-22-2004 07:56 PM
NVIDIA Driver Help - Debian Sid philwozza Debian 3 02-07-2004 03:25 PM


All times are GMT -5. The time now is 04:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration