LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-06-2004, 11:19 AM   #1
slashdotdash
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Rep: Reputation: 0
Problem installing mysql using DotDeb


I'm trying to install mysql (mysql-server 4.1.7-1.dotdeb.0) on my Debian server, but it's causing me a major headache. I want to use the LAMP packages from dotdeb. I have added the necessary line to sources.list but the install fails.

/etc/apt/sources.list
Code:
<snip>
...
# dotdeb Debian LAMP project
deb hxxxp://packages.dotdeb.org ./
(Note: funny URLs to get around the forums anti-spamming measures!)
Code:
$ apt-get install -s -t dotdeb mysql-client
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  mysql-client: Depends: libdbi-perl but it is not going to be installed
                Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed
E: Sorry, broken packages
Trying to apt-get install libdbi-perl...
Code:
$ apt-get install -s -t dotdeb libdbi-perl
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  libdbi-perl: Depends: perlapi-5.6.1
E: Sorry, broken packages
Code:
$ apt-cache search perlapi
perl-base - The Pathologically Eclectic Rubbish Lister
So apt-gett'ing perl...
Code:
$ apt-get install -s perl-base
Reading Package Lists... Done
Building Dependency Tree... Done
Sorry, perl-base is already the newest version.
0 packages upgraded, 0 newly installed, 0 to remove and 0  not upgraded.
Seems to be installed and at the latest version. That's me stuck!

Being a newcomer to Debian I'm struggling to resolve the problem and have looked through the Debian docs and the extensive apt guide but no luck so far. I think I have confused myself (and the PC) by mixing packages from stable / release and dotdeb and apt doesn't seem to like downgrading packages. It always wants to install the latest version available.

Any help appreciated!
 
Old 12-08-2004, 01:32 AM   #2
bastard23
Member
 
Registered: Mar 2003
Distribution: Debian
Posts: 275

Rep: Reputation: 30
What version of perl-base do you have?
dpkg -l perl-base

If it is something like 5.8.4, then you have testing/sarge installed. If it is 5.6.1, then you should be runny woody/stable which is what dotdeb is for, I think.

post all of your sources list.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using apt-get with dotdeb packages lazymanc Debian 2 05-17-2005 03:26 AM
Problem installing MySQL 5.0.2-alpha on Red Hat Enterprise ES V3 ETSUSnake Linux - Software 2 03-08-2005 10:24 AM
MySql password problem right after installing on mandrake rmanocha Linux - Software 1 07-26-2004 06:50 AM
Problem installing PHP with MySQL on RedHat 9 d2army Linux - Newbie 1 07-11-2004 05:58 PM
Problem Installing MySQL kaplan71 Mandriva 1 05-12-2004 09:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration