-   Debian (
-   -   Problem booting on GPT partition. (

zuku 12-30-2011 04:09 AM

Problem booting on GPT partition.
I have a problem after installation debian on 8TB GPT partition (hardware raid5 - adaptec).
After successful installation my system won't boot, and giving me this error:


Grub loading
Welcome to GRUB!
error:file not found
grub rescue >

I'm able to boot to my system using Super Grub2 Disk because it detect my boot entries:

(hd1,gpt2)/boot/vmlinuz-2.6.32-5-amd64 (single)

After logged to Gnome I've reinstalled my Grub:


grub-install /dev/sda
Installation finished. No error reported.

Unfortunately after reboot I have the same error, could you help me?

Here are my partitions:


Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                               
Model: Adaptec RAID 5 (scsi)
Disk /dev/sda: 8987GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start  End    Size    File system    Name  Flags
 1      17.4kB  1018kB  1000kB                        bios_grub
 2      1018kB  8979GB  8979GB  ext3                  boot
 3      8979GB  8987GB  8105MB  linux-swap(v1)


GPT fdisk (gdisk) version 0.5.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): p
Disk /dev/sda: 17553141760 sectors, 8.2 TiB
Disk identifier (GUID): 64
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 17553141726
Total free space is 0 sectors (0 bytes)

Number  Start (sector)    End (sector)  Size      Code  Name
  1              34            1987  977.0 KiB  EF02
  2            1988    17537312534  8.2 TiB    EF00
  3    17537312535    17553141726  7.5 GiB    8200

Command (? for help): i
Partition number (1-3): 1
Partition GUID code: 49 (BIOS boot partition)
Partition unique GUID: FE
First sector: 34 (at 17.0 KiB)
Last sector: 1987 (at 993.5 KiB)
Partition size: 1954 sectors (977.0 KiB)
Attribute flags: 0000000000000000
Partition name:

Command (? for help): i
Partition number (1-3): 2
Partition GUID code: 3B (EFI System)
Partition unique GUID: 6D
First sector: 1988 (at 994.0 KiB)
Last sector: 17537312534 (at 8.2 TiB)
Partition size: 17537310547 sectors (8.2 TiB)
Attribute flags: 0000000000000000
Partition name:

Command (? for help): i
Partition number (1-3): 3
Partition GUID code: 4F (Linux swap)
Partition unique GUID: C9
First sector: 17537312535 (at 8.2 TiB)
Last sector: 17553141726 (at 8.2 TiB)
Partition size: 15829192 sectors (7.5 GiB)
Attribute flags: 0000000000000000
Partition name:

Command (? for help):

syg00 12-30-2011 06:54 PM

That sounds like you haven't built the grub.cfg (correctly). Don't know how Debian does it, but you'll need to run grub-mkconfig - Ubuntu has a wrapper for this (update-grub), I'm sure Debian would have something similar.

zuku 01-03-2012 03:06 AM

update-grub apllied successfully, but stil the same error in grub :(

otoomet 01-20-2012 09:31 AM

Did you get it to work?

What I did was essentially following:

a) ensure you have efi boot partition with boot flag on (formated as fat16/32)

b) install grub-efi (not grub-pc)

c) run:
install-grub /dev/sda

d) ensure that grub.cfg (grub64x.cfg in my case) will be copied to your efi boot partition (into a directory like /EFI/grub)

e) Seemingly ubuntu 11.10 still could not handle the correct installation on efi side, so I had to run efibootmgr by hand.

All times are GMT -5. The time now is 07:08 AM.