LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-06-2019, 05:54 AM   #31
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello Evo


I'm not sure what you talking about. could you please tell me more clearly? About root shell.
 
Old 08-06-2019, 06:09 AM   #32
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,009

Rep: Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391
Hi,
Quote:
Originally Posted by joseph_lewis View Post
I'm not sure what you talking about. could you please tell me more clearly? About root shell.
What do you do to get a terminal that looks like the following?
Code:
root@joseph:/home/joseph#
I can see from that, that you are in the normal users home directory which makes me think that the PATH is being preserved from the user joseph and not being set to the proper path for root.

Normally, to become root, as a normal user you issue the following command in a terminal:
Code:
su -l
Evo2.
 
Old 08-06-2019, 06:12 AM   #33
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello Evo

ah to that,

Code:
joseph@joseph:~$ su
Password: 
root@joseph:/home/joseph#
 
Old 08-06-2019, 06:23 AM   #34
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,009

Rep: Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391
Hi,

ok, then please try using "su -l" instead of "su".

Evo2.
 
Old 08-06-2019, 06:46 AM   #35
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello Evo

Code:
oseph@joseph:~$ su -l
Password: 
root@joseph:~# 
root@joseph:~# 
root@joseph:~# exit
logout
joseph@joseph:~$ su -p
Password: 
root@joseph:~# 
root@joseph:~# 
root@joseph:~# exit
exit
joseph@joseph:~$
 
Old 08-06-2019, 06:49 AM   #36
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello Evo

With the "su -l" command, I can run "nethogs". It opens normally. If I run "nethogs" after "su -p", it's not working.

Code:
joseph@joseph:~$ su -l
Password: 
root@joseph:~# nethogs
Linux Cooked Socket link detected
                                 Waiting for first packet to arrive (see sourceforge.net bug 1019381)
root@joseph:~# exit
logout
joseph@joseph:~$ su -p
Password: 
root@joseph:~# nethogs
bash: nethogs: command not found
root@joseph:~#
 
Old 08-06-2019, 06:57 AM   #37
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,009

Rep: Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391
Hi,

Quote:
Originally Posted by joseph_lewis View Post
With the "su -l" command, I can run "nethogs". It opens normally. If I run "nethogs" after "su -p", it's not working.
That is the expected behaviour for a default Buster installation.

Evo2.
 
Old 08-06-2019, 07:01 AM   #38
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello Evo

But why it worked before? In stretch, I didn't have any problem running it on root. So my previous system vs broken? :O

If my new system is working fine, then it's fine with me.

I also have another small little tiny problem Evo.

Every time my system start, audio is muted. Audio level is 0%. This started to happen after the buster update. I checked on settings, didn't found anything related to fix it. Can you help me through this?
 
Old 08-06-2019, 07:11 AM   #39
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,009

Rep: Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391
Hi,

possibly the default behaviour of su changed. I've never really used su without options, always either su -p or su -l. If you are interested, you can have a look at the change logs.

I'll try to have a look at your audio issue tomorrow. Dinner time for me now.

Cheers,

Evo2.
 
Old 08-06-2019, 07:16 AM   #40
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Thanks Evo

Ah ok Evo. Thanks for your help. You solved my problem and taught me many things. I really appreciate your help.

Thank you Evo.
 
Old 08-06-2019, 10:12 PM   #41
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,009

Rep: Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391Reputation: 1391
Hi,

I'm not sure about your audio problem. There is some information at https://unix.stackexchange.com/quest...w-to-save-them
that may be of use to you.

I suggest you start a new thread for this problem.

Cheers,

Evo2.
 
Old 08-06-2019, 11:22 PM   #42
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello Evo

Ah ok evo... I'll try to find a solution for this. If I can't find any, I'll open another thread for it. Thanks for helping me. It taught me so many things. Thanks again.
 
Old 08-07-2019, 02:04 AM   #43
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 12,533
Blog Entries: 9

Rep: Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393
Quote:
Originally Posted by evo2 View Post
possibly the default behaviour of su changed.
There was indeed talk about that some time ago; either su or sudo, can't remember which.

Also check if you have any aliases for su/sudo:
Code:
alias|grep su
 
Old 08-07-2019, 02:07 AM   #44
joseph_lewis
Member
 
Registered: Aug 2019
Location: Sri Lanka
Distribution: Debian
Posts: 32

Original Poster
Rep: Reputation: 1
Hello ondoho,

I tried "alias | grep su". But it's not showing me anything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Remastering Debian Stretch/Buster using Linux-live-debian-050419 into a Live CD/DVD/USB/HDD linus72 Debian 1 10-14-2019 01:25 PM
LXer: How to Upgrade Debian 9 Stretch to Debian 10 Buster LXer Syndicated Linux News 0 07-07-2019 05:54 PM
[SOLVED] Nvidia-Driver broken on Stretch & Buster baumerang Debian 4 06-17-2019 04:51 PM
[SOLVED] Upgraded Stretch->Buster, lost network. How to set up simple DHCP connection? pepperslq Debian 7 02-26-2018 02:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration