LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Problem after upgrading to Buster from Stretch (https://www.linuxquestions.org/questions/debian-26/problem-after-upgrading-to-buster-from-stretch-4175658508/)

joseph_lewis 08-06-2019 05:54 AM

Hello Evo
 
I'm not sure what you talking about. could you please tell me more clearly? About root shell.

evo2 08-06-2019 06:09 AM

Hi,
Quote:

Originally Posted by joseph_lewis (Post 6022045)
I'm not sure what you talking about. could you please tell me more clearly? About root shell.

What do you do to get a terminal that looks like the following?
Code:

root@joseph:/home/joseph#
I can see from that, that you are in the normal users home directory which makes me think that the PATH is being preserved from the user joseph and not being set to the proper path for root.

Normally, to become root, as a normal user you issue the following command in a terminal:
Code:

su -l
Evo2.

joseph_lewis 08-06-2019 06:12 AM

Hello Evo
 
ah to that,

Code:

joseph@joseph:~$ su
Password:
root@joseph:/home/joseph#


evo2 08-06-2019 06:23 AM

Hi,

ok, then please try using "su -l" instead of "su".

Evo2.

joseph_lewis 08-06-2019 06:46 AM

Hello Evo
 
Code:

oseph@joseph:~$ su -l
Password:
root@joseph:~#
root@joseph:~#
root@joseph:~# exit
logout
joseph@joseph:~$ su -p
Password:
root@joseph:~#
root@joseph:~#
root@joseph:~# exit
exit
joseph@joseph:~$


joseph_lewis 08-06-2019 06:49 AM

Hello Evo
 
With the "su -l" command, I can run "nethogs". It opens normally. If I run "nethogs" after "su -p", it's not working.

Code:

joseph@joseph:~$ su -l
Password:
root@joseph:~# nethogs
Linux Cooked Socket link detected
                                Waiting for first packet to arrive (see sourceforge.net bug 1019381)
root@joseph:~# exit
logout
joseph@joseph:~$ su -p
Password:
root@joseph:~# nethogs
bash: nethogs: command not found
root@joseph:~#


evo2 08-06-2019 06:57 AM

Hi,

Quote:

Originally Posted by joseph_lewis (Post 6022067)
With the "su -l" command, I can run "nethogs". It opens normally. If I run "nethogs" after "su -p", it's not working.

That is the expected behaviour for a default Buster installation.

Evo2.

joseph_lewis 08-06-2019 07:01 AM

Hello Evo
 
But why it worked before? In stretch, I didn't have any problem running it on root. So my previous system vs broken? :O

If my new system is working fine, then it's fine with me. :D

I also have another small little tiny problem Evo. :D

Every time my system start, audio is muted. Audio level is 0%. This started to happen after the buster update. I checked on settings, didn't found anything related to fix it. Can you help me through this? :)

evo2 08-06-2019 07:11 AM

Hi,

possibly the default behaviour of su changed. I've never really used su without options, always either su -p or su -l. If you are interested, you can have a look at the change logs.

I'll try to have a look at your audio issue tomorrow. Dinner time for me now.

Cheers,

Evo2.

joseph_lewis 08-06-2019 07:16 AM

Thanks Evo
 
Ah ok Evo. Thanks for your help. You solved my problem and taught me many things. I really appreciate your help.

Thank you Evo. :)

evo2 08-06-2019 10:12 PM

Hi,

I'm not sure about your audio problem. There is some information at https://unix.stackexchange.com/quest...w-to-save-them
that may be of use to you.

I suggest you start a new thread for this problem.

Cheers,

Evo2.

joseph_lewis 08-06-2019 11:22 PM

Hello Evo
 
Ah ok evo... I'll try to find a solution for this. If I can't find any, I'll open another thread for it. Thanks for helping me. It taught me so many things. Thanks again. :)

ondoho 08-07-2019 02:04 AM

Quote:

Originally Posted by evo2 (Post 6022076)
possibly the default behaviour of su changed.

There was indeed talk about that some time ago; either su or sudo, can't remember which.

Also check if you have any aliases for su/sudo:
Code:

alias|grep su

joseph_lewis 08-07-2019 02:07 AM

Hello ondoho,

I tried "alias | grep su". But it's not showing me anything.


All times are GMT -5. The time now is 10:09 AM.