LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   PPC Mac G5, Debian 8 (Jessie) Graphics Problems (https://www.linuxquestions.org/questions/debian-26/ppc-mac-g5-debian-8-jessie-graphics-problems-4175543659/)

89Laredo 05-26-2015 01:01 PM

PPC Mac G5, Debian 8 (Jessie) Graphics Problems
 
Note: This is a crosspost from Debian Forums, here. Just trying to get more help.

I did a quick forum search but didn't find much,I have asked on Reddit and only got one commenter (they were somewhat helpful, but we couldnt resolve my issue), searched google and followed some different forum posts/tuts but haven't fixed the issue. May just be a lack of skill, I need walked through this.

The computer is a "late" Mac G5, the one with the stupidly heavy aluminum case.
PowerPC dual core processor, 64bit
2gb Ram
Geforce 6600 Graphics
Currently has 7.8.0 Wheezy -official Powerpc
For now, this setup is working fine

I would really like to upgrade to Jessie with Cinnamon since I use Mint on my laptop and like it and Id also like to try running steam for giggles (which I highly doubt will work well). I have installed Jessie from DVD but it boots to this screen. I think I have it tracked down to a problem with Nouveau or Xorg, but haven't been able to fix it.

I'm mainly just looking for advice and seeing if anyone has actually made this setup work before I waste another 2 hours reinstalling Jessie from DVD and more countless hours in terminal unF***ing the graphics, I'm getting pretty irritated. For now Wheezy works, but as I said, Id really like to run Jessie.

Thanks,
Dylan

EDDY1 05-27-2015 12:18 AM

Check this out
https://packages.debian.org/sid/nvid...y-304xx-driver
Try installing nvidia-legacy drivers

TobiSGD 05-27-2015 04:16 AM

Quote:

Originally Posted by 89Laredo (Post 5367732)
Id also like to try running steam for giggles (which I highly doubt will work well).

Steam doesn't have a PowerPC version, so not only won't it work well, it won't work at all. The same is true for the Nvidia driver mentioned by EDDY1, sadly, so you will have to deal with the nouveau driver instead.
For a starter, add the nomodeset option to your bootloaders kernel line and try if you can get a proper display. This will disable any and all acceleration you get from the card, but at least may make it possible to boot at all for further troubleshooting.

89Laredo 05-27-2015 09:58 AM

Quote:

Originally Posted by EDDY1 (Post 5367959)
Check this out
https://packages.debian.org/sid/nvid...y-304xx-driver
Try installing nvidia-legacy drivers

Already tried it, following this wiki: https://wiki.debian.org/NvidiaGraphi...legacy_GPUs.29 and quickly found out there wasnt a powerpc version, as has been mentioned below.

Quote:

Originally Posted by TobiSGD (Post 5368055)
Steam doesn't have a PowerPC version, so not only won't it work well, it won't work at all. The same is true for the Nvidia driver mentioned by EDDY1, sadly, so you will have to deal with the nouveau driver instead.
For a starter, add the nomodeset option to your bootloaders kernel line and try if you can get a proper display. This will disable any and all acceleration you get from the card, but at least may make it possible to boot at all for further troubleshooting.

I didnt realize steam needed a specific powerpc version...

Ill try that, whenever I decide to screw with this thing again (like I said, It takes like 2hrs to install from dvd and wheezy is working ok for now.)

I think I will order another hard drive to install Jessie on, that way I dont have to nuke my wheezy install again.

TobiSGD 05-27-2015 11:17 AM

Quote:

Originally Posted by 89Laredo (Post 5368209)
I didnt realize steam needed a specific powerpc version...

The Steam client is a 32 bit x86 application, all of the games in the Steam store (AFAIK) are also x86 (sometimes x86_64), so even if you would get the client running you would still have no luck with gaming on this machine.

89Laredo 05-29-2015 02:56 PM

Well, I tried installing Jessie on a flash drive last night and somehow now Jessie AND wheezy won't boot. I'm a noob, and a moron. I'll have to look tonight and see if I can figure out what I screwed up.

89Laredo 05-29-2015 10:23 PM

Got Jessie going again. Tried the nomodeset option, it boots to a black screen with a cursor.
Terminals still work.

89Laredo 06-09-2015 08:00 PM

Sending this from the offending mac computer...

Someone on the mailing list suggested adding "nouveau.noaccel=1" to the boot options. This got me to a GUI. Cinnamon was extremely slow in software rendering so I installed LXDE. Seems to be working pretty good, and is actually decently fast.
Id really like to have some hardware accel, but this will work for now.

TobiSGD 06-10-2015 03:24 AM

Quote:

Originally Posted by 89Laredo (Post 5374880)
Id really like to have some hardware accel, but this will work for now.

Submit your problems as a bug to the nouveau project, this might help to get that working.


All times are GMT -5. The time now is 09:35 AM.