LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-27-2005, 09:08 AM   #1
ncp
LQ Newbie
 
Registered: Nov 2005
Location: Skive, Denmark
Distribution: Debian, Gentoo, Slackware
Posts: 3

Rep: Reputation: 0
Postfix question


I have setup postfix with amavis an spamassian.

I think every thing work, cause when i look at my mail.log file there is no errors.
Just to be sure, this in the last entry in my logfil.

Nov 27 14:57:34 iBox amavis[3578]: (03578-02) Passed, <forum@linuxquestions.org> -> <spam@eoe.dk>, Message-ID: <200511271456.jAREugtY031000@web1.linuxquestions.org>, Hits: -
Nov 27 14:57:34 iBox postfix/smtp[3826]: CDC98A966A: to=<spam@eoe.dk>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=03578-02, from MTA: 250 Ok: queued as 68E73A988C)
Nov 27 14:57:34 iBox postfix/qmgr[3654]: CDC98A966A: removed
Nov 27 14:57:34 iBox postfix/virtual[3832]: 68E73A988C: to=<spam@eoe.dk>, relay=virtual, delay=0, status=sent (delivered to maildir)
Nov 27 14:57:34 iBox postfix/qmgr[3654]: 68E73A988C: removed

This should be correct?

I also cant figure out how to add 'x-spam-status' to all incoming mails. In amavisd.conf I set '$sa_tag_level_deflt = -1000'.

Now all mails should get x-spam-status added to there header right?
but when i look at the mails header, i can only find

'X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at localhost'

So it seems that amavis scans the mail but wont add X-spam-status to it, where did i go wrong?

Must i use procmail to add this to all mails, or did i configure something wrong.
 
Old 11-29-2005, 01:45 AM   #2
ncp
LQ Newbie
 
Registered: Nov 2005
Location: Skive, Denmark
Distribution: Debian, Gentoo, Slackware
Posts: 3

Original Poster
Rep: Reputation: 0
found the problem

took me a while to find out, but there was a bypass line in my amavisd.conf that disabled scanning of incoming mails.

I just comment it out, an now every thing works

All mails now get x-spam-status add to there header, an i only have to set up the rules so amavis know when it's spam.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix question macBasH Red Hat 0 09-28-2005 08:32 AM
Postfix Question redice Debian 3 09-06-2005 11:15 AM
postfix question twk Linux - Networking 1 11-01-2004 01:52 PM
Postfix Question capkapak Linux - Software 3 01-20-2003 02:22 AM
Postfix question DavidPhillips Linux - General 1 02-18-2002 12:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration