LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-24-2006, 11:49 PM   #1
tuxuser19
Member
 
Registered: Oct 2005
Posts: 67

Rep: Reputation: 15
Pinging between PC's doesnt work !


I have a small home network at my house one is running Ubuntu and the other one is running Debian Sarge. The problem is I can ping the Ubuntu pc from Debian pc but I cant ping the Debian pc from Ubuntu.

I have added IP's of both the pc's in /etc/hosts and /etc/hosts.allow in respective pc's.

In fact I am trying to run a thin client setup at my house. What else will be the reason by which I can't ping the Debian pc ?
 
Old 02-25-2006, 12:03 AM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,138

Rep: Reputation: 167Reputation: 167
It's possible to disable echo responses with sysctl even if the firewall isn't blocking them. Have a look at /sbin/sysctl -a | grep 'net.ipv4.icmp' to see whether any ignore flags are set. Also, you can run ethereal on each box and see whether the problem is with the packets leaving one box or arriving at the other.
 
Old 02-25-2006, 08:56 AM   #3
tuxuser19
Member
 
Registered: Oct 2005
Posts: 67

Original Poster
Rep: Reputation: 15
I have executed the command you have given, this is what I get as the output:

root@tux:/sbin# sysctl -a | grep 'net.ipv4.icmp'
error: "Invalid argument" reading key "net.ipv4.route.flush"
net.ipv4.icmp_ratemask = 6168
net.ipv4.icmp_ratelimit = 100
net.ipv4.icmp_ignore_bogus_error_responses = 0
net.ipv4.icmp_echo_ignore_broadcasts = 1
net.ipv4.icmp_echo_ignore_all = 1

Are the last 2 messages meant that the Debian pc is configured not to accept any ping packets ? If thats the case how to disable it and make the 2 pc's in my home network to talk to each other ?
 
Old 02-25-2006, 09:47 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,618

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by tuxuser19
I have executed the command you have given, this is what I get as the output:

root@tux:/sbin# sysctl -a | grep 'net.ipv4.icmp'
error: "Invalid argument" reading key "net.ipv4.route.flush"
net.ipv4.icmp_ratemask = 6168
net.ipv4.icmp_ratelimit = 100
net.ipv4.icmp_ignore_bogus_error_responses = 0
net.ipv4.icmp_echo_ignore_broadcasts = 1
net.ipv4.icmp_echo_ignore_all = 1

Are the last 2 messages meant that the Debian pc is configured not to accept any ping packets ? If thats the case how to disable it and make the 2 pc's in my home network to talk to each other ?
Yes but that does not mean they cannot communicate if you have a ssh server setup on the machines then use it to try and login to each machine from the other.
 
Old 02-25-2006, 01:52 PM   #5
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,138

Rep: Reputation: 167Reputation: 167
You can change the setting on of 2 ways. As root, type echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all. You can also add an entry to /etc/sysctl.conf:
Code:
net.ipv4.icmp_echo_ignore_all = 0
You then force sysctl to re-read its settings with sysctl -p
The sysctl.conf method will preserve the settings between reboots, the first does not unless you add the command to one of your startup scripts.

However, keep in mind what HappyTux pointed out - having pings ignored does not stop any of your functionality for ssh etc.
 
Old 02-26-2006, 12:39 AM   #6
tuxuser19
Member
 
Registered: Oct 2005
Posts: 67

Original Poster
Rep: Reputation: 15
Thank you gilead it's working now.
 
Old 02-26-2006, 12:56 AM   #7
tuxuser19
Member
 
Registered: Oct 2005
Posts: 67

Original Poster
Rep: Reputation: 15
I have a very strange problem now. I have setup a thin client network at my place by querying X from the server. After running thin client setup I can't get the KDE desktop ! It hangs up at the begining 'loading peripherals' and stays over there for ages.

I killed the session by ctl+alt+backspace and typed in 'startx' i have the same problem. In fact, to run thin client setup what I do is I kill the clients desktop session by ctl+alt+backspace then I query X from the server. To close the session I logout and kill the desktop session. After doing this thing now I cant get the KDE desktop interface.

Any clues how to reconfigure the X configuration?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why doesnt my USB mouse doesnt work? barkha Linux - Hardware 2 08-16-2005 11:31 AM
Sound Doesnt Work :( mrmo000 Fedora 5 06-15-2005 02:32 PM
xmms doesnt work lnthai2002 Linux - Software 1 02-27-2005 07:04 PM
can't access shared folder of other PC's.work on Mandrake 9.2 to WinXP nicolo Linux - Networking 0 03-04-2004 08:39 AM
Problems networking Linux and Windows. Pinging does not work. ElijahLofgren Linux - Networking 29 02-11-2004 11:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration