-   Debian (
-   -   Package needs re-installation, but package cannot be found (

woodbase 09-25-2006 05:34 PM

Package needs re-installation, but package cannot be found
I tried to install jEdit from their deb-package on edubuntu (Ubuntu), but an error occured during the installation. Now I can't run updates or anything, because this broken package is blocking it all.

How can I possibly remove it?

//My system is running in danish see translation below
E: Pakken jedit skal geninstalleres, men jeg kan ikke finde noget arkiv med den.
E: Internal error opening cache (1). Please report.

E: The package jedit needs to be re-installed, but I can't find any archive with it
E: Internal error opening cache (1). Please report.

Is there anyone who can get me out of this mess?

pljvaldez 09-25-2006 05:47 PM

Use dpkg --get-selections | grep -i jedit to find the right package. Then you can try dpkg -P jedit (I'm guessing at the package name). This should purge the package using dpkg.

woodbase 09-25-2006 06:08 PM

I'm afraid not:

dpkg: error during handling jedit (--purge):
Package is in a very poor, inconsistant state - You should re-install it, before You try to uninstall it.
An error occured during handling of:

woodbase 09-26-2006 01:30 PM

Problem solved:

sudo dpkg --remove --force-remove-reinstreq jedit

I don't know exactly how it works, so if someone would spent a minute to explain that would be GREAT.

However I tried it and it fixed my problem.

pljvaldez 09-26-2006 02:07 PM


Originally Posted by woodbase
sudo dpkg --remove --force-remove-reinstreq jedit

Reading the man page (i.e. man dpkg basically says you're using the low-level debian package manager, dpkg, to remove a file (but leave the config files) and forcefully remove the package jedit, even though it requires a reinstall. Typically dpkg won't remove a package requiring a reinstall because you might leave parts of the package on the system.

From man dpkg

remove-reinstreq: Remove a package, even if it's broken and marked to require reinstallation. This may, for example, cause parts of the package to remain on the system, which will then be forgotten by dpkg.
You can probably clean it up with deborphan if needed.

All times are GMT -5. The time now is 03:22 AM.