LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-16-2009, 12:24 PM   #1
gentoome
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
openvpn server help


hi all, i am running lenny on a romote vps, i just installed the openvpn through
Code:
aptitude install openvpn
, and it did not come up a window to let choose whether to enable the tun device or not! i can see the tun at /dev/net/tun, but when i do a
Code:
ifconfig -a
it;s like this
Code:
eth0      Link encap:Ethernet  HWaddr aa:00:13:63:83:01
          inet addr:a.b.c.d  Bcast:x.x.x.x  Mask:255.255.255.0
          inet6 addr: fe80::a800:13ff:fe63:8301/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:708037 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4662 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:173761298 (165.7 MiB)  TX bytes:1107770 (1.0 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
,seems the tun isn't up!

i build the openvpn server like..... edit the vars , source ./vars build-ca, build-key-server server, build-key client, build-dh , after these steps , i copy the all the keys to the /etc/openvpn/vnet , and made a server.conf
Code:
# non default port to prevent worm attacks!
port 11194
proto tcp
dev tun
ca vnet/ca.crt
cert vnet/server.crt
key vnet/server.key
dh vnet/dh1024.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
keepalive 10 120
comp-lzo
user nobody
group nobody
persist-key
persist-tun
status openvpn-status.log
verb 3
push "redirect-gateway def1 bypass-dhcp"
after that , i can not start the openvpn service ! if i do /etc/init.d/openvpn/ it always return a red failed! how can i enable the tun device!

Last edited by gentoome; 03-16-2009 at 01:20 PM.
 
Old 03-16-2009, 01:34 PM   #2
ddaemonunics
Member
 
Registered: May 2008
Location: Romania
Distribution: Debian
Posts: 242

Rep: Reputation: 41
a red failed doesn't really helps... what does tail -f /var/log/syslog says when you try to start openvpn
 
Old 03-16-2009, 01:55 PM   #3
gentoome
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Original Poster
Rep: Reputation: 0
er. it says:
Quote:
ovpn-server[1209]: OpenVPN 2.1_rc11 i486-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] built on Sep 18 2008, ovpn-server[1209]: Cannot open /vnet/dh1024.pem for DH parameters: error:02001002:system library:fopen:No such file or directory: error:2006D080:BIO routines:BIO_new_file:no such file ,
ovpn-server[1209]: Exiting

Last edited by gentoome; 03-16-2009 at 02:01 PM.
 
Old 03-16-2009, 02:29 PM   #4
ddaemonunics
Member
 
Registered: May 2008
Location: Romania
Distribution: Debian
Posts: 242

Rep: Reputation: 41
This says it ..

Cannot open /vnet/dh1024.pem for DH parameters
 
Old 03-16-2009, 03:45 PM   #5
gentoome
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Original Poster
Rep: Reputation: 0
txh so much! , but it dose exist at /etc/openvpn/vet/dh1024.pem, ,alright i will try to rebuild my openvpn server tomorrow, it's too late for me now ! anyway ,thx for the trouble shooting!
 
Old 03-16-2009, 04:59 PM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
oops
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenVPN client has not default gateway when connect to OpenVPN server sailershen Linux - Security 3 03-04-2010 03:20 AM
OpenVPN Bi-Directional (server-to-server)... HOW? n8tgc Linux - Software 6 01-19-2009 09:23 PM
OpenVPN sometimes does not forward all traffic to server depam Linux - Software 1 06-28-2008 05:13 PM
openvpn client and server Synchronous wanghao Linux - Enterprise 0 06-24-2008 03:20 AM
Routing from OpenVPN server jjge Linux - Networking 1 08-29-2006 10:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration