LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-01-2004, 12:08 PM   #16
initialdrifteg6
Member
 
Registered: Sep 2004
Location: France, Kentucky
Distribution: debian
Posts: 173

Original Poster
Rep: Reputation: 38

i'm at work right now so i can't run linux (boss freaks out when he see's something that he's not use to)... i'll definately try it later

i have as much faith in ati's support for linux as i do faith in bush running this country... ouch..
 
Old 12-02-2004, 06:01 PM   #17
initialdrifteg6
Member
 
Registered: Sep 2004
Location: France, Kentucky
Distribution: debian
Posts: 173

Original Poster
Rep: Reputation: 38
debian:/lib/modules/fglrx/build_mod# ./make.sh
ATI module generator V 2.0
==========================
initializing...
./make.sh: line 498: [: =: unary operator expected
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.8-1-386/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/kernel-headers-2.6.8-1-386'
CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:295:17: drm.h: No such file or directory
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:311:22: drm_proc.h: No such file or directory
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `firegl_init_module':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:613: error: `DRM_PROC_ENTRIES' undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:613: error: (Each undeclared identifier is reported only once
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:613: error: for each function it appears in.)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:619: error: `FGLDRM_proc_list' undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `do_vm_pcie_nopage':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2189: error: `drm_device_t' undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2189: error: `dev' undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2189: error: parse error before ')' token
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2528: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:301: warning: `FGLDRM_mem_info' defined but not used
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/kernel-headers-2.6.8-1-386'
make: *** [kmod_build] Error 2
build succeeded with return value 0
ln: `./fglrx.ko': File exists
duplicating results into driver repository...
cp: cannot stat `fglrx.ko': No such file or directory
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.

there's a clipping of my terminal... i got it to start the build and i redirected the link to the correct directory... but look at the bottom... the fglrx.ko was made, but the module has a 0 in filesize.... why can't those files above be found? what is it doing now?
==============================
debian:/lib/modules/fglrx/build_mod#
 
Old 12-03-2004, 02:27 AM   #18
shmonkey
Member
 
Registered: Nov 2004
Location: UK
Distribution: Ubuntu
Posts: 118

Rep: Reputation: 15
Looks like you have not got your kernel-sources installed.

You may get away with installing kernel-headers for your kernel version, but I imagine that you will need to rebuild your kernel.

make sure the symlink /usr/src/linux exists and is pointing to your kernel sources before you do /lib/modules/fglrx/build_mod/./make.sh

Regards

Shmonkey
 
Old 12-03-2004, 07:46 AM   #19
initialdrifteg6
Member
 
Registered: Sep 2004
Location: France, Kentucky
Distribution: debian
Posts: 173

Original Poster
Rep: Reputation: 38
heh... thanks for all of you help shmonkey, BUT I GOT IT WORKING!

after all this time it was crappy ati drivers... i went into their make.sh file and rewrote a lot of the crap that they had in there.... i'll be sure to document it and post it on here....
 
Old 12-03-2004, 08:39 AM   #20
shmonkey
Member
 
Registered: Nov 2004
Location: UK
Distribution: Ubuntu
Posts: 118

Rep: Reputation: 15
NICE
 
Old 12-03-2004, 11:49 AM   #21
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
please do post the fix..
i know i run slackware not debian.. but if i can get GL working with my POS ATI that would rock.

l8r
 
Old 12-03-2004, 11:56 AM   #22
initialdrifteg6
Member
 
Registered: Sep 2004
Location: France, Kentucky
Distribution: debian
Posts: 173

Original Poster
Rep: Reputation: 38
run ./make.sh under build_mod and post results
 
Old 12-03-2004, 04:31 PM   #23
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
dude, post ur modded make.sh so others can benefit from it.
 
Old 12-03-2004, 06:11 PM   #24
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
ok...
i didn't see a 'build_mod' directory, nor a 'make.sh'
i have the :
radeon-20040930-linux.i386.tar.gz
which extracts to a
dripkg
directory that contains an 'install.sh'
did you get a different driver?
i ran the install.sh.. and it seemed to go good.. but maybe i have a different driver...
what is the driver called that you got?
 
Old 12-03-2004, 06:15 PM   #25
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
this is my dmesg:
Linux version 2.4.26 (root@tree) (gcc version 3.3.4) #6 Mon Jun 14 19:07:27 PDT 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 0000000000100000 - 000000000ffe2800 (usable)
BIOS-e820: 000000000ffe2800 - 0000000010000000 (reserved)
BIOS-e820: 00000000feda0000 - 00000000fee00000 (reserved)
BIOS-e820: 00000000ffb80000 - 0000000100000000 (reserved)
255MB LOWMEM available.
On node 0 totalpages: 65506
zone(0): 4096 pages.
zone(1): 61410 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=Linux ro root=303
Initializing CPU#0
Detected 996.711 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 1985.74 BogoMIPS
Memory: 255948k/262024k available (1844k kernel code, 5688k reserved, 618k data, 120k init, 0k highmem)
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU: After generic, caps: 0383f9ff 00000000 00000000 00000000
CPU: Common caps: 0383f9ff 00000000 00000000 00000000
CPU: Intel(R) Pentium(R) III Mobile CPU 1000MHz stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfbfee, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
Transparent bridge - Intel Corp. 82801BAM/CAM PCI Bridge
PCI: Discovered primary peer bus 08 [IRQ]
PCI: Using IRQ router PIIX/ICH [8086/248c] at 00:1f.0
PCI: Found IRQ 11 for device 00:1f.1
PCI: Sharing IRQ 11 with 02:00.0
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
Journalled Block Device driver loaded
vesafb: framebuffer at 0xe0000000, mapped to 0xd080d000, size 1536k
vesafb: mode is 1024x768x8, linelength=1024, pages=20
vesafb: protected mode interface info at c000:5378
vesafb: scrolling: redraw
Console: switching to colour frame buffer device 128x48
fb0: VESA VGA frame buffer device
pty: 512 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
PCI: Found IRQ 11 for device 00:1f.6
PCI: Sharing IRQ 11 with 00:1f.5
Real Time Clock Driver v1.10f
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 7777K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH3M: IDE controller at PCI slot 00:1f.1
PCI: Enabling device 00:1f.1 (0005 -> 0007)
PCI: Found IRQ 11 for device 00:1f.1
PCI: Sharing IRQ 11 with 02:00.0
ICH3M: chipset revision 1
ICH3M: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xbfa0-0xbfa7, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0xbfa8-0xbfaf, BIOS settings: hdcMA, hddio
hda: HITACHI_DK23DA-20, ATA DISK drive
blk: queue c03b3360, I/O limit 4095Mb (mask 0xffffffff)
hdc: TOSHIBA DVD-ROM SD-C2502, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 39070080 sectors (20004 MB) w/2048KiB Cache, CHS=2432/255/63, UDMA(100)
hdc: attached ide-cdrom driver.
hdc: ATAPI 24X DVD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
Partition check:
hda: hda1 hda2 hda3 hda4
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
8regs : 1650.000 MB/sec
32regs : 951.200 MB/sec
pIII_sse : 2302.800 MB/sec
pII_mmx : 2228.000 MB/sec
p5_mmx : 2324.000 MB/sec
raid5: using function: pIII_sse (2302.800 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.8(17/11/2003)
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 120k freed
Adding Swap: 257032k swap-space (priority -1)
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: Detected Intel(R) 830M chipset
agpgart: AGP aperture is 256M @ 0xd0000000
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Intel ISA PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
PCI: Found IRQ 11 for device 02:01.0
PCI: Sharing IRQ 11 with 02:01.1
PCI: Found IRQ 11 for device 02:01.1
PCI: Sharing IRQ 11 with 02:01.0
Yenta ISA IRQ mask 0x06b8, PCI irq 11
Socket status: 30000006
Yenta ISA IRQ mask 0x06b8, PCI irq 11
Socket status: 30000010
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0820-0x08ff: excluding 0x828-0x837 0x840-0x84f 0x860-0x877 0x880-0x88f 0x898-0x89f 0x8a8-0x8cf 0x8e0-0x8ff
cs: IO port probe 0x0800-0x080f: excluding 0x800-0x80f
cs: IO port probe 0x03e0-0x04ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x0100-0x03af: excluding 0x280-0x287 0x378-0x37f
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
eth0: Xircom: port 0x300, irq 3, hwaddr 00:80:C7:3F:28:27
eth0: MII link partner: 41e1
eth0: MII selected
eth0: media 100BaseT, silicon revision 4
PCI: Found IRQ 11 for device 02:00.0
PCI: Sharing IRQ 11 with 00:1f.1
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
See Documentation/networking/vortex.txt
02:00.0: 3Com PCI 3c905C Tornado at 0xec80. Vers LK1.1.18-ac
00:06:5b:d8:ea:a6, IRQ 11
product code 0000 rev 00.6 date 11-12-01
Internal config register is 1840000, transceivers 0xa.
8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate interface.
MII transceiver found at address 24, status 782d.
Enabling bus-master transmits and whole-frame receives.
02:00.0: scatter/gather enabled. h/w checksums enabled
PCI: Found IRQ 11 for device 00:1f.5
PCI: Sharing IRQ 11 with 00:1f.6
PCI: Setting latency timer of device 00:1f.5 to 64
intel8x0_measure_ac97_clock: measured 49799 usecs
intel8x0: clocking to 48000
i810_rng: RNG not detected
hw_random: RNG not detected
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:1d.0
PCI: Sharing IRQ 11 with 01:00.0
PCI: Setting latency timer of device 00:1d.0 to 64
uhci.c: USB UHCI at I/O 0xbf80, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
 
Old 12-03-2004, 06:17 PM   #26
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
this is my glxinfo:
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_SGI_make_current_read, GLX_SGIS_multisample
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_visual_select_group
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGI_make_current_read,
GLX_SGIS_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_shadow, GL_ARB_shadow_ambient,
GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_func_separate, GL_EXT_blend_logic_op, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint, GL_EXT_copy_texture,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, GL_EXT_stencil_wrap,
GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
GL_EXT_vertex_array, GL_APPLE_packed_pixels, GL_ATI_texture_mirror_once,
GL_ATI_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square,
GL_NV_point_sprite, GL_NV_texgen_reflection, GL_NV_texture_rectangle,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
GL_SGIX_shadow, GL_SGIX_shadow_ambient
glu version: 1.3
 
Old 12-03-2004, 06:30 PM   #27
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
ok.. ok.. ok...
so -now- i find the fglrx thing.. but i can only find it as .rpm... this may be OK.. i know i have support for them.. (although i -much- prefer source code) so i'm assuming i simply have the -wrong- driver.
so i'm going to do my best to get this elusive fglrx thing.. and i will post results..
 
Old 12-03-2004, 06:56 PM   #28
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
ok...
now. i got the rpm.. turned it into a source and used slackware pkgtool to install it...
found the build_mod/make.sh and got this:
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
firegl_public.c:207:1: warning: "pte_unmap" redefined
firegl_public.c:140:1: warning: this is the location of the previous definition
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================



then went to {..} and did the ./make_install.sh and got:
x# ./make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: init_module: No such device
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.

... so now what?
thanks.
 
Old 12-03-2004, 07:05 PM   #29
soylentgreen
Member
 
Registered: Sep 2004
Location: old village
Distribution: android, BSD, CentOS, Ubuntu
Posts: 221

Rep: Reputation: 30
btw... i think i have Xorg.. not Xfree86...
is that bad?
 
Old 12-03-2004, 08:40 PM   #30
initialdrifteg6
Member
 
Registered: Sep 2004
Location: France, Kentucky
Distribution: debian
Posts: 173

Original Poster
Rep: Reputation: 38
Quote:
Originally posted by zero79
dude, post ur modded make.sh so others can benefit from it.
dude... it's compiled specifically for my kernel and setup... i am willing to help people troubleshoot their shit... punk... how was karaoke the other night...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
what does OpenGL do? servnov General 7 11-17-2004 01:53 PM
Overwrite Mesa OpenGL with ATI OpenGL Carl-Fredrik Slackware 12 10-01-2004 03:33 PM
Changing from MESA OpenGL to ATI OpenGL tillyoubreakit Linux - Hardware 19 10-07-2003 07:32 PM
OpenGL is needed by plib-1.7.0- but i have opengl ! qwijibow Linux - Newbie 0 08-05-2003 07:12 AM
Where is OpenGL SherylGlas Linux - Newbie 2 03-21-2003 04:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration