-   Debian (
-   -   Onborad sound donīt work!!! HELP (

GSX 02-14-2005 02:22 AM

Onborad sound donīt work!!! HELP

my sound donīt work
In KDE I I selected ALSA but I get the error "Cannot load sound module..."

I run Debian Sarge with kernel 2.6.6-1.

My motherboard is an

ASUS P4P8X with onboardsound:

--- Audio ADI AD1985 SoundMAX 6-channel CODEC -----

When I boot-up debian Linux load the sound module ACī97 successfully, but itīs the wrong module.

Is there a SoundMax-driver available for Debian?
Or have somebody the same problems?

Please help..

vharishankar 02-14-2005 02:56 AM

You must manually load the module i810_audio.

Become root then type in a terminal.


modprobe i810_audio
To load the module every time you boot you need to run some command which I forget now. I'll try to find it out for you. Meanwhile you can load the module by hand.

vharishankar 02-14-2005 03:06 AM

Ah found the command.


as root to automatically configure to load the modules at startup.

GSX 02-14-2005 03:18 AM

First thanks a lot for your fast reply :-)

Iīm not 100% sure but I think my debian system also loads the i810_audio module at startup.
But Linux said something about ID=0 ???
But I donīt know what that means...

Maybe the problem that Linux loads both audio modules???
In case Linux loads the i810 module correctly, what can be the reason that my sound donīt work?
Where can I check it out?

vharishankar 02-14-2005 03:37 AM

Go as root and type

and paste the results here.

Also open KDE Control Center -> Sound and Multimedia -> Sound System.

Tell us the options selected and whether the sound system is enabled or not.

GSX 02-14-2005 03:55 AM


I paste the results here for you...

But I can only post it tommorrow because I donīt have internet at home, ok?

Thanks in advance

HalfDiminished 02-14-2005 06:42 AM

Quick note - KDE by default uses the arts sound server. This needs to be turned off to free up the sound services for alsa. In the configuration gui (control center?) on the KDE menu, there is a 'sound' section. Look in there to find how to disable arts.

GSX 02-14-2005 08:29 AM

Hi, I was at home and hereīs my lsmod :

Module Size Used by
ds 18500 0
yenta_socket 21376 0
pcmcia_core 67620 2 ds,yenta_socket
snd_intel8x0 34952 0
snd_ac97_codec 65188 1 snd_intel8x0
snd_pcm 98148 1 snd_intel8x0
snd_timer 25380 1 snd_pcm
snd_page_alloc 11460 2 snd_intel8x0,snd_pcm
gameport 4704 1 snd_intel8x0
snd_mpu401_uart 7968 1 snd_intel8x0
snd_rawmidi 24704 1 snd_mpu401_uart
snd_seq_device 8200 1 snd_rawmidi
snd 54692 7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
i810_audio 33844 0
ac97_codec 18956 1 i810_audio
soundcore 10336 2 snd,i810_audio
i8xx_tco 6964 0
hw_random 5460 0
ehci_hcd 29988 0
uhci_hcd 31632 0
usbcore 108060 4 ehci_hcd,uhci_hcd
shpchp 102220 0
pciehp 102412 0
pci_hotplug 36400 2 shpchp,pciehp
intel_agp 18556 1
intel_mch_agp 10576 0
agpgart 34152 2 intel_agp,intel_mch_agp
evdev 9536 0
capability 4100 0
commoncap 7200 1 capability
ide_cd 43268 0
cdrom 40384 1 ide_cd
rtc 12760 0
xfs 622232 0
reiserfs 236656 0
vfat 14656 0
fat 46624 1 vfat
isofs 35416 0
ext2 72456 0
ext3 126184 1
jbd 62008 1 ext3
mbcache 9348 2 ext2,ext3
ide_disk 19872 3
ide_generic 1408 0
piix 13696 1
ide_core 149696 4 ide_cd,ide_disk,ide_generic,piix
unix 28560 6
font 8320 0
cfbcopyarea 3840 0
cfbimgblt 3040 0
cfbfillrect 3776 0

In KDE my sound is activated, but when I select ALSA, I get the error that the sound module cannot be loaded!!!


vharishankar 02-14-2005 09:37 AM

Try the Open Sound System option in KDE Sound System audio device option in the Hardware tab.

GSX 02-14-2005 09:45 AM

OK I try but whatīs about the

ACī97 and i810_audio modules?

I donīt need both modules, donīt I?

GSX 02-15-2005 02:04 AM


when I select OSS instead of ALSA I get the same error
<Cannot load sound module>.

When I run "update-modules", is it also possible to remove modules from the automatically start-up?

f1dave 02-16-2005 01:40 AM

Damn this problem comes up all the time.

From memory, i used to have the same problem until a more recent copy of sarge detected everything nicely. (I've got an ASUS board too- ANK8E or something [hell i'm at work and it's got a random abbreviated name i can't remember]) But i remember messing around with AC97, i810 etc... and i also remember finding the answer at that wonderful repository of complaining linux users that is google :P

So yeah, go there and search your onboard sound with "no sound" or something in a google linux search and i'm sure you'll find something. Hell, i'm sure you'll get some results doing a similar search here.


GSX 02-16-2005 02:11 AM


Yesterday I read my kern.log...


Feb 15 16:09:06 lowrider kernel: Intel 810 + AC97 Audio, version 0.24, 15:59:45 May 12 2004
Feb 15 16:09:06 lowrider kernel: PCI: Setting latency timer of device 0000:00:1f.5 to 64
Feb 15 16:09:06 lowrider kernel: i810: Intel ICH5 found at IO 0xee80 and 0xe800, MEM 0xfebff800 and 0xfebff400, IRQ 17
Feb 15 16:09:06 lowrider kernel: i810: Intel ICH5 mmio at 0xf894c800 and 0xf89e3400
Feb 15 16:09:06 lowrider kernel: i810_audio: Primary codec has ID 0
Feb 15 16:09:06 lowrider kernel: i810_audio: Audio Controller supports 6 channels.
Feb 15 16:09:06 lowrider kernel: i810_audio: Defaulting to base 2 channel mode.
Feb 15 16:09:06 lowrider kernel: i810_audio: Resetting connection 0
Feb 15 16:09:06 lowrider kernel: i810_audio: Connection 0 with codec id 0
Feb 15 16:09:06 lowrider kernel: ac97_codec: AC97 Audio codec, id: ADS117 (Unknown)
Feb 15 16:09:06 lowrider kernel: i810_audio: AC'97 codec 0 supports AMAP, total channels = 6

When I select the ALSA-driver:


Error-message: "Error while initializing the sound driver:
device: default canīt be openend for playback (No such file or directory)
The sound server will continue, using the null output device

I deactivated aRts... but no sound

When I select the OSS-driver:
No error but also no sound.

What can I do?

vharishankar 02-16-2005 03:21 AM

If you selected your OSS driver and you get no error message, did you run the volume control (kmix) to set the volume correctly?

Also if you want ALSA, make sure the ALSA kernel modules are installed (not installed by default I think in kernel 2.4). Just go to synaptic and search for ALSA and install the relevant ALSA kernel module.

GSX 02-16-2005 05:31 AM

I configured kmix, I think itīs correctly set-up.

There is something weird:

The first time I selected OSS I got an error:
"Cannot find /dev/dsp*"

Then I selected ALSA: I wrote the error above.

Then I selected OSS again and I didnīt get an error (And I didnīt click to : DO NOT SHOW AGAIN THIS MESSAGE)

All times are GMT -5. The time now is 10:09 PM.