-   Debian (
-   -   NVidia drivers not working, causing freezes? (

eurleif 11-18-2004 03:34 PM

NVidia drivers not working, causing freezes?
I'm running Debian Sarge with Linux 2.6.8, KDE 3.2.3, and XFree86 4.3.0 on a system with a GeForce FX 5500. When I installed NVidia drivers (using Andrew's Debian-nVidia HOWTO), glxgears worked and appeared accelerated; however, every other OpenGL application I tried either displayed a black screen or wouldn't start at all. In addition, the entire system would freeze -- mouse movement worked, but that was it -- after just a few minutes of being turned on. What might be going on here?

darkleaf 11-18-2004 03:39 PM

Do you think there's a problem with using the proprietary drivers made by NVidia self?

wellmt 11-19-2004 08:42 AM

Wow never read that HOWTO. Seems like a long way of doing it to me. I got my NVIDIA drivers working by simply recompiling the kernel and then installing the NVIDIA driver using the bog-standard NVIDIA installer from the NVIDIA website. Not had a single stability issue.

I've got the same set-up as you too (KDE 3.2, XFree 4.3, Kernel 2.6.8.

drawhla 11-19-2004 09:13 AM

I had the same problem I was caused by agpgart loading the wrong drivers, check your /etc/modules (post it just in case), you should have agpgart and nvidia-agp
thats the combination that worked for me

eurleif 11-19-2004 06:31 PM

Thanks for the help, everyone. I tried adding nvidia-agp and agpgart to /etc/modules, but that didn't seem to help.

Just in case, here's /etc/modules:

# /etc/modules: kernel modules to load at boot time.
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.


drawhla 11-19-2004 10:30 PM

switch the order
put first agpgart and then nvidia-agp
that should do it

eurleif 11-20-2004 12:25 AM

Thanks a lot for trying, but that doesn't seem to have worked; it still freezes. Any other ideas?

darkleaf 11-20-2004 04:31 AM

You could use the official nvidia drivers?

eurleif 11-20-2004 05:19 AM

I've tried the official NVidia installer; doesn't seem to change anything. Thanks a lot for trying to help, though.

Now I'm wondering if it might be just be over-heating. Would the cursor still be movable in that case, though? Is there an easy way to check the temperature of my card?

dmigh 11-20-2004 07:54 AM

how much different performance with nvidia driver?

i am using nvidia vga. but no nvidia-driver.

zero79 11-21-2004 12:14 AM

you're going to get much better 3d performance and video rendering/playback.

you need to make sure that the glcore and dri modules are not being loaded in "/etc/X11/XF86Config-4"

i would suggest using the nvidia installer from nvidia's site. it's much easier than that link.

thegsusfreek 11-22-2004 12:58 AM

A few things to try:

Right when your system boots up, run "dmesg" from a prompt and see if you see anything about NVIDIA drivers or AGP failing.

Go to /proc/driver/nvidia/agp/status and see if agp is indeed enabled. There may be an error there.

Then, just out of curiousity, what is your glxgears framerate? It should be over 1000 FPS.

Lastly, you can check "glxinfo" and make sure that direct-rendering is enabled.

These are just solutiong to some of the more common problems. Thanx.

urka58 11-22-2004 10:53 AM

What version of nvidia driver did you installed? It seems the latest version has problems with 2.6 kernel series.
I've succesfully installed nvidia-ver-6111 on my freshly installed Debian (2.4.27). The problem I found is the driver did not compile because of a "bug" in the Debian kernel. After a simple patch on the nvidia driver it is working properly.
I've also added the line
just after agpgart in my /etc/modules.preload.
Hope this helps

thegsusfreek 11-22-2004 02:34 PM

I'm using the latest driver with a 2.6.5 kernel. Works fine. I did have to update my kernel from a previous 2.6.4 using Y.O.U.

cgltower 12-17-2004 04:22 AM

GLX issue
i got 1-0-6629 nvidia drivers for 6600gt agp card.

My issue is that GLX seems to fail on X startup

I just got kernel modules nvidia, agpgart and sis-agp to work (thru 'cat /proc/driver/nvidia/agp/status'). All libGL files seems to be inplace. But X will not load (through 'startx). It will load if i comment "glx" out of the modules section of /etc/X11/XF86config-4

So i figure there is a problem with GLX. glxinfo wont run (coz it never initialises). X crashes with 'caught signal 11' and no helpful EE messages in X log.

I had kernel 2.6.5-1-686 testing and have upgraded to 2.6.8-1-686 which fixed the agp to work.

All times are GMT -5. The time now is 01:25 AM.