LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-30-2003, 11:49 AM   #1
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Rep: Reputation: 15
nvidia driver installation


I know there are already several topics about this problem. But there isn't a clear answer in any of them.

I now have suse linux installed on my machine with the nvidia drivers. The nvidia driver installation was very simple. First install the kernel-source of your kernel witch could be done by Yast2. Then launch the nvidia driver installer downloaded from the nvidia site (NVIDIA-Linux-x86-1.0-4496-pkg2.run).

Now i want to install debian on the same system. Can I install the nvidia drivers the same way as i did in suse or are there other things i have to do. So can i install the kernel source with dselect and then simply run NVIDIA-Linux-x86-1.0-4496-pkg2.run? I want to install linux debian 3.0 with kernel 2.4!

Does debian install Xfree automaticly, if so does it install the right version for the nvidia driver to work? If not how and in what order do i need to install all this inclusief gnome?

Last edited by simonwindt; 10-30-2003 at 11:56 AM.
 
Old 10-30-2003, 12:31 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Should be able to install the drivers the same way. But you actually intalled them wrong in suse

In suse your just supposed to run online update, and check the box next to "NVIDIA DRIVERS".. lol
 
Old 10-30-2003, 04:04 PM   #3
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
So i don't need to replace the kernel source files? I thought i read that somewhere.

And i have to complie the kernel to don't I. I forgot to mention it before but i did it also in Suse. Can i do that in Debian the same way:
cd /usr/src/linux
make cloneconfig && make dep

And on more thing, I installed the nvidia driver in Suse like it said in the howto of suse (ftp://ftp.suse.com/pub/suse/i386/sup...ler-HOWTO.html)
I was using suse linux 8.2.

Last edited by simonwindt; 10-31-2003 at 03:52 AM.
 
Old 10-31-2003, 04:38 AM   #4
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
I installed unpakked the kernel-source and it's now in /usr/src/ .
How can i install and configure it so that the nvidia installed can use it?
The suse way didn't work.
 
Old 10-31-2003, 05:15 AM   #5
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
the only things you have to do is to install the kernel headers for your kernel and then run the installer.

modify your /etc/X11/XF86Config-4 file

and that's all

Usually debian has problems configuring the X so, you could take the config file from the SuSE installation.
 
Old 10-31-2003, 05:16 AM   #6
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
now you can(I think) uninstall the kernel headers
 
Old 10-31-2003, 05:17 AM   #7
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
Ok problem solleved.
This is what I did:
apt-get install kernel-headers-'uname -r'
sh NVIDIA-Linux-x86-1.0-4363.run --kernel-include-path=/usr/src/kernel-headers-2.4.18-bf2.4/include/
But I think that Knoppix kernel headers may not be available...
The thing is that Debian store kernel headers at /usr/src/kernel-headers-VERSION

found it on an other forum

Only now my system hangs when I startx. Wich is proberbly a result of a wrong Xfreeconfig because i didn't had this problem in suse.
 
Old 11-03-2003, 02:30 AM   #8
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
OK i can't get the problem fix the problem that x hangs when i start it. X starts at startup and i don't now how to disable that. Which is probably very simple just edit a file but I don't now which one. But even if I knew how I couldn't edit it because my system now hangs at startup

Is there any way to boot my system in recovery mode? Maybe with the debian cd? So that I can disable X at startup.
 
Old 11-03-2003, 09:51 AM   #9
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
Kick

I deleted a symlink so that x doesn't start at startup. Only i can't find the problem why x hangs when i start it.
this is my Xfreeconfig:

### BEGIN DEBCONF SECTION
# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.
#
# To change things within the debconf section, run the command:
# dpkg-reconfigure xserver-xfree86
# as root. Also see "How do I add custom sections to a dexconf-generated
# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "extmod"
Load "freetype"
Load "glx"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-68
VertRefresh 50-85
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1152x864"
EndSubSection
SubSection "Display"
Depth 4
Modes "1152x864"
EndSubSection
SubSection "Display"
Depth 8
Modes "1152x864"
EndSubSection
SubSection "Display"
Depth 15
Modes "1152x864"
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

### END DEBCONF SECTION
 
Old 11-04-2003, 01:19 AM   #10
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
The way to disable X to start at boot time is to modify /etc/inittab deafult runlevel from 5 to 3.


to boot up as single user (some kind of recovery, or better "safe mode") would be to enter

Code:
name_of_kernel_in_lilo init 1
where name_of_kernel_in_lilo would be the string that appears in /etc/lilo.conf at the zone that includes the vmlinuz-2.x.x-xxx string (usually the string is "Linux")
 
Old 11-04-2003, 02:54 AM   #11
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
Unhappy

change the default run level to 3 won't work. Debain will still start xdm. There is a symlink in /etc/rc2.d/ called S99xdm. If you delete that synlink xdm will no longer be started at startup. debian starts everything in the rc2.d folder.

So i already solved that problem. I also solved the problem of x hanging at startup, it had something to do with my usb mouse. I now configured it with an ps2 and it runs.

Only now i cant get out of x properly. If i do ctrl+alt+bcksp it hangs. When i type shutdown -h now in a shell it hangs. alt+f2 it hangs
Didn't find the solution for that yet, but i will post it here if i founded it.
 
Old 11-04-2003, 05:05 AM   #12
simonwindt
LQ Newbie
 
Registered: Oct 2003
Location: Netherlands
Distribution: Debian Woody 3.0
Posts: 22

Original Poster
Rep: Reputation: 15
Unhappy

Can't find the solution. Does anywone have any idee how to solve this?

I found the solution! I needed to plug my tv connector out. It's a know error in the nvidia drivers!

Last edited by simonwindt; 11-05-2003 at 04:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA driver installation woopud Slackware 4 10-01-2005 09:28 AM
Nvidia Driver Installation redhatbadboi Fedora 7 02-13-2005 05:55 PM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 09:45 AM
Nvidia driver installation help... visualblind Linux - Software 8 08-07-2004 02:34 PM
NVIDIA driver installation Dave Johnston Linux - General 2 10-31-2001 12:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration