LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   NordVPN (v3) doesn't work on Debian (v10.3) (https://www.linuxquestions.org/questions/debian-26/nordvpn-v3-doesnt-work-on-debian-v10-3-a-4175674003/)

JDLandre 04-26-2020 04:55 AM

NordVPN (v3) doesn't work on Debian (v10.3)
 
I'm trying to get the most recent version of NordVPN (3.7.1) to work on Debian Buster (10.3). Downloading and installing works fine, just as loging into NordVPN and setting options and making a connection to NordVPN. But after I have done so, NordVPN will not allow me to access any site on internet. As soon as I disconnect from NordVPN I can access internet again.

When I connect with an old version of NordVPN (2.2.1) everything works fine and I can access everything I want on internet, but when I install the old version I get the advice to upgrade to the most recent version (which doesn't work for me).

Recently I installed NordVPN (3.7.1) on LMDE4 (Linux Mint version 4 based on Debian 10) and there NordVPN was working just fine on the same machine as I run Debian Buster on. And I cannot find any big differences between the installation of LMDE4 and Debian Buster.

NordVPN customer service is aware of this issue, but cannot seem to solve it.

Anyone with a bright idea about solving this issue? It would be most welcome.

esteeven 04-27-2020 07:19 AM

Are you running Debian Buster and LMDE4 on the same laptop? LMDE4 uses - AFAIK - Buster. Do they share a /home directory? Do you use them as the same user?

JDLandre 04-27-2020 07:46 AM

Hi esteeven,
I'm running both Debian Buster (10.3) and LMDE4 from the same machine (HPE-510). It contains 2 hard disks. On one of them I installed Debian with full disk encryption and on the other I've installed LMDE4 with full disk encryption. Apart from the fact that they are on the same machine, they do not share anything. I even have a different user for them.

Here's a little more hardware info from inxi:
Machine: Type: Desktop System: Hewlett-Packard product: HPE-510nl v: 1.04 serial: <root required>
Mobo: PEGATRON model: 2AB6 v: 1.04 serial: <root required> UEFI: AMI v: 7.08 date: 02/16/2011
Memory: RAM: total: 7.77 GiB used: 2.07 GiB (26.7%)
RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU: Topology: Quad Core model: Intel Core i7-2600 bits: 64 type: MT MCP L2 cache: 8192 KiB
Speed: 1744 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1596 2: 1597 3: 1597 4: 1597 5: 1598 6: 1597 7: 1597
8: 1597
Drives: Local Storage: total: 4.55 TiB used: 1.84 TiB (40.5%)
ID-1: /dev/sda vendor: Hitachi model: HDS722020ALA330 size: 1.82 TiB
ID-2: /dev/sdb vendor: Toshiba model: DT01ACA300 size: 2.73 TiB

Hope this helps.
Thanks for looking into this.

shruggy 04-27-2020 08:01 AM

Quote:

Originally Posted by JDLandre (Post 6115991)
And I cannot find any big differences between the installation of LMDE4 and Debian Buster.

I'm sure there're no differences at all: it's one and the same NordVPN deb package for any Debian-based distribution.

But the systems themselves (Debian Buster and LDME4) may be configured differently. Have you tried to connect manually?

JDLandre 04-27-2020 10:55 AM

Hi shruggy,

Thanks for digging into this as well.

I just tried to connect manually from Debian with NordVPN 2.2.0-3 installed and with NordVPN 3.7.1 installed. And in both cases manually connecting OpenVPN in line with the suggestions given look to work from the terminal, but ends up with a system unable to resolve any web-server-id (like: NordVPN.com).

I checked the contents of /etc.resolv.conf and saw they were not changed by OpenVPN (or NordVPN); so they contained the dns-names of my local ISP.

As soon as I interrupted the terminal with Ctrl+C, the web-server-id's were resolved by the dns-servers of my local ISP again and I can access internet again.

Any further ideas?

shruggy 04-27-2020 12:57 PM

Well, there're many ways to configure DNS on Linux nowadays.

NordVPN recommends doing it traditionally, by editing /etc/resolv.conf. If doing it this way don't forget to protect the file from being overwritten by Network Manager with chattr +i. This will have some unwanted side effects on Debian though as explained in Debian Wiki. Also see Defining the (DNS) Nameservers there.

Others recommend doing it via resolvconf or via Network Manager GUI.

JDLandre 04-28-2020 09:27 AM

Okay, I'verun NordVPN 2.2.0-3 on Debian with nameservers 103.86.96.96 / 103.86.99.99 and with nameservers 103.86.96.100 / 103.86.99.100 and in both cases release 2.2.0-3 runs fine.

I also ran NordVPN 3.7.1 on Debian with nameservers 103.86.96.96 / 103.86.99.99 and with nameservers 103.86.96.100 / 103.86.99.100 and in both cases release 3.7.1 blocks all my internet traffic.

So, I think it has nothing to do with the DNS servers.

The main difference I see between NordVPN 2.2.0-3 and NordVPN 3.7.1 is that release 2.2.0-3 does NOT de-activate my UFW firewall and release 3.7.1 does de-activate my UFW firewall. It states so on start-up. As far as I know all rules from UFW should at that time be copied to the NordVPN firewall, but I highly doubt this works correctly, because apart from traffic to and from NordVPN's own servers all other traffic is blocked.

The setup for Windows states there should be 6 specific rules in Windows firewall to allow NordVPN to work (https://support.nordvpn.com/Connecti...figuration.htm). So, I suspect there should be specific rules in my UFW-firewall for NordVPN to work, after it has copied those rules to the NordVPN firewall.

JDLandre 04-29-2020 11:01 AM

I could not find a way to see what rules NordVPN copied into its firewall or not. But today I got a suggestion from NordVPN Helpdesk to try NordLynx. And actually NordVPN 3.7.1 works well on Debian 10.3 when I did set Technology=NordLynx. This is possible since Wireguard is incorporated in the Linux-kernel of Debian 10.3 since about a month now. NordLynx is still a work in progress as NordVPN states (like Wireguard in Linux-kernel is as well), but it works for me.


All times are GMT -5. The time now is 06:01 PM.