-   Debian (
-   -   no video or sound on debian lenny (

biharibong 02-20-2009 07:09 PM

no video or sound on debian lenny
I had everything working on etch and after lenny things have stopped working. First I did an upgrade and I had the same problem, then I figured if I did a clean install it would be fixed. But I have the same problems. I have posted something similar before, but I unsubscribed and I don't know how to subscribe back

Before I start here's whats in my sources.list


deb lenny main contrib non-free
deb-src lenny main contrib non-free

deb lenny/updates main contrib non-free
deb-src lenny/updates main contrib non-free

deb lenny/volatile main contrib
deb-src lenny/volatile main contrib

deb sid main
On viewing videos online (youtube, dailymotion etc..) the video loads and only plays (without sound) for a few seconds and then freezes. This happens after I installed the package 'flashplayer-mozilla' using synaptic. Before that with the pre loaded flash player I would get a big 'play button' and the video did not load. On viewing divx vidoes, the video loads but does not play.

Here are my list of plugins:


Shockwave Flash
File name:
Shockwave Flash 10.0 r15

DivX Browser Plug-In
File name:
mplayerplug-in 3.55

QuickTime Plug-in 7.4.5
File name:
mplayerplug-in 3.55

RealPlayer 9
File name:
mplayerplug-in 3.55

Windows Media Player Plug-in
File name:
mplayerplug-in 3.55

mplayerplug-in 3.5
File name:
mplayerplug-in 3.55

Java(TM) Plug-in 1.6.0_12-b04
File name:
Java(TM) Plug-in 1.6.0_12
On viewing videos on my computer, neither vlc, mplayer nor totem work. On vlc the video loads, and is played, but the video does not load up. I am currently trying to fix things after a clean install, but when I had done an upgrade and trying to fix the same problem I had found a temporary way to make vlc work. I havent tried that as yet, since I figure the online and on computer media are rooted from the same problem.

Anyways this is what I had done to fix vlc


#: apt-get install libavcodec51=0.svn20080206-17 libavformat52=0.svn20080206-17
Something to do with downgrading and then adding lines to /etc/apt/preferences


Package: libavcodec51
Pin: version 0.svn20080206-17
Pin-Priority: 900

Package: libavformat52
Pin: version 0.svn20080206-17
Pin-Priority: 900
and then running command


rm -rf ~/.vlc
For sound I found instructions to run 'alsaconf'. Which works temporarily.

biharibong 02-20-2009 10:34 PM

I have found a temporary fix! Basically I have to run these steps every time I reboot. Hopefully someone can help me with something permenant

Before anything I followed instructions here.

The fix suggested for vlc is a one time thing though. Even though sound is an issue

Sound being the common issue, I ran

sudo alsaconf
'volume control error' shows up, which I reload at the end
Screen shows up, and I select my sound card > then I press ok to configure snd-atixp and modify /etc/modprobe.d/sound > then I get a message saying that my sound card was configured

back on the command prompt, I run

sudo alsamixer
I dont make any changes here, but I still have to run it in order for the sound and video to work. Don't know why but it works. Then I just close the window

Now everything works: divx, flash, sound, movie player

On restart: no sound, no divx or flash, and movieplayer plays video in slow motion

jdkaye 02-21-2009 07:13 AM

Once you have rebooted and got the sound working again type this at the console:

sudo alsactl save
That should make your sound work the next time you reboot.
You need to have the package alsa-utils installed.

biharibong 02-21-2009 12:00 PM

alsactl store did not work. Figured that is what you meant. I found another forum suggesting the same thing, and then requiring to type alsa restore on every reboot. The final solution was to add the alsa restore line to /etc/rc.d/rc.local. I did not try that since alsa restore did not work either.

I did find that I have two sound devices detected before I perform alsaconf and alsamixer. And once run it is restored I am left with the correct sound card. I had felt that this was my main problem. The other sound device was my modem. Even though I could not figure out how to remove, I did however figure out how to blacklist it

edit /etc/modprobe.d/blacklist
and enter the lines

blacklist snd-atiixp-modem
Problem is not resolved

BigVig 02-21-2009 05:44 PM


Originally Posted by biharibong (Post 3452391)
alsactl store did not work.
Problem is not resolved

I had the same problem after I installed my webcam and skype. The links in the linked post led me to the answer.

biharibong 02-23-2009 05:50 PM

I still couldn't get it to work.

The links talk about setting the order on /etc/modprobe.conf: -

options snd_atiixp index=0
options snd_pcsp index=1
options snd_atiixp_modem index=2
On the other hand I did discover that my pc speaker was loading first on /proc/asound/cards. ON changing the order it was resolved to this on reboot

ATI IXP rev 0 with ALC202 at 0xe8004400, irq 17
1 [pcsp ]: PC-Speaker - pcsp
Internal PC-Speaker at port 0x61
2 [Modem ]: ATIIXP-MODEM - ATI IXP Modem
ATI IXP Modem rev 1 at 0xe8004800, irq 17
On doing alsaconf and alsamixer, it then looked like

ATI IXP rev 0 with ALC202 at 0xe8004400, irq 17
So with my working sound, pc speaker and my modem sound don't exist. Any way I could maintain that on every reboot

biharibong 02-23-2009 06:17 PM

Even though there are no changes when I have to start up my sound on every reboot. I did see some errors and warnings after making the changes above.

atiixp codec read timeout

and another warning mentioned something about not having /etc/modprobe.d/! even though /etc/modprobe.conf exists

All times are GMT -5. The time now is 07:26 PM.