-   Debian (
-   -   No text in flash animations (

twsnnva 06-15-2004 11:37 PM

No text in flash animations
I am reposting this in the debian section since it seems to be specific to certian distros(debian included)

Debian/GNU Linux 2.6.5 i686 Sarge / Debian/GNU Linux 2.4.18 Sarge
Flashplayer Plugin 7.0.25 / Flashplayer Plugin 6.0.9
Mozilla Firefox .8 / Mozilla 1.4 / Mozilla 1.6 / Konqueror 3.2.2
KDE 3.2.2 / Gnome 2.4.1
Xfree86 4.3

I am having issues viewing text in flash animations. If I create an animation and use normal text then I cannot see the text, If I make the same text bold(but do nothing else), I can see it no problem. I have tried it with all of the combinations above and receive the same results with each. I don't have this issue on a Fedora Core 1 setup using the same versions of software. For my project using a bold font is a perfectly acceptable fix, however I would like to know what is causing this behavior. A site that does not display correctly is (The global links bar at the top of the page has no text). Also left clicking on a flash animation and bringing up the settings menu, (there is no text on the settings menu).
Does display correctly for any other Debian user?
Any suggestions? Thanks.

Dead Parrot 06-16-2004 09:11 PM

No complaints here. and flash animations show perfectly. Do you mean the bar that says Home Products Showcase etc.? Also the settings menu when mouse clicking (in my case right-click seems to work) shows OK.

I use Debian Sid, Linux 2.6.6-1-686, Firefox 0.8-12, Flashplugin 7.0.25-2, J2RE 1.4.1-6, WindowMaker 0.80.2-0.2, and XFree86 4.3.0.dfsg.1-4.

If you're having issues with Sarge, then perhaps you should upgrade to Sid? If this is your production machine and you're worried about stability in Sid, you can install apt-listbugs, which will warn you before installing packages with release-critical bugs filed against it.

twsnnva 06-16-2004 09:33 PM

Im upgrading to sid now. Thanks for the reply.

twsnnva 06-17-2004 10:44 PM

Well, I upgraded to sid and still get the same thing. I also downloaded KNOPPIX livecd and it works fine here. So it should work in Debian.

Dead Parrot 06-17-2004 11:01 PM

The versions don't actually change that much from Testing to Unstable. Perhaps you just need to install j2re to see the page properly?

Add this line to your /etc/apt/sources.list:

deb ./

Then install j2re1.4 using either apt-get or some frontend, such as Aptitude or Synaptic.

If you want java to work in Firefox, you also need to symlink the plugin:

# ln -s /etc/alternatives/ /usr/lib/mozilla-firefox/plugins

I can assure you that the web page shows perfectly in my Firefox.

Dead Parrot 06-17-2004 11:33 PM

I also have in /usr/lib/mozilla-firefox/plugins/ symlinks to /usr/lib/flashplugin-nonfree/flashplayer.xpt and to /usr/lib/flashplugin-nonfree/ but these symlinks were made automatically when installing the flashplugin-nonfree (which is located in Aptitude at the web/contrib directory).

twsnnva 06-17-2004 11:47 PM

Didn't figure that'd work but I tried it anyway, still dosen't work. Here's a screenshot of with the flash settings menu open. So far it works on Redhat9 and KNOPPIX for me, and Debian for others, but not on 3 seperate Debian boxes for me, stable, testing, or sid. This is becoming rather annoying. Parrot could you please post the output of:
#dpkg -l font* xfont* xfs*
and thanks for the help, at least I know it can work.

Dead Parrot 06-18-2004 12:08 AM

OK, here we go...

| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
ii fontconfig 2.2.2-2 generic font configuration library
un fontilus <none> (no description available)
ii xfonts-100dpi 4.3.0.dfsg.1-4 100 dpi fonts for X
ii xfonts-75dpi 4.3.0.dfsg.1-4 75 dpi fonts for X
un xfonts-abi <none> (no description available)
un xfonts-artwiz <none> (no description available)
ii xfonts-base 4.3.0.dfsg.1-4 standard fonts for X
un xfonts-cjk <none> (no description available)
un xfonts-cyrilli <none> (no description available)
ii xfonts-scalabl 4.3.0.dfsg.1-4 scalable fonts for X
un xfs <none> (no description available)

Hope this helps! :)

Dead Parrot 06-18-2004 12:28 AM

Ah, if it's a fonts issue, then I need to add that I have msttcorefonts installed (in Aptitude these are at graphics/contrib directory).

I've manually added the lines:

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

into /etc/X11/XF86Config-4.

I've also run (as root) "dpkg-reconfigure fontconfig", "dpkg-reconfigure libpango1.0-common", and "dpkg-reconfigure x-ttcidfont-conf".

Perhaps these actions affect the way that Firefox shows fonts in flash animations?

Dead Parrot 06-18-2004 12:58 AM

Can anyone else confirm my view? Please point your browser towards

and tell if you can see the text (Home Products Showcase etc.) in the grey upper bar, that doesn't show any text in this guy's screenshot.

Am I the only Debian user whose web browser shows text in flash animations?

twsnnva 06-20-2004 12:58 AM

It's working now. Ran dpkg-reconfigure libpango1.0-common and choose not to entrust font management to defoma. Again, thanks for the help parrot.

tyconmismatch 07-10-2004 01:45 PM

Still having font problems
I would like to add that I am still having the problem after following twsnnva's advice above, so it is not a catch-all. Maybe you have to do this before something else happens, or else you have to also do something else (some other reconfiguration perhaps)? I'll post something if I find a solution to my problem.

nemesis_rebirth 08-23-2004 05:37 PM

Same problem here ...

debian sid
kernel 2.4.22, 2.4.24 , 2.4.25, 2.6.1, 2.6.4, 2.6.5, 2.6.6 , 2.6.7 , (in fact all i tested, i often upgrade lol)
firefox , mozilla, all versions (including lasts 0.9.3 // 1.7.2)
flashplugin 6 , 7 all version tested , Xfree 4.3

flash animation show no text
i tried twsnnva tip, but it still sucks

I have a friend on debian sid too , he also has the problem

this really pisses me off ... if anyone has an idea?

tyconmismatch 08-29-2004 10:35 PM

My fonts have myseriously begun working recently in flash. I'm not sure if Macromedia has changed their menu, but another way to check is to right click on a flash animation and choose Settings (some animations do not allow this for some reason) - I know the text in the Settings dialog was not working before either, but it is now. I believe it happened after I installed a round of packages associated with the Eclipse IDE, which I believe included the gsfonts-x11 package. I also installed the latest Blackdown j2re1.4 and j2sdk1.4 for debian available unofficially, which you can get here. I have a list of packages I've installed by date and I can provide this if it will be helpful (my /var/cache/apt/archives/), but it doesn't seem to include the ones I installed with Eclipse for some reason.

nemesis_rebirth 08-31-2004 05:02 PM

i already have gsfonts-x11 installed, but i'll try installing eclipse, maybe it will install THE needed dependency ^^
i would be grateful if you'd provide me the list of all the packages you installed until it worked ;-)

All times are GMT -5. The time now is 09:30 PM.