-   Debian (
-   -   No space left on device (

edhe1 05-12-2011 08:27 AM

No space left on device
When I try 'apt-get --reinstall install kde' I get:

'The following packages have unmet dependencies:
kde: Depends: kde-full (>=5:66) but it is not going to be installed
linux-image-2.6-amd64: Depends: linux-image-2.6.32-5-amd64 but it is not going to be installed
Try 'apt-get -f install''

I tried the 'apt-get -f install' and got:

dpkg:error processing /var/cache/apt/archives/linux-image-2.6.32-5-amd64_2.6.32-31_amd64.deb (--unpack):
failed in write on buffer copy for backend dpkg-deb during './lib/modules/2.6.32-5-amd64/kernel/drivers/usb/atm/ueagle-atm.ko': No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Errors were encountered while processing:

Filesystem Size Use Mounted On
/dev/sda1 327m 86% /
tmpfs 976M 0% /lib/init/rw
udev 10M 2% /dev
tmpfs 976M 0% /dev/shm
/dev/sda9 289G 1% /HOME
/dev/sda8 1.9g 1% /tmp
/dev/sda5 20g 21% /usr
/dev/sda6 12g 16% /var

Dutch Master 05-12-2011 09:14 AM

Start aptitude (no args, it'll start in interactive mode) and clean the package cache. That should clear up space to re-install stuff. Next, you're advised to reconsider the disk layout, 20 and 16GB for /usr and /var respectively is quite overkill. Ideally /var should be a bit bigger then /usr as the latter holds primarily static stuff whereas /var holds variable amounts of data. (log-files!!) On my system, /usr is 4GB where /var is 5GB and so is /tmp. (to have room for the data of a DVD) The root (/) partition is about 10GB, allowing for the rest (there's a /boot partition too) except /home and swap.

alan_ri 05-12-2011 09:18 AM

OK, what were your adventures with aptitude exactly? Post;

fdisk -l
But it looks to me that you should increase / partition. That I believe will solve your problem with No space left on device....

edhe1 05-12-2011 09:26 AM

I cleaned the package cache. I still get the same error messages; and was still forced to try 'apt-get -f install'
I dramatically increased the sizes of my partitions because /usr was at 90% use. I will consider your suggestion, though; especially about /tmp.

edhe1 05-12-2011 09:40 AM

I acted on aptitudes suggestions (delete, mark automatic, upgrade, install) There was some 'A' files that I applied '-' to, to see if there was any dependencies; and if so I did Control-T. The ones that changed to 'd' as a result of my '-', I was not able to undo.

When using gparted I am blocked from changing the size of /.

edhe1 05-12-2011 09:56 AM

Device Boot Start End Blocks Id SYSTEM
/dev/sda1 * 1 43 345366 83 Linux
/dev/sda2 44 48641 390363435 5 Extended
/dev/sda5 695 3244 20478976 83 Linux
/dev/sda6 3244 4774 12288000 83 Linux
/dev/sda7 4744 5412 5120000 82 Linux swap / Solaris
/dev/sda8 5412 5667 2046976 83 Linux
/dev/sda9 5667 43911 307200000 83 Linux

countach74 05-12-2011 09:58 AM

You cannot resize a partition while it is mounted. If you boot to a rescue or live CD/USB, you will be allowed to change it. Just a reminder though, resizing partitions can lead to data corruption. I would encourage you to backup anything that may be important to you before you do any more partitioning.

jlinkels 05-12-2011 12:40 PM

Your root partition is too small and has too little space. Size 327M, filled 86% leaves... hmmm... 45MB. You need at least 70 MB for the /lib/modules/kernel-version.
So it is not /tmp or anything else.

If you have more obsolete kernels installed, you might remove them to free up space. I am not very fond of resizing partitions, especially when it is the root partition. If you have a second hard disk, you could partition it properly and copy over all your files to that one. Install a new boot loader and use that disk.


All times are GMT -5. The time now is 07:26 PM.